summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Alfredo da Silva <luis.adasilvaf@gmail.com>2020-09-15 23:11:22 +0000
committerAndrei Gherzan <andrei@gherzan.ro>2020-11-03 17:25:45 +0000
commitbc4b848a2beee2bf0d9312465f1e2dc876d66966 (patch)
treedef858530b682fc17689ac18d21f33132741e81d
parent2fca3a999b36299da44b679d0676a5e3ae3e07a4 (diff)
downloadmeta-raspberrypi-bc4b848a2beee2bf0d9312465f1e2dc876d66966.tar.gz
Revert "mesa: querying dma_buf modifiers for specific formats"
This reverts commit 84cb8538cd22586fc82daba38458909cedfec2db. Fixes: - https://gitlab.gnome.org/GNOME/mutter/-/issues/1421 - #711
-rw-r--r--recipes-graphics/mesa/files/0001-dri2-query-dma-buf-modifiers.patch43
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend4
2 files changed, 0 insertions, 47 deletions
diff --git a/recipes-graphics/mesa/files/0001-dri2-query-dma-buf-modifiers.patch b/recipes-graphics/mesa/files/0001-dri2-query-dma-buf-modifiers.patch
deleted file mode 100644
index 0bda014..0000000
--- a/recipes-graphics/mesa/files/0001-dri2-query-dma-buf-modifiers.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1mesa: querying dma_buf_modifiers for specific formats
2
3mesa wl_drm protocol is the backend for wayland server side which requires
4the dmabuf modifiers for some DRM formats on specific devices like RPI.
5Currently there is no support of giving any dmabuf modifiers on wl_drm protocol.
6This dma_buf modifiers allows EGL implementations to add extra attributes
7to drm_fourcc format.
8
9Upstream-Status: Pending
10
11Signed-off-by: Balaji Velmurugan <balaji.velmurugan@ltts.com>
12
13--- a/src/gallium/state_trackers/dri/dri2.c
14+++ b/src/gallium/state_trackers/dri/dri2.c
15@@ -1366,14 +1366,28 @@ dri2_from_planar(__DRIimage *image, int
16 return img;
17 }
18
19+static boolean
20+dri2_query_dma_buf_modifiers(__DRIscreen *_screen, int fourcc, int max,
21+ uint64_t *modifiers, unsigned int *external_only,
22+ int *count);
23 static __DRIimage *
24 dri2_from_fds(__DRIscreen *screen, int width, int height, int fourcc,
25 int *fds, int num_fds, int *strides, int *offsets,
26 void *loaderPrivate)
27 {
28+ uint64_t modifier= DRM_FORMAT_MOD_INVALID;
29+ unsigned int external_only= 0;
30+ int count= 0;
31+ boolean result;
32+ result= dri2_query_dma_buf_modifiers( screen, fourcc, 1, &modifier, &external_only, &count);
33+ return dri2_create_image_from_fd(screen, width, height, fourcc,
34+ modifier, fds, num_fds,
35+ strides, offsets, NULL, loaderPrivate);
36+ #if 0
37 return dri2_create_image_from_fd(screen, width, height, fourcc,
38 DRM_FORMAT_MOD_INVALID, fds, num_fds,
39 strides, offsets, NULL, loaderPrivate);
40+ #endif
41 }
42
43 static boolean
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index d3435e7..eaa46f2 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,10 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2# DRI3 note: 1# DRI3 note:
3# With oe-core commit 8509e2e1a87578882b71948ccef3b50ccf1228b3 dri3 is set 2# With oe-core commit 8509e2e1a87578882b71948ccef3b50ccf1228b3 dri3 is set
4# as default. To state out clearly that Raspi needs dri3 and to avoid surprises 3# as default. To state out clearly that Raspi needs dri3 and to avoid surprises
5# in case oe-core changes this default, we set dri3 explicitly. 4# in case oe-core changes this default, we set dri3 explicitly.
6
7SRC_URI_append_rpi = " file://0001-dri2-query-dma-buf-modifiers.patch "
8
9PACKAGECONFIG_append_rpi = " gallium vc4 v3d kmsro ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11 dri3', '', d)}" 5PACKAGECONFIG_append_rpi = " gallium vc4 v3d kmsro ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11 dri3', '', d)}"
10DRIDRIVERS_class-target_rpi = "" 6DRIDRIVERS_class-target_rpi = ""