summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-10-20 11:27:53 -0700
committerAndrei Gherzan <andrei@gherzan.ro>2020-11-03 17:25:57 +0000
commita47b0b1fd9a85b12c26a08570ca69424a7e10892 (patch)
treecbcd61f1c26ad4d3d16b3508f893cf4333c1f628
parentd14a9a499819c85539c858bfc79c6c2f9b04223e (diff)
downloadmeta-raspberrypi-a47b0b1fd9a85b12c26a08570ca69424a7e10892.tar.gz
linux-raspberrypi: Fix build regression from last update
This patch is now backported into 5.4 stable commit bc79abf4afea97d5ce682aa2bd1095fb74400916 so it should have been deleted, otherwise its causing build/patch failures now as expected Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-kernel/linux/files/0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch68
-rw-r--r--recipes-kernel/linux/linux-raspberrypi_5.4.bb1
2 files changed, 0 insertions, 69 deletions
diff --git a/recipes-kernel/linux/files/0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch b/recipes-kernel/linux/files/0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch
deleted file mode 100644
index 0d86947..0000000
--- a/recipes-kernel/linux/files/0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch
+++ /dev/null
@@ -1,68 +0,0 @@
1From 168200b6d6ea0cb5765943ec5da5b8149701f36a Mon Sep 17 00:00:00 2001
2From: Leo Yan <leo.yan@linaro.org>
3Date: Tue, 5 May 2020 21:36:42 +0800
4Subject: [PATCH] perf cs-etm: Move definition of 'traceid_list' global
5 variable from header file
6
7The variable 'traceid_list' is defined in the header file cs-etm.h,
8if multiple C files include cs-etm.h the compiler might complaint for
9multiple definition of 'traceid_list'.
10
11To fix multiple definition error, move the definition of 'traceid_list'
12into cs-etm.c.
13
14Upstream-Status: Backport [v5.8-rc1]
15
16Fixes: cd8bfd8c973e ("perf tools: Add processing of coresight metadata")
17Reported-by: Thomas Backlund <tmb@mageia.org>
18Signed-off-by: Leo Yan <leo.yan@linaro.org>
19Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org>
20Reviewed-by: Mike Leach <mike.leach@linaro.org>
21Tested-by: Mike Leach <mike.leach@linaro.org>
22Tested-by: Thomas Backlund <tmb@mageia.org>
23Cc: Alexander Shishkin <alexander.shishkin@linux.intel.com>
24Cc: Jiri Olsa <jolsa@redhat.com>
25Cc: Mark Rutland <mark.rutland@arm.com>
26Cc: Namhyung Kim <namhyung@kernel.org>
27Cc: Peter Zijlstra <peterz@infradead.org>
28Cc: Suzuki Poulouse <suzuki.poulose@arm.com>
29Cc: Tor Jeremiassen <tor@ti.com>
30Cc: linux-arm-kernel@lists.infradead.org
31Link: http://lore.kernel.org/lkml/20200505133642.4756-1-leo.yan@linaro.org
32Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
33---
34 tools/perf/util/cs-etm.c | 3 +++
35 tools/perf/util/cs-etm.h | 3 ---
36 2 files changed, 3 insertions(+), 3 deletions(-)
37
38diff --git a/tools/perf/util/cs-etm.c b/tools/perf/util/cs-etm.c
39index 3c802fde4954..c283223fb31f 100644
40--- a/tools/perf/util/cs-etm.c
41+++ b/tools/perf/util/cs-etm.c
42@@ -94,6 +94,9 @@ struct cs_etm_queue {
43 struct cs_etm_traceid_queue **traceid_queues;
44 };
45
46+/* RB tree for quick conversion between traceID and metadata pointers */
47+static struct intlist *traceid_list;
48+
49 static int cs_etm__update_queues(struct cs_etm_auxtrace *etm);
50 static int cs_etm__process_queues(struct cs_etm_auxtrace *etm);
51 static int cs_etm__process_timeless_queues(struct cs_etm_auxtrace *etm,
52diff --git a/tools/perf/util/cs-etm.h b/tools/perf/util/cs-etm.h
53index 650ecc2a6349..4ad925d6d799 100644
54--- a/tools/perf/util/cs-etm.h
55+++ b/tools/perf/util/cs-etm.h
56@@ -114,9 +114,6 @@ enum cs_etm_isa {
57 CS_ETM_ISA_T32,
58 };
59
60-/* RB tree for quick conversion between traceID and metadata pointers */
61-struct intlist *traceid_list;
62-
63 struct cs_etm_queue;
64
65 struct cs_etm_packet {
66--
672.25.1
68
diff --git a/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index f5e0a96..4a7182f 100644
--- a/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -8,7 +8,6 @@ require linux-raspberrypi_5.4.inc
8 8
9SRC_URI += "file://0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch \ 9SRC_URI += "file://0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch \
10 file://0002-Revert-selftests-bpf-Fix-perf_buffer-test-on-systems.patch \ 10 file://0002-Revert-selftests-bpf-Fix-perf_buffer-test-on-systems.patch \
11 file://0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch \
12 file://powersave.cfg \ 11 file://powersave.cfg \
13 file://android-drivers.cfg \ 12 file://android-drivers.cfg \
14 " 13 "