summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2020-08-06 11:53:27 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2020-08-10 11:10:11 +0100
commit7a2624d5ba0e9d7f8a4b5f120e1e13759373f652 (patch)
treebec737567716c4539621e25b7dc9b17ea5d33927
parentfc494a35b513b05860c5a813239274017f1ef934 (diff)
downloadmeta-raspberrypi-7a2624d5ba0e9d7f8a4b5f120e1e13759373f652.tar.gz
Revert "Generalize the naming of the bootfiles deploy directory"
This reverts commit a907c3261ef583f898803706cd596d372c6644cb.
-rw-r--r--classes/sdcard_image-rpi.bbclass4
-rw-r--r--conf/machine/include/rpi-base.inc8
-rw-r--r--recipes-bsp/bootfiles/bcm2835-bootfiles.bb (renamed from recipes-bsp/bootfiles/bootfiles.bb)2
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb142
-rw-r--r--recipes-kernel/linux/linux-raspberrypi.inc4
5 files changed, 78 insertions, 82 deletions
diff --git a/classes/sdcard_image-rpi.bbclass b/classes/sdcard_image-rpi.bbclass
index 1d876e4..43426b2 100644
--- a/classes/sdcard_image-rpi.bbclass
+++ b/classes/sdcard_image-rpi.bbclass
@@ -26,7 +26,7 @@ inherit image_types
26IMAGE_TYPEDEP_rpi-sdimg = "${SDIMG_ROOTFS_TYPE}" 26IMAGE_TYPEDEP_rpi-sdimg = "${SDIMG_ROOTFS_TYPE}"
27 27
28# Set kernel and boot loader 28# Set kernel and boot loader
29IMAGE_BOOTLOADER ?= "bootfiles" 29IMAGE_BOOTLOADER ?= "bcm2835-bootfiles"
30 30
31# Kernel image name 31# Kernel image name
32SDIMG_KERNELIMAGE_raspberrypi ?= "kernel.img" 32SDIMG_KERNELIMAGE_raspberrypi ?= "kernel.img"
@@ -114,7 +114,7 @@ IMAGE_CMD_rpi-sdimg () {
114 BOOT_BLOCKS=$(LC_ALL=C parted -s ${SDIMG} unit b print | awk '/ 1 / { print substr($4, 1, length($4 -1)) / 512 /2 }') 114 BOOT_BLOCKS=$(LC_ALL=C parted -s ${SDIMG} unit b print | awk '/ 1 / { print substr($4, 1, length($4 -1)) / 512 /2 }')
115 rm -f ${WORKDIR}/boot.img 115 rm -f ${WORKDIR}/boot.img
116 mkfs.vfat -F32 -n "${BOOTDD_VOLUME_ID}" -S 512 -C ${WORKDIR}/boot.img $BOOT_BLOCKS 116 mkfs.vfat -F32 -n "${BOOTDD_VOLUME_ID}" -S 512 -C ${WORKDIR}/boot.img $BOOT_BLOCKS
117 mcopy -v -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${BOOTFILES_DIR_NAME}/* ::/ || bbfatal "mcopy cannot copy ${DEPLOY_DIR_IMAGE}/${BOOTFILES_DIR_NAME}/* into boot.img" 117 mcopy -v -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/bcm2835-bootfiles/* ::/ || bbfatal "mcopy cannot copy ${DEPLOY_DIR_IMAGE}/bcm2835-bootfiles/* into boot.img"
118 if [ "${@bb.utils.contains("MACHINE_FEATURES", "armstub", "1", "0", d)}" = "1" ]; then 118 if [ "${@bb.utils.contains("MACHINE_FEATURES", "armstub", "1", "0", d)}" = "1" ]; then
119 mcopy -v -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/armstubs/${ARMSTUB} ::/ || bbfatal "mcopy cannot copy ${DEPLOY_DIR_IMAGE}/armstubs/${ARMSTUB} into boot.img" 119 mcopy -v -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/armstubs/${ARMSTUB} ::/ || bbfatal "mcopy cannot copy ${DEPLOY_DIR_IMAGE}/armstubs/${ARMSTUB} into boot.img"
120 fi 120 fi
diff --git a/conf/machine/include/rpi-base.inc b/conf/machine/include/rpi-base.inc
index 47a482f..c398705 100644
--- a/conf/machine/include/rpi-base.inc
+++ b/conf/machine/include/rpi-base.inc
@@ -84,10 +84,6 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "${@oe.utils.conditional('ENABLE_IR', '1'
84 84
85SERIAL_CONSOLES_CHECK ??= "${SERIAL_CONSOLES}" 85SERIAL_CONSOLES_CHECK ??= "${SERIAL_CONSOLES}"
86 86
87# The name of the deploy directory for raspberry pi boot files.
88# This variable is referred to by recipes fetching / generating the files.
89BOOTFILES_DIR_NAME ?= "bootfiles"
90
91# Set Raspberrypi splash image 87# Set Raspberrypi splash image
92SPLASH = "psplash-raspberrypi" 88SPLASH = "psplash-raspberrypi"
93 89
@@ -114,14 +110,14 @@ def make_dtb_boot_files(d):
114 return ' '.join([transform(dtb) for dtb in alldtbs.split(' ') if dtb]) 110 return ' '.join([transform(dtb) for dtb in alldtbs.split(' ') if dtb])
115 111
116 112
117IMAGE_BOOT_FILES ?= "${BOOTFILES_DIR_NAME}/* \ 113IMAGE_BOOT_FILES ?= "bcm2835-bootfiles/* \
118 ${@make_dtb_boot_files(d)} \ 114 ${@make_dtb_boot_files(d)} \
119 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', \ 115 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', \
120 '${KERNEL_IMAGETYPE} u-boot.bin;${SDIMG_KERNELIMAGE} boot.scr', \ 116 '${KERNEL_IMAGETYPE} u-boot.bin;${SDIMG_KERNELIMAGE} boot.scr', \
121 '${KERNEL_IMAGETYPE};${SDIMG_KERNELIMAGE}', d)} \ 117 '${KERNEL_IMAGETYPE};${SDIMG_KERNELIMAGE}', d)} \
122 " 118 "
123do_image_wic[depends] += " \ 119do_image_wic[depends] += " \
124 bootfiles:do_deploy \ 120 bcm2835-bootfiles:do_deploy \
125 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \ 121 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \
126 " 122 "
127 123
diff --git a/recipes-bsp/bootfiles/bootfiles.bb b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
index 80e226d..d20312c 100644
--- a/recipes-bsp/bootfiles/bootfiles.bb
+++ b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -1,4 +1,4 @@
1DESCRIPTION = "Closed source binary files to help boot all raspberry pi devices." 1DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835."
2LICENSE = "Broadcom-RPi" 2LICENSE = "Broadcom-RPi"
3 3
4LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=c403841ff2837657b2ed8e5bb474ac8d" 4LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=c403841ff2837657b2ed8e5bb474ac8d"
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 67c166a..d964de5 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -31,203 +31,203 @@ GPIO_IR_TX ?= "17"
31inherit deploy nopackages 31inherit deploy nopackages
32 32
33do_deploy() { 33do_deploy() {
34 install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} 34 install -d ${DEPLOYDIR}/bcm2835-bootfiles
35 35
36 cp ${S}/config.txt ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/ 36 cp ${S}/config.txt ${DEPLOYDIR}/bcm2835-bootfiles/
37 37
38 if [ -n "${KEY_DECODE_MPG2}" ]; then 38 if [ -n "${KEY_DECODE_MPG2}" ]; then
39 sed -i '/#decode_MPG2=/ c\decode_MPG2=${KEY_DECODE_MPG2}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 39 sed -i '/#decode_MPG2=/ c\decode_MPG2=${KEY_DECODE_MPG2}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
40 fi 40 fi
41 if [ -n "${KEY_DECODE_WVC1}" ]; then 41 if [ -n "${KEY_DECODE_WVC1}" ]; then
42 sed -i '/#decode_WVC1=/ c\decode_WVC1=${KEY_DECODE_WVC1}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 42 sed -i '/#decode_WVC1=/ c\decode_WVC1=${KEY_DECODE_WVC1}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
43 fi 43 fi
44 if [ -n "${DISABLE_OVERSCAN}" ]; then 44 if [ -n "${DISABLE_OVERSCAN}" ]; then
45 sed -i '/#disable_overscan=/ c\disable_overscan=${DISABLE_OVERSCAN}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 45 sed -i '/#disable_overscan=/ c\disable_overscan=${DISABLE_OVERSCAN}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
46 fi 46 fi
47 if [ "${DISABLE_SPLASH}" = "1" ]; then 47 if [ "${DISABLE_SPLASH}" = "1" ]; then
48 sed -i '/#disable_splash=/ c\disable_splash=${DISABLE_SPLASH}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 48 sed -i '/#disable_splash=/ c\disable_splash=${DISABLE_SPLASH}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
49 fi 49 fi
50 50
51 # Set overclocking options 51 # Set overclocking options
52 if [ -n "${ARM_FREQ}" ]; then 52 if [ -n "${ARM_FREQ}" ]; then
53 sed -i '/#arm_freq=/ c\arm_freq=${ARM_FREQ}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 53 sed -i '/#arm_freq=/ c\arm_freq=${ARM_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
54 fi 54 fi
55 if [ -n "${GPU_FREQ}" ]; then 55 if [ -n "${GPU_FREQ}" ]; then
56 sed -i '/#gpu_freq=/ c\gpu_freq=${GPU_FREQ}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 56 sed -i '/#gpu_freq=/ c\gpu_freq=${GPU_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
57 fi 57 fi
58 if [ -n "${CORE_FREQ}" ]; then 58 if [ -n "${CORE_FREQ}" ]; then
59 sed -i '/#core_freq=/ c\core_freq=${CORE_FREQ}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 59 sed -i '/#core_freq=/ c\core_freq=${CORE_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
60 fi 60 fi
61 if [ -n "${SDRAM_FREQ}" ]; then 61 if [ -n "${SDRAM_FREQ}" ]; then
62 sed -i '/#sdram_freq=/ c\sdram_freq=${SDRAM_FREQ}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 62 sed -i '/#sdram_freq=/ c\sdram_freq=${SDRAM_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
63 fi 63 fi
64 if [ -n "${OVER_VOLTAGE}" ]; then 64 if [ -n "${OVER_VOLTAGE}" ]; then
65 sed -i '/#over_voltage=/ c\over_voltage=${OVER_VOLTAGE}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 65 sed -i '/#over_voltage=/ c\over_voltage=${OVER_VOLTAGE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
66 fi 66 fi
67 67
68 # GPU memory 68 # GPU memory
69 if [ -n "${GPU_MEM}" ]; then 69 if [ -n "${GPU_MEM}" ]; then
70 sed -i '/#gpu_mem=/ c\gpu_mem=${GPU_MEM}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 70 sed -i '/#gpu_mem=/ c\gpu_mem=${GPU_MEM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
71 fi 71 fi
72 if [ -n "${GPU_MEM_256}" ]; then 72 if [ -n "${GPU_MEM_256}" ]; then
73 sed -i '/#gpu_mem_256=/ c\gpu_mem_256=${GPU_MEM_256}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 73 sed -i '/#gpu_mem_256=/ c\gpu_mem_256=${GPU_MEM_256}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
74 fi 74 fi
75 if [ -n "${GPU_MEM_512}" ]; then 75 if [ -n "${GPU_MEM_512}" ]; then
76 sed -i '/#gpu_mem_512=/ c\gpu_mem_512=${GPU_MEM_512}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 76 sed -i '/#gpu_mem_512=/ c\gpu_mem_512=${GPU_MEM_512}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
77 fi 77 fi
78 if [ -n "${GPU_MEM_1024}" ]; then 78 if [ -n "${GPU_MEM_1024}" ]; then
79 sed -i '/#gpu_mem_1024=/ c\gpu_mem_1024=${GPU_MEM_1024}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 79 sed -i '/#gpu_mem_1024=/ c\gpu_mem_1024=${GPU_MEM_1024}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
80 fi 80 fi
81 81
82 # Set boot delay 82 # Set boot delay
83 if [ -n "${BOOT_DELAY}" ]; then 83 if [ -n "${BOOT_DELAY}" ]; then
84 sed -i '/#boot_delay=/ c\boot_delay=${BOOT_DELAY}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 84 sed -i '/#boot_delay=/ c\boot_delay=${BOOT_DELAY}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
85 fi 85 fi
86 if [ -n "${BOOT_DELAY_MS}" ]; then 86 if [ -n "${BOOT_DELAY_MS}" ]; then
87 sed -i '/#boot_delay_ms=/ c\boot_delay_ms=${BOOT_DELAY_MS}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 87 sed -i '/#boot_delay_ms=/ c\boot_delay_ms=${BOOT_DELAY_MS}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
88 fi 88 fi
89 89
90 # Set HDMI and composite video options 90 # Set HDMI and composite video options
91 if [ -n "${HDMI_FORCE_HOTPLUG}" ]; then 91 if [ -n "${HDMI_FORCE_HOTPLUG}" ]; then
92 sed -i '/#hdmi_force_hotplug=/ c\hdmi_force_hotplug=${HDMI_FORCE_HOTPLUG}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 92 sed -i '/#hdmi_force_hotplug=/ c\hdmi_force_hotplug=${HDMI_FORCE_HOTPLUG}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
93 fi 93 fi
94 if [ -n "${HDMI_DRIVE}" ]; then 94 if [ -n "${HDMI_DRIVE}" ]; then
95 sed -i '/#hdmi_drive=/ c\hdmi_drive=${HDMI_DRIVE}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 95 sed -i '/#hdmi_drive=/ c\hdmi_drive=${HDMI_DRIVE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
96 fi 96 fi
97 if [ -n "${HDMI_GROUP}" ]; then 97 if [ -n "${HDMI_GROUP}" ]; then
98 sed -i '/#hdmi_group=/ c\hdmi_group=${HDMI_GROUP}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 98 sed -i '/#hdmi_group=/ c\hdmi_group=${HDMI_GROUP}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
99 fi 99 fi
100 if [ -n "${HDMI_MODE}" ]; then 100 if [ -n "${HDMI_MODE}" ]; then
101 sed -i '/#hdmi_mode=/ c\hdmi_mode=${HDMI_MODE}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 101 sed -i '/#hdmi_mode=/ c\hdmi_mode=${HDMI_MODE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
102 fi 102 fi
103 if [ -n "${CONFIG_HDMI_BOOST}" ]; then 103 if [ -n "${CONFIG_HDMI_BOOST}" ]; then
104 sed -i '/#config_hdmi_boost=/ c\config_hdmi_boost=${CONFIG_HDMI_BOOST}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 104 sed -i '/#config_hdmi_boost=/ c\config_hdmi_boost=${CONFIG_HDMI_BOOST}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
105 fi 105 fi
106 if [ -n "${SDTV_MODE}" ]; then 106 if [ -n "${SDTV_MODE}" ]; then
107 sed -i '/#sdtv_mode=/ c\sdtv_mode=${SDTV_MODE}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 107 sed -i '/#sdtv_mode=/ c\sdtv_mode=${SDTV_MODE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
108 fi 108 fi
109 if [ -n "${SDTV_ASPECT}" ]; then 109 if [ -n "${SDTV_ASPECT}" ]; then
110 sed -i '/#sdtv_aspect=/ c\sdtv_aspect=${SDTV_ASPECT}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 110 sed -i '/#sdtv_aspect=/ c\sdtv_aspect=${SDTV_ASPECT}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
111 fi 111 fi
112 if [ -n "${DISPLAY_ROTATE}" ]; then 112 if [ -n "${DISPLAY_ROTATE}" ]; then
113 sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 113 sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
114 fi 114 fi
115 115
116 # Video camera support 116 # Video camera support
117 if [ "${VIDEO_CAMERA}" = "1" ]; then 117 if [ "${VIDEO_CAMERA}" = "1" ]; then
118 echo "# Enable video camera" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 118 echo "# Enable video camera" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
119 echo "start_x=1" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 119 echo "start_x=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
120 fi 120 fi
121 121
122 # Offline compositing support 122 # Offline compositing support
123 if [ "${DISPMANX_OFFLINE}" = "1" ]; then 123 if [ "${DISPMANX_OFFLINE}" = "1" ]; then
124 echo "# Enable offline compositing" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 124 echo "# Enable offline compositing" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
125 echo "dispmanx_offline=1" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 125 echo "dispmanx_offline=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
126 fi 126 fi
127 127
128 # SPI bus support 128 # SPI bus support
129 if [ "${ENABLE_SPI_BUS}" = "1" ] || [ "${PITFT}" = "1" ]; then 129 if [ "${ENABLE_SPI_BUS}" = "1" ] || [ "${PITFT}" = "1" ]; then
130 echo "# Enable SPI bus" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 130 echo "# Enable SPI bus" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
131 echo "dtparam=spi=on" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 131 echo "dtparam=spi=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
132 fi 132 fi
133 133
134 # I2C support 134 # I2C support
135 if [ "${ENABLE_I2C}" = "1" ] || [ "${PITFT}" = "1" ]; then 135 if [ "${ENABLE_I2C}" = "1" ] || [ "${PITFT}" = "1" ]; then
136 echo "# Enable I2C" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 136 echo "# Enable I2C" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
137 echo "dtparam=i2c1=on" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 137 echo "dtparam=i2c1=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
138 echo "dtparam=i2c_arm=on" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 138 echo "dtparam=i2c_arm=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
139 fi 139 fi
140 140
141 # PiTFT22 display support 141 # PiTFT22 display support
142 if [ "${PITFT22}" = "1" ]; then 142 if [ "${PITFT22}" = "1" ]; then
143 echo "# Enable PITFT22 display" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 143 echo "# Enable PITFT22 display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
144 echo "dtoverlay=pitft22,rotate=270,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 144 echo "dtoverlay=pitft22,rotate=270,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
145 fi 145 fi
146 if [ "${PITFT28r}" = "1" ]; then 146 if [ "${PITFT28r}" = "1" ]; then
147 echo "# Enable PITFT28r display" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 147 echo "# Enable PITFT28r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
148 echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 148 echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
149 fi 149 fi
150 if [ "${PITFT28c}" = "1" ]; then 150 if [ "${PITFT28c}" = "1" ]; then
151 echo "# Enable PITFT28c display" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 151 echo "# Enable PITFT28c display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
152 echo "dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 152 echo "dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
153 echo "dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 153 echo "dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
154 fi 154 fi
155 if [ "${PITFT35r}" = "1" ]; then 155 if [ "${PITFT35r}" = "1" ]; then
156 echo "# Enable PITFT35r display" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 156 echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
157 echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 157 echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
158 fi 158 fi
159 159
160 # UART support 160 # UART support
161 if [ "${ENABLE_UART}" = "1" ]; then 161 if [ "${ENABLE_UART}" = "1" ]; then
162 echo "# Enable UART" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 162 echo "# Enable UART" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
163 echo "enable_uart=1" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 163 echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
164 fi 164 fi
165 165
166 # Infrared support 166 # Infrared support
167 if [ "${ENABLE_IR}" = "1" ]; then 167 if [ "${ENABLE_IR}" = "1" ]; then
168 echo "# Enable infrared" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 168 echo "# Enable infrared" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
169 echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 169 echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
170 echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 170 echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
171 fi 171 fi
172 172
173 # VC4 Graphics support 173 # VC4 Graphics support
174 if [ "${VC4GRAPHICS}" = "1" ]; then 174 if [ "${VC4GRAPHICS}" = "1" ]; then
175 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 175 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
176 echo "dtoverlay=${VC4DTBO}" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 176 echo "dtoverlay=${VC4DTBO}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
177 fi 177 fi
178 178
179 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm) 179 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
180 if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then 180 if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
181 echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 181 echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
182 echo "max_usb_current=1" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 182 echo "max_usb_current=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
183 echo "hdmi_group=2" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 183 echo "hdmi_group=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
184 echo "hdmi_mode=87" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 184 echo "hdmi_mode=87" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
185 echo "hdmi_cvt 1024 600 60 6 0 0 0" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 185 echo "hdmi_cvt 1024 600 60 6 0 0 0" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
186 echo "hdmi_drive=1" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 186 echo "hdmi_drive=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
187 fi 187 fi
188 188
189 # DWC2 USB peripheral support 189 # DWC2 USB peripheral support
190 if [ "${ENABLE_DWC2_PERIPHERAL}" = "1" ]; then 190 if [ "${ENABLE_DWC2_PERIPHERAL}" = "1" ]; then
191 echo "# Enable USB peripheral mode" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 191 echo "# Enable USB peripheral mode" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
192 echo "dtoverlay=dwc2,dr_mode=peripheral" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 192 echo "dtoverlay=dwc2,dr_mode=peripheral" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
193 fi 193 fi
194 194
195 # AT86RF23X support 195 # AT86RF23X support
196 if [ "${ENABLE_AT86RF}" = "1" ]; then 196 if [ "${ENABLE_AT86RF}" = "1" ]; then
197 echo "# Enable AT86RF23X" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 197 echo "# Enable AT86RF23X" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
198 echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 198 echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
199 fi 199 fi
200 200
201 # ENABLE CAN 201 # ENABLE CAN
202 if [ "${ENABLE_CAN}" = "1" ]; then 202 if [ "${ENABLE_CAN}" = "1" ]; then
203 echo "# Enable CAN" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 203 echo "# Enable CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
204 echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 204 echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
205 fi 205 fi
206 206
207 # Append extra config if the user has provided any 207 # Append extra config if the user has provided any
208 printf "${RPI_EXTRA_CONFIG}\n" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 208 printf "${RPI_EXTRA_CONFIG}\n" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
209 209
210 # Handle setup with armstub file 210 # Handle setup with armstub file
211 if [ "${@bb.utils.contains("MACHINE_FEATURES", "armstub", "1", "0", d)}" = "1" ]; then 211 if [ "${@bb.utils.contains("MACHINE_FEATURES", "armstub", "1", "0", d)}" = "1" ]; then
212 echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 212 echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
213 echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 213 echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
214 case "${ARMSTUB}" in 214 case "${ARMSTUB}" in
215 *-gic.bin) 215 *-gic.bin)
216 echo "enable_gic=1" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 216 echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
217 ;; 217 ;;
218 esac 218 esac
219 fi 219 fi
220} 220}
221 221
222do_deploy_append_raspberrypi3-64() { 222do_deploy_append_raspberrypi3-64() {
223 echo "# have a properly sized image" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 223 echo "# have a properly sized image" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
224 echo "disable_overscan=1" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 224 echo "disable_overscan=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
225 225
226 echo "# Enable audio (loads snd_bcm2835)" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 226 echo "# Enable audio (loads snd_bcm2835)" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
227 echo "dtparam=audio=on" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt 227 echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
228} 228}
229 229
230addtask deploy before do_build after do_install 230addtask deploy before do_build after do_install
231do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}" 231do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
232 232
233PACKAGE_ARCH = "${MACHINE_ARCH}" 233PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-kernel/linux/linux-raspberrypi.inc b/recipes-kernel/linux/linux-raspberrypi.inc
index f7dee77..3c3a8e5 100644
--- a/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/recipes-kernel/linux/linux-raspberrypi.inc
@@ -131,10 +131,10 @@ do_compile_append() {
131 131
132do_deploy_append() { 132do_deploy_append() {
133 # Deploy cmdline.txt 133 # Deploy cmdline.txt
134 install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} 134 install -d ${DEPLOYDIR}/bcm2835-bootfiles
135 PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}" 135 PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
136 if [ ${PITFT} = "1" ]; then 136 if [ ${PITFT} = "1" ]; then
137 PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8" 137 PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8"
138 fi 138 fi
139 echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/cmdline.txt 139 echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/bcm2835-bootfiles/cmdline.txt
140} 140}