summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-27 20:49:34 -0700
committerAndrei Gherzan <andrei@gherzan.ro>2020-11-03 17:25:35 +0000
commit7157e54d45c5c3710d21b845aa83d63013e3b39c (patch)
treec5226fab372e47a808a654a5a0540ad844b76d75
parent806575fc1d1ea3a6852210b83be9f2999d93b0da (diff)
downloadmeta-raspberrypi-7157e54d45c5c3710d21b845aa83d63013e3b39c.tar.gz
xserver-xorg: Depend on userland when vc4graphics is disabled
This helps in getting right headers, we have made a choice to let userland provide KHR/khrplatform.h when using it instead of mesa-gl which could have been another provider, xserver-xorg's glx implementation depends on virtual/libgl which in case of rpi-without-vc4 driver is provided by mesa-gl, as a result, compilation fails since no one is providing this header in this case. Fixes errors like usr/include/GL/glext.h:56:10: fatal error: KHR/khrplatform.h: No such file or directory | 56 | #include <KHR/khrplatform.h> | | ^~~~~~~~~~~~~~~~~~~ Fixes issue #391 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
index fba1632..9574fa5 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -1 +1,5 @@
1OPENGL_PKGCONFIGS_rpi = "dri glx ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'dri3 xshmfence glamor', '', d)}" 1OPENGL_PKGCONFIGS_rpi = "dri glx ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'dri3 xshmfence glamor', '', d)}"
2
3# when using userland graphic KHR/khrplatform.h is provided by userland but virtual/libgl is provided by mesa-gl where
4# we explicitly delete KHR/khrplatform.h since its already coming from userland package
5DEPENDS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'userland', d)}"