summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2020-07-16 12:18:41 -0300
committerAndrei Gherzan <andrei@gherzan.ro>2020-08-10 11:10:11 +0100
commit671ae4ab486c75b982728eef6e80ade036b3ba10 (patch)
tree727d319acd81c58af9babfa8de0e23c4a7532e23
parent8258e733ea89b6ac1f65419a8baf42110b83fdbc (diff)
downloadmeta-raspberrypi-671ae4ab486c75b982728eef6e80ade036b3ba10.tar.gz
u-boot: Move fw_env.config to u-boot append
The u-boot-env is provided by u-boot recipe and not by libubootenv, so right recipe to append is the u-boot. Adding the rpi-u-boot-scr in DEPENDS variable is wrong because it is forcing rpi-u-boot-scr to be a dependency, but it'll fail if I have another recipe that provides bootscript, once both recipes provide the same file. The default value of u-boot-default-script is rpi-u-boot-scr, so right way is to use u-boot-default-script and change the PREFERRED_PROVIDER_u-boot-default-script if needed. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/libubootenv_%.bbappend12
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend11
2 files changed, 11 insertions, 12 deletions
diff --git a/recipes-bsp/u-boot/libubootenv_%.bbappend b/recipes-bsp/u-boot/libubootenv_%.bbappend
deleted file mode 100644
index 22d1bdc..0000000
--- a/recipes-bsp/u-boot/libubootenv_%.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_rpi = " \
4 file://fw_env.config \
5"
6
7DEPENDS_append_rpi = " rpi-u-boot-scr"
8
9do_install_append_rpi () {
10 install -d ${D}${sysconfdir}
11 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
12}
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 9ce6425..7f38adb 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1 +1,12 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_rpi = " \
4 file://fw_env.config \
5"
6
1DEPENDS_append_rpi = " u-boot-default-script" 7DEPENDS_append_rpi = " u-boot-default-script"
8
9do_install_append_rpi () {
10 install -d ${D}${sysconfdir}
11 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
12}