summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2013-05-22 09:39:41 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2013-06-10 12:04:59 +0300
commitac879f9e21f622811e51c50a57990f44a9561137 (patch)
treeef3e3524aaa8ea7da7b7b5315b46d7f45da5fa7f
parent26000aace1cfbe839d6b7f82bf61707e6a1c3994 (diff)
downloadmeta-raspberrypi-ac879f9e21f622811e51c50a57990f44a9561137.tar.gz
psplash: only set image for MACHINE=raspberrypi
Instead of overriding the default psplash image, the raspberrypi image is added as an additional image. It is then set as the default in the raspberrypi machine config file so that other targets do not pick up our splash image. Tested on raspberrpi and qemuarm: on raspberrypi I see to Raspberry Pi logo, on qemuarm I see the Yocto Project logo. Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
-rw-r--r--conf/machine/raspberrypi.conf3
-rw-r--r--recipes-core/psplash/psplash_git.bbappend2
2 files changed, 4 insertions, 1 deletions
diff --git a/conf/machine/raspberrypi.conf b/conf/machine/raspberrypi.conf
index 6e95291..e25b59a 100644
--- a/conf/machine/raspberrypi.conf
+++ b/conf/machine/raspberrypi.conf
@@ -32,3 +32,6 @@ MACHINE_FEATURES_BACKFILL_CONSIDERED = "rtc"
32MACHINE_EXTRA_RRECOMMENDS += " \ 32MACHINE_EXTRA_RRECOMMENDS += " \
33 kernel-modules \ 33 kernel-modules \
34" 34"
35
36# Set raspberrypi splash image
37SPLASH = "psplash-raspberrypi"
diff --git a/recipes-core/psplash/psplash_git.bbappend b/recipes-core/psplash/psplash_git.bbappend
index eea8dfb..65dc30f 100644
--- a/recipes-core/psplash/psplash_git.bbappend
+++ b/recipes-core/psplash/psplash_git.bbappend
@@ -1,2 +1,2 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2SPLASH_IMAGES = "file://psplash-raspberrypi-img.h;outsuffix=default" 2SPLASH_IMAGES += "file://psplash-raspberrypi-img.h;outsuffix=raspberrypi"