summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2017-03-24 13:49:16 -0400
committerAndrei Gherzan <andrei@gherzan.ro>2017-04-03 14:38:35 +0100
commitda32aac453da278e254d37b816602410af85d162 (patch)
treedc92ddf03b139667162530e205079e761974a01a
parent0948d17dede617687669a45f7140354a4cf7809c (diff)
downloadmeta-raspberrypi-da32aac453da278e254d37b816602410af85d162.tar.gz
rpi-config: waveshare screen support
Add support for the Waveshare 1024x600 "C" Rev2.1 7" IPS Capacitive Touch Screen LCD with HDMI interface: http://www.waveshare.com/7inch-HDMI-LCD-C.htm http://www.waveshare.com/wiki/7inch_HDMI_LCD_(C) This product works "out of the box" with the Raspberry Pi. Simply connect the provided HDMI and USB cables between the two devices. The touch<=>mouse integration works automatically. Tested with a Raspberry Pi 3, with a 32-bit raspberrypi3 build. Signed-off-by: Trevor Woerner <twoerner@gmail.com>
-rw-r--r--README13
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb10
2 files changed, 20 insertions, 3 deletions
diff --git a/README b/README
index 65a1e5f..c58bc99 100644
--- a/README
+++ b/README
@@ -29,7 +29,8 @@ Contents:
29 3.L. Enable SPI bus 29 3.L. Enable SPI bus
30 3.M. Enable I2C 30 3.M. Enable I2C
31 3.N. Enable PiTFT support 31 3.N. Enable PiTFT support
32 3.O. Enable UART support 32 3.O. Misc. display
33 3.P. Enable UART support
334. Extra apps 344. Extra apps
34 4.A. omxplayer 35 4.A. omxplayer
355. Board Configuration 365. Board Configuration
@@ -241,9 +242,15 @@ List of currently supported models:
241 - pitft22 242 - pitft22
242 - pitft28r 243 - pitft28r
243 244
2443.O. Enable UART 2453.O. Misc. display
245=============== 246==================
247If you would like to use the Waveshare "C" 1024×600, 7 inch Capacitive Touch
248Screen LCD, HDMI interface (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
249Rev 2.1, please set the following in your local.conf
250WAVESHARE_1024X600_C_2.1 = "1"
246 251
2523.P. Enable UART
253===============
247RaspberryPi 1, 2 and CM will have UART console enabled by default. 254RaspberryPi 1, 2 and CM will have UART console enabled by default.
248 255
249RaspberryPi 3 does not have the UART enabled by default because this needs a 256RaspberryPi 3 does not have the UART enabled by default because this needs a
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 20ec343..8adc938 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -110,6 +110,16 @@ do_deploy() {
110 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 110 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
111 echo "dtoverlay=vc4-kms-v3d,${VC4_CMA_SIZE}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 111 echo "dtoverlay=vc4-kms-v3d,${VC4_CMA_SIZE}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
112 fi 112 fi
113
114 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
115 if [ "${WAVESHARE_1024X600_C_2.1}" = "1" ]; then
116 echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
117 echo "max_usb_current=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
118 echo "hdmi_group=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
119 echo "hdmi_mode=87" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
120 echo "hdmi_cvt 1024 600 60 6 0 0 0" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
121 echo "hdmi_drive=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
122 fi
113} 123}
114 124
115do_deploy_append_raspberrypi3-64() { 125do_deploy_append_raspberrypi3-64() {