summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2017-04-04 19:35:50 +0200
committerAndrei Gherzan <andrei@gherzan.ro>2017-04-05 16:35:21 +0100
commitd0c152d7f88d9d0d6c85904c6143a189f3caa380 (patch)
treefc476f77803c204dc9bdbccf183fc5c68850112b
parentda32aac453da278e254d37b816602410af85d162 (diff)
downloadmeta-raspberrypi-d0c152d7f88d9d0d6c85904c6143a189f3caa380.tar.gz
rpi-config: fix invalid shell variable name
Commit da32aac introduced an invalid shell variable name in do_deploy(): according to bash manpage variable names cannot contain dots. Replace dot with underscore to fix it. Signed-off-by: Andrea Galbusera <gizero@gmail.com>
-rw-r--r--README2
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/README b/README
index c58bc99..9fdd5eb 100644
--- a/README
+++ b/README
@@ -247,7 +247,7 @@ List of currently supported models:
247If you would like to use the Waveshare "C" 1024×600, 7 inch Capacitive Touch 247If you would like to use the Waveshare "C" 1024×600, 7 inch Capacitive Touch
248Screen LCD, HDMI interface (http://www.waveshare.com/7inch-HDMI-LCD-C.htm) 248Screen LCD, HDMI interface (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
249Rev 2.1, please set the following in your local.conf 249Rev 2.1, please set the following in your local.conf
250WAVESHARE_1024X600_C_2.1 = "1" 250WAVESHARE_1024X600_C_2_1 = "1"
251 251
2523.P. Enable UART 2523.P. Enable UART
253=============== 253===============
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 8adc938..af55983 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -112,7 +112,7 @@ do_deploy() {
112 fi 112 fi
113 113
114 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm) 114 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
115 if [ "${WAVESHARE_1024X600_C_2.1}" = "1" ]; then 115 if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
116 echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 116 echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
117 echo "max_usb_current=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 117 echo "max_usb_current=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
118 echo "hdmi_group=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 118 echo "hdmi_group=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt