summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2016-11-02 00:46:47 +1100
committerAndrei Gherzan <andrei@gherzan.ro>2016-11-12 13:26:18 +0100
commitb0308141c1fa1aeb80189d37cfd3a0630881504d (patch)
tree305222366824fd8759e661e64f581d7c8573690c
parent9c12ac8280d30e8debb4c3ae350a44cc2fbab894 (diff)
downloadmeta-raspberrypi-b0308141c1fa1aeb80189d37cfd3a0630881504d.tar.gz
u-boot: Fix appending to RDEPENDS
The += operator should not be used in combination with overrides as it will clear any existing values in the variable. Example: FOO = "bar" FOO_rpi += "baz" The above example would result in FOO being equal to " baz" instead of "bar baz". The bbappend is changed to use a wildcard instead of a specific version to simplify updating U-Boot. Signed-off-by: Jonathan Liu <net147@gmail.com>
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend1
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.03.bbappend1
2 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
new file mode 100644
index 0000000..3781666
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -0,0 +1 @@
RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr"
diff --git a/recipes-bsp/u-boot/u-boot_2016.03.bbappend b/recipes-bsp/u-boot/u-boot_2016.03.bbappend
deleted file mode 100644
index 35dfc37..0000000
--- a/recipes-bsp/u-boot/u-boot_2016.03.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1RDEPENDS_${PN}_rpi += "rpi-u-boot-scr"