summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.com>2017-05-17 18:48:36 +0100
committerGitHub <noreply@github.com>2017-05-17 18:48:36 +0100
commit39e1d49097ba9c3193b222c23fc9db6871f74333 (patch)
treedeb5ef83a66f688374d3faa9079a228eed47a09e
parentadf62cd9e84dbda5509f5b45230f33914f38c7d4 (diff)
parent9eaff5ce1a403f4a37575953361bc5c4a3e045b6 (diff)
downloadmeta-raspberrypi-39e1d49097ba9c3193b222c23fc9db6871f74333.tar.gz
Merge pull request #70 from agherzan/pbarker/drop-4.4
linux-rasberrypi: Drop 4.4 series kernel
-rw-r--r--recipes-kernel/linux/linux-raspberrypi-4.4/0001-fix-dtbo-rules.patch44
-rw-r--r--recipes-kernel/linux/linux-raspberrypi_4.4.bb10
2 files changed, 0 insertions, 54 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi-4.4/0001-fix-dtbo-rules.patch b/recipes-kernel/linux/linux-raspberrypi-4.4/0001-fix-dtbo-rules.patch
deleted file mode 100644
index 5113e23..0000000
--- a/recipes-kernel/linux/linux-raspberrypi-4.4/0001-fix-dtbo-rules.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From 13c8784da3dbd977f64cec740eba775b6fab11c2 Mon Sep 17 00:00:00 2001
2From: Herve Jourdain <herve.jourdain@neuf.fr>
3Date: Fri, 20 May 2016 16:02:23 +0800
4Subject: [yocto][meta-raspberrypi][PATCH v4 4/5] linux-raspberrypi_4.4.inc:
5 support for .dtbo files for dtb overlays
6
7Upstream-Status: Pending
8
9Kernel 4.4.6+ on RaspberryPi support .dtbo files for overlays, instead of .dtb.
10Patch the kernel, which has faulty rules to generate .dtbo the way yocto does
11
12Signed-off-by: Herve Jourdain <herve.jourdain@neuf.fr>
13---
14 .../0001-fix-dtbo-rules.patch | 27 ++++++++++++++++++++++
15 1 file changed, 27 insertions(+)
16 create mode 100644 recipes-kernel/linux/linux-raspberrypi-4.4/0001-fix-dtbo-rules.patch
17
18diff --git a/arch/arm/Makefile b/arch/arm/Makefile
19index a2e7cf7..673c1cb 100644
20--- a/arch/arm/Makefile
21+++ b/arch/arm/Makefile
22@@ -333,6 +333,8 @@ $(INSTALL_TARGETS):
23
24 %.dtb: | scripts
25 $(Q)$(MAKE) $(build)=$(boot)/dts MACHINE=$(MACHINE) $(boot)/dts/$@
26+%.dtbo: | scripts
27+ $(Q)$(MAKE) $(build)=$(boot)/dts MACHINE=$(MACHINE) $(boot)/dts/$@
28
29 PHONY += dtbs dtbs_install
30
31diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
32index 3079c4f..6cc3766 100644
33--- a/scripts/Makefile.lib
34+++ b/scripts/Makefile.lib
35@@ -293,7 +293,8 @@ $(obj)/%.dtb: $(src)/%.dts FORCE
36 $(call if_changed_dep,dtc)
37
38 quiet_cmd_dtco = DTCO $@
39-cmd_dtco = $(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) $< ; \
40+cmd_dtco = mkdir -p $(dir ${dtc-tmp}) ; \
41+ $(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) $< ; \
42 $(objtree)/scripts/dtc/dtc -@ -H epapr -O dtb -o $@ -b 0 \
43 -i $(dir $<) $(DTC_FLAGS) \
44 -d $(depfile).dtc.tmp $(dtc-tmp) ; \
diff --git a/recipes-kernel/linux/linux-raspberrypi_4.4.bb b/recipes-kernel/linux/linux-raspberrypi_4.4.bb
deleted file mode 100644
index b6be0ec..0000000
--- a/recipes-kernel/linux/linux-raspberrypi_4.4.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
2
3LINUX_VERSION ?= "4.4.50"
4
5SRCREV = "04c8e47067d4873c584395e5cb260b4f170a99ea"
6SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=rpi-4.4.y \
7 file://0001-fix-dtbo-rules.patch \
8"
9
10require linux-raspberrypi.inc