summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-09 23:48:44 -0700
committerAndrei Gherzan <andrei@gherzan.ro>2017-05-11 18:18:05 +0100
commit2aa6b1a637112aea7729bf32e114aa9fa270fb23 (patch)
tree6c48ae8661a9eeeb14e6db70a92c7b55aafcfa94
parent8527a396d38aec7776182caca8b9a237e03c3965 (diff)
downloadmeta-raspberrypi-2aa6b1a637112aea7729bf32e114aa9fa270fb23.tar.gz
userland: Add missing GLES2 defines
Needed by weston Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch30
-rw-r--r--recipes-graphics/userland/userland_git.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch b/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch
new file mode 100644
index 0000000..2232d4b
--- /dev/null
+++ b/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch
@@ -0,0 +1,30 @@
1From 55a66f56a14eb8c3ae8294860e49efc9c9598c46 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 10 May 2017 06:39:34 +0000
4Subject: [PATCH] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT
5
6weston code uses these defines
7Upstream-Status: Pending
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 interface/khronos/include/GLES2/gl2ext.h | 3 +++
12 1 file changed, 3 insertions(+)
13
14diff --git a/interface/khronos/include/GLES2/gl2ext.h b/interface/khronos/include/GLES2/gl2ext.h
15index 4eacf7f..283e3e1 100644
16--- a/interface/khronos/include/GLES2/gl2ext.h
17+++ b/interface/khronos/include/GLES2/gl2ext.h
18@@ -327,6 +327,9 @@ typedef void* GLeglImageOES;
19 #define GL_RGBX_BRCM 0x80EE
20 #endif
21
22+#define GL_R8_EXT 0x8229
23+#define GL_RG8_EXT 0x822B
24+
25 /* GL_EXT_texture_type_2_10_10_10_REV */
26 #ifndef GL_EXT_texture_type_2_10_10_10_REV
27 #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368
28--
291.9.1
30
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 9526fae..1176ef2 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -33,6 +33,7 @@ SRC_URI = "\
33 file://0011-build-shared-library-for-vchostif.patch \ 33 file://0011-build-shared-library-for-vchostif.patch \
34 file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \ 34 file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \
35 file://0013-Implement-triple-buffering-for-wayland.patch \ 35 file://0013-Implement-triple-buffering-for-wayland.patch \
36 file://0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch \
36" 37"
37S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
38 39