summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRob Woolley <rob.woolley@windriver.com>2017-04-06 11:44:19 -0700
committerAndrei Gherzan <andrei@gherzan.ro>2017-04-17 02:22:34 +0100
commit0ef0667550de2b1c99e2a1ff2f50fde2efb353f2 (patch)
tree8c0f8c1e1dd30ec10c96c66b1b6aad7a2269c8bb
parente11d38f8dca47bfb6a06fd3ced139d37750eff15 (diff)
downloadmeta-raspberrypi-0ef0667550de2b1c99e2a1ff2f50fde2efb353f2.tar.gz
pitft: Include a pitft35r MACHINE_FEATURE
This MACHINE_FEATURE will automatically add the recommended Adafruit configuration line to the Raspberry Pi config.txt. Signed-off-by: Rob Woolley <rob.woolley@windriver.com>
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index af55983..b3c5084 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -18,6 +18,7 @@ PR = "r5"
18PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}" 18PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
19PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}" 19PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}"
20PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}" 20PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}"
21PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
21 22
22VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" 23VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
23 24
@@ -99,6 +100,11 @@ do_deploy() {
99 echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 100 echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
100 fi 101 fi
101 102
103 if [ "${PITFT35r}" = "1" ]; then
104 echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
105 echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
106 fi
107
102 # UART support 108 # UART support
103 if [ "${ENABLE_UART}" = "1" ]; then 109 if [ "${ENABLE_UART}" = "1" ]; then
104 echo "# Enable UART" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 110 echo "# Enable UART" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt