summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Haigh <jonathan.haigh@arm.com>2018-05-08 14:17:06 +0100
committerAndrei Gherzan <andrei@gherzan.com>2018-05-09 16:40:25 +0100
commitd2015ceee06531c61fb59f16d8fd23e31b9e68e7 (patch)
treefe867c737e4b1f5192bbda66f532245cfcc09437
parenta93a373c3eb806636602efe94fc45e8d4485f05a (diff)
downloadmeta-raspberrypi-d2015ceee06531c61fb59f16d8fd23e31b9e68e7.tar.gz
u-boot: Remove upstreamed U-Boot rpi0w defconfig patch
[Issue #239] -- https://github.com/agherzan/meta-raspberrypi/issues/239 The patch 0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch has been applied to the upstream U-Boot repo and is now in the release that openembedded-core uses so remove it from meta-raspberrypi's U-Boot bbappend. Signed-off-by: Jonathan Haigh <jonathan.haigh@arm.com>
-rw-r--r--recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch41
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend6
2 files changed, 0 insertions, 47 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch b/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch
deleted file mode 100644
index e98fd85..0000000
--- a/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1From 5d113dc0130ea2ea9faaa000fba9c737266b9747 Mon Sep 17 00:00:00 2001
2From: Drew Moseley <drew.moseley@northern.tech>
3Date: Fri, 9 Feb 2018 18:10:09 -0500
4Subject: [PATCH] rpi_0_w: Add configs consistent with RpI3
5
6Upstream-Status: Accepted [https://patchwork.ozlabs.org/patch/856572/]
7
8Signed-off-by: Drew Moseley <drew.moseley@northern.tech>
9---
10 configs/rpi_0_w_defconfig | 7 +++++++
11 1 file changed, 7 insertions(+)
12
13diff --git a/configs/rpi_0_w_defconfig b/configs/rpi_0_w_defconfig
14index 9a6d24b..1248294 100644
15--- a/configs/rpi_0_w_defconfig
16+++ b/configs/rpi_0_w_defconfig
17@@ -12,14 +12,21 @@ CONFIG_SYS_PROMPT="U-Boot> "
18 CONFIG_CMD_GPIO=y
19 CONFIG_CMD_MMC=y
20 CONFIG_CMD_USB=y
21+CONFIG_OF_EMBED=y
22+CONFIG_ENV_FAT_INTERFACE="mmc"
23+CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
24+CONFIG_DM_KEYBOARD=y
25 CONFIG_DM_MMC=y
26 CONFIG_MMC_SDHCI=y
27 CONFIG_MMC_SDHCI_BCM2835=y
28 CONFIG_DM_ETH=y
29 CONFIG_USB=y
30 CONFIG_DM_USB=y
31+CONFIG_USB_DWC2=y
32 CONFIG_USB_STORAGE=y
33 CONFIG_USB_KEYBOARD=y
34+CONFIG_USB_HOST_ETHER=y
35+CONFIG_USB_ETHER_SMSC95XX=y
36 CONFIG_DM_VIDEO=y
37 CONFIG_SYS_WHITE_ON_BLACK=y
38 CONFIG_CONSOLE_SCROLL_LINES=10
39--
402.7.4
41
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 7d4a49e..95015f4 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,7 +1 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
2
3SRC_URI_append_rpi = " \
4 file://0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch \
5"
6
7DEPENDS_append_rpi = " rpi-u-boot-scr" DEPENDS_append_rpi = " rpi-u-boot-scr"