summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Schuessler <m@schunet.com>2019-06-20 15:19:19 +0200
committerAndrei Gherzan <andrei@gherzan.ro>2019-06-24 17:46:48 +0100
commit6c73694912c73187560f657bec24893f184f9b14 (patch)
tree980dd5970a157ca3936017ab988d5eb1bf83995c
parent1c842e21c22e999b8a317e33d7748102ef13b6b4 (diff)
downloadmeta-raspberrypi-6c73694912c73187560f657bec24893f184f9b14.tar.gz
omxplayer: remove hardcoded tune and arch from Makefile
Fixes: #428 Signed-off-by: Martin Schuessler <tossprobe@gmail.com>
-rw-r--r--recipes-multimedia/omxplayer/omxplayer/0007-Remove-Makefile-hardcoded-arch-tune.patch8
-rw-r--r--recipes-multimedia/omxplayer/omxplayer_git.bb1
2 files changed, 9 insertions, 0 deletions
diff --git a/recipes-multimedia/omxplayer/omxplayer/0007-Remove-Makefile-hardcoded-arch-tune.patch b/recipes-multimedia/omxplayer/omxplayer/0007-Remove-Makefile-hardcoded-arch-tune.patch
new file mode 100644
index 0000000..0331973
--- /dev/null
+++ b/recipes-multimedia/omxplayer/omxplayer/0007-Remove-Makefile-hardcoded-arch-tune.patch
@@ -0,0 +1,8 @@
1--- a/Makefile 2019-06-20 15:04:53.390282996 +0200
2+++ b/Makefile 2019-06-20 15:03:45.538763872 +0200
3@@ -1,4 +1,4 @@
4-CFLAGS=-pipe -mfloat-abi=hard -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -mfpu=vfp -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
5+CFLAGS+= -fomit-frame-pointer -mabi=aapcs-linux -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
6 CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
7
8 LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/
diff --git a/recipes-multimedia/omxplayer/omxplayer_git.bb b/recipes-multimedia/omxplayer/omxplayer_git.bb
index aad2fed..831a91b 100644
--- a/recipes-multimedia/omxplayer/omxplayer_git.bb
+++ b/recipes-multimedia/omxplayer/omxplayer_git.bb
@@ -33,6 +33,7 @@ SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=git;branch=master
33 file://0006-Prevent-ffmpeg-configure-compile-race-condition.patch \ 33 file://0006-Prevent-ffmpeg-configure-compile-race-condition.patch \
34 file://0001-Specify-cc-cxx-and-ld-variables-from-environment.patch \ 34 file://0001-Specify-cc-cxx-and-ld-variables-from-environment.patch \
35 file://cross-crompile-ffmpeg.patch \ 35 file://cross-crompile-ffmpeg.patch \
36 file://0007-Remove-Makefile-hardcoded-arch-tune.patch \
36 " 37 "
37 38
38SRC_URI_append = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " file://0001-Fix-build-with-vc4-driver.patch ", "", d)}" 39SRC_URI_append = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " file://0001-Fix-build-with-vc4-driver.patch ", "", d)}"