summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2019-07-02 15:17:44 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2019-07-20 21:56:21 +0100
commit33f810f43486c509293e04edf56701b16339582a (patch)
tree9bc22de6e872259e737ff469d94ce30725dc518c
parent242b1f53c0e14a94d6a6b29850dad29338026ce2 (diff)
downloadmeta-raspberrypi-33f810f43486c509293e04edf56701b16339582a.tar.gz
rpi-config: Handle ARMSTUB
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index b3356ed..08c80a6 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -191,6 +191,17 @@ do_deploy() {
191 191
192 # Append extra config if the user has provided any 192 # Append extra config if the user has provided any
193 printf "${RPI_EXTRA_CONFIG}\n" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 193 printf "${RPI_EXTRA_CONFIG}\n" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
194
195 # Handle setup with armstub file
196 if [ -n "${ARMSTUB}" ]; then
197 echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
198 echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
199 case "${ARMSTUB}" in
200 *-gic.bin)
201 echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
202 ;;
203 esac
204 fi
194} 205}
195 206
196do_deploy_append_raspberrypi3-64() { 207do_deploy_append_raspberrypi3-64() {