summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Laplante <mostthingsweb@gmail.com>2021-02-21 09:42:54 -0500
committerAndrei Gherzan <andrei@gherzan.com>2021-02-26 12:48:42 +0000
commitb29eb27c5b7f0d5c3f446fd1b22f9a246e93efc6 (patch)
tree5c0adc81183443d01a65d3cf7183fbf669dc1ca3
parent823220e64840c0979070f9224c3f453b22eeee78 (diff)
downloadmeta-raspberrypi-b29eb27c5b7f0d5c3f446fd1b22f9a246e93efc6.tar.gz
python3-adafruit-circuitpython-motor: add recipe
Signed-off-by: Chris Laplante <mostthingsweb@gmail.com>
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb b/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
new file mode 100644
index 0000000..e05e2ab
--- /dev/null
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
@@ -0,0 +1,18 @@
1SUMMARY = "CircuitPython helper library provides higher level objects to control motors and servos."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Motor"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b72678307cc7c10910b5ef460216af07"
5
6SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Motor.git"
7SRCREV = "2251bfc0501d0acfb96c0a43f4f2b4c6a10ca14e"
8
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
15RDEPENDS_${PN} += " \
16 python3-adafruit-blinka \
17 python3-core \
18"