diff options
Diffstat (limited to 'recipes-qt')
-rw-r--r-- | recipes-qt/qt5/qttools/run-ptest | 4 | ||||
-rw-r--r-- | recipes-qt/qt5/qttools_git.bb | 17 |
2 files changed, 21 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qttools/run-ptest b/recipes-qt/qt5/qttools/run-ptest new file mode 100644 index 00000000..5cd5e27e --- /dev/null +++ b/recipes-qt/qt5/qttools/run-ptest | |||
@@ -0,0 +1,4 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | ./tst_qtdiag | ||
4 | ./tst_qtattributionsscanner | ||
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb index a2b01be9..5c0f51cc 100644 --- a/recipes-qt/qt5/qttools_git.bb +++ b/recipes-qt/qt5/qttools_git.bb | |||
@@ -14,9 +14,12 @@ LIC_FILES_CHKSUM = " \ | |||
14 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | 14 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ |
15 | " | 15 | " |
16 | 16 | ||
17 | inherit ptest | ||
18 | |||
17 | DEPENDS += "qtbase qtdeclarative qtxmlpatterns" | 19 | DEPENDS += "qtbase qtdeclarative qtxmlpatterns" |
18 | 20 | ||
19 | SRC_URI += " \ | 21 | SRC_URI += " \ |
22 | file://run-ptest \ | ||
20 | file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \ | 23 | file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \ |
21 | file://0003-add-noqtwebkit-configuration.patch \ | 24 | file://0003-add-noqtwebkit-configuration.patch \ |
22 | file://0004-linguist-tools-cmake-allow-overriding-the-location-f.patch \ | 25 | file://0004-linguist-tools-cmake-allow-overriding-the-location-f.patch \ |
@@ -33,3 +36,17 @@ EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'C | |||
33 | SRCREV = "30c10900adecca55faa1d59c2f0caac74b1f9df6" | 36 | SRCREV = "30c10900adecca55faa1d59c2f0caac74b1f9df6" |
34 | 37 | ||
35 | BBCLASSEXTEND = "native nativesdk" | 38 | BBCLASSEXTEND = "native nativesdk" |
39 | |||
40 | do_compile_ptest() { | ||
41 | export PATH=${STAGING_DIR_NATIVE}/usr/include/qt5:$PATH | ||
42 | cd ${S}/tests | ||
43 | qmake -o Makefile tests.pro | ||
44 | oe_runmake | ||
45 | } | ||
46 | |||
47 | do_install_ptest() { | ||
48 | mkdir -p ${D}${PTEST_PATH} | ||
49 | t=${D}${PTEST_PATH} | ||
50 | cp ${S}/tests/auto/qtdiag/tst_tdiag $t | ||
51 | cp ${S}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t | ||
52 | } | ||