diff options
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r-- | recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch | 44 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwayland_git.bb | 3 |
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch b/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch new file mode 100644 index 00000000..e1e978e8 --- /dev/null +++ b/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From c93dbe53e8a1b2203c750a66c7efe6fc9a326903 Mon Sep 17 00:00:00 2001 | ||
2 | From: Raphael Freudiger <raphael.freudiger@siemens.com> | ||
3 | Date: Thu, 22 Dec 2016 13:54:31 +0100 | ||
4 | Subject: [PATCH] fix build without xkbcommon-evdev | ||
5 | |||
6 | Signed-off-by: Raphael Freudiger <raphael.freudiger@siemens.com> | ||
7 | --- | ||
8 | src/compositor/compositor_api/qwaylandkeyboard.cpp | 13 +++++++------ | ||
9 | 1 file changed, 7 insertions(+), 6 deletions(-) | ||
10 | |||
11 | diff --git a/src/compositor/compositor_api/qwaylandkeyboard.cpp b/src/compositor/compositor_api/qwaylandkeyboard.cpp | ||
12 | index 55381b4..5c054c6 100644 | ||
13 | --- a/src/compositor/compositor_api/qwaylandkeyboard.cpp | ||
14 | +++ b/src/compositor/compositor_api/qwaylandkeyboard.cpp | ||
15 | @@ -338,12 +338,6 @@ void QWaylandKeyboardPrivate::createXKBState(xkb_keymap *keymap) | ||
16 | xkb_state = xkb_state_new(keymap); | ||
17 | } | ||
18 | |||
19 | -uint QWaylandKeyboardPrivate::toWaylandXkbV1Key(const uint nativeScanCode) | ||
20 | -{ | ||
21 | - const uint offset = 8; | ||
22 | - Q_ASSERT(nativeScanCode >= offset); | ||
23 | - return nativeScanCode - offset; | ||
24 | -} | ||
25 | |||
26 | void QWaylandKeyboardPrivate::createXKBKeymap() | ||
27 | { | ||
28 | @@ -373,6 +367,13 @@ void QWaylandKeyboardPrivate::createXKBKeymap() | ||
29 | } | ||
30 | #endif | ||
31 | |||
32 | +uint QWaylandKeyboardPrivate::toWaylandXkbV1Key(const uint nativeScanCode) | ||
33 | +{ | ||
34 | + const uint offset = 8; | ||
35 | + Q_ASSERT(nativeScanCode >= offset); | ||
36 | + return nativeScanCode - offset; | ||
37 | +} | ||
38 | + | ||
39 | void QWaylandKeyboardPrivate::sendRepeatInfo() | ||
40 | { | ||
41 | Q_FOREACH (Resource *resource, resourceMap()) { | ||
42 | -- | ||
43 | 2.1.4 | ||
44 | |||
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb index 21abd545..d42d80a0 100644 --- a/recipes-qt/qt5/qtwayland_git.bb +++ b/recipes-qt/qt5/qtwayland_git.bb | |||
@@ -43,4 +43,7 @@ EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" | |||
43 | 43 | ||
44 | SRCREV = "0e2a950895805457a45abe860bc91a7cc4ba405e" | 44 | SRCREV = "0e2a950895805457a45abe860bc91a7cc4ba405e" |
45 | 45 | ||
46 | # From https://bugreports.qt.io/browse/QTBUG-57767 | ||
47 | SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch" | ||
48 | |||
46 | BBCLASSEXTEND =+ "native nativesdk" | 49 | BBCLASSEXTEND =+ "native nativesdk" |