summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebglplugin_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebglplugin_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
new file mode 100644
index 00000000..62601bb3
--- /dev/null
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -0,0 +1,21 @@
1require qt5.inc
2require qt5-git.inc
3
4LICENSE = "GPL-3.0 | The-Qt-Company-Commercial"
5LIC_FILES_CHKSUM = " \
6 file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
7"
8
9DEPENDS += "qtbase qtwebsockets"
10
11PACKAGECONFIG ?= "qtdeclarative"
12PACKAGECONFIG[qtdeclarative] = ",,qtdeclarative"
13
14do_configure_prepend() {
15 # disable qtdeclarative test if it isn't enabled by PACKAGECONFIG
16 sed -e 's/^\(qtHaveModule(quick)\)/OE_QTDECLARATIVE_ENABLED:\1/' -i ${S}/src/plugins/platforms/webgl/webgl.pro
17}
18
19EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
20
21SRCREV = "62a5226c6147ee45f488a2e2c65870c1f836a5be"