summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index a0cda175..4f27ade5 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -2,7 +2,7 @@ require qt5.inc
2require qt5-git.inc 2require qt5-git.inc
3 3
4DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native" 4DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native"
5DEPENDS_append_class-target = " libxkbcommon" 5DEPENDS:append:class-target = " libxkbcommon"
6 6
7LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )" 7LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
8LIC_FILES_CHKSUM = " \ 8LIC_FILES_CHKSUM = " \
@@ -19,12 +19,12 @@ PACKAGECONFIG ?= " \
19 wayland-egl \ 19 wayland-egl \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcomposite-egl xcomposite-glx', '', d)} \ 20 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcomposite-egl xcomposite-glx', '', d)} \
21" 21"
22PACKAGECONFIG_class-native ?= "" 22PACKAGECONFIG:class-native ?= ""
23PACKAGECONFIG_class-nativesdk ?= "" 23PACKAGECONFIG:class-nativesdk ?= ""
24QMAKE_PROFILES_class-native = "${S}/src/qtwaylandscanner" 24QMAKE_PROFILES:class-native = "${S}/src/qtwaylandscanner"
25QMAKE_PROFILES_class-nativesdk = "${S}/src/qtwaylandscanner" 25QMAKE_PROFILES:class-nativesdk = "${S}/src/qtwaylandscanner"
26B_class-native = "${SEPB}/src/qtwaylandscanner" 26B:class-native = "${SEPB}/src/qtwaylandscanner"
27B_class-nativesdk = "${SEPB}/src/qtwaylandscanner" 27B:class-nativesdk = "${SEPB}/src/qtwaylandscanner"
28 28
29PACKAGECONFIG[wayland-client] = "-feature-wayland-client,-no-feature-wayland-client" 29PACKAGECONFIG[wayland-client] = "-feature-wayland-client,-no-feature-wayland-client"
30PACKAGECONFIG[wayland-server] = "-feature-wayland-server,-no-feature-wayland-server" 30PACKAGECONFIG[wayland-server] = "-feature-wayland-server,-no-feature-wayland-server"
@@ -43,7 +43,7 @@ BBCLASSEXTEND =+ "native nativesdk"
43 43
44# The same issue as in qtbase: 44# The same issue as in qtbase:
45# http://errors.yoctoproject.org/Errors/Details/152641/ 45# http://errors.yoctoproject.org/Errors/Details/152641/
46LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" 46LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
47 47
48# Since version 5.11.2 some private headers are not installed. Work around 48# Since version 5.11.2 some private headers are not installed. Work around
49# until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for 49# until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for
@@ -51,7 +51,7 @@ LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-
51QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY ?= "1" 51QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY ?= "1"
52# First 6 characters before first + (e.g. 5.11.3-+git) or - (e.g. 5.11.3-2) 52# First 6 characters before first + (e.g. 5.11.3-+git) or - (e.g. 5.11.3-2)
53SHRT_VER ?= "${@d.getVar('PV').split('+')[0].split('-')[0]}" 53SHRT_VER ?= "${@d.getVar('PV').split('+')[0].split('-')[0]}"
54do_install_append() { 54do_install:append() {
55 if [ -d "${B}/src/client" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/" ]; then 55 if [ -d "${B}/src/client" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/" ]; then
56 for header in `find ${B}/src/client -name '*wayland-*.h'`; do 56 for header in `find ${B}/src/client -name '*wayland-*.h'`; do
57 header_base=`basename $header` 57 header_base=`basename $header`