summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative_git.bb')
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb28
1 files changed, 27 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index caa851a3..5f628c28 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -1,4 +1,30 @@
1require qt5.inc
1require qt5-git.inc 2require qt5-git.inc
2require ${PN}.inc 3
4# There are no LGPLv3-only licensed files in this component.
5LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
6LIC_FILES_CHKSUM = " \
7 file://LICENSE.LGPLv21;md5=cff17b12416c896e10ae2c17a64252e7 \
8 file://LICENSE.LGPLv3;md5=c1939be5579666be947371bc8120425f \
9 file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
10 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
11"
12
13DEPENDS += "qtbase"
14
15SRC_URI += " \
16 file://0001-qmltestexample-fix-link.patch \
17"
18
19PACKAGECONFIG ??= "qtxmlpatterns"
20PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns"
21
22do_configure_prepend() {
23 # disable qtxmlpatterns test if it isn't enabled by PACKAGECONFIG
24 sed -e 's/^\(qtHaveModule(xmlpatterns)\)/OE_QTXMLPATTERNS_ENABLED:\1/' -i ${S}/src/imports/imports.pro
25 sed -e 's/^\(!qtHaveModule(xmlpatterns)\)/!OE_QTXMLPATTERNS_ENABLED|\1/' -i ${S}/tests/auto/quick/quick.pro
26}
27
28EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
3 29
4SRCREV = "2b3c2339616680537145a9cc2e7567575add1abb" 30SRCREV = "2b3c2339616680537145a9cc2e7567575add1abb"