summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qttools.inc9
-rw-r--r--recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch32
-rw-r--r--recipes-qt/qt5/qttools_5.2.0.bb5
3 files changed, 46 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qttools.inc b/recipes-qt/qt5/qttools.inc
new file mode 100644
index 00000000..8412db49
--- /dev/null
+++ b/recipes-qt/qt5/qttools.inc
@@ -0,0 +1,9 @@
1require qt5.inc
2
3DEPENDS += "qtbase"
4
5SRC_URI += " \
6 file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \
7"
8
9FILES_${PN}-examples = "${datadir}/${QT_DIR_NAME}/examples"
diff --git a/recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch b/recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch
new file mode 100644
index 00000000..0f953338
--- /dev/null
+++ b/recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch
@@ -0,0 +1,32 @@
1From 26228d3ed02a4a244d01b3cc2bf3633f25797bb7 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 17 Jan 2014 14:33:19 +0100
4Subject: [PATCH] assistant/help: fix linking of dependent libraries
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9else we get:
10| ...ld: warning: libQt5CLucene.so.5, needed by ...libQt5Help.so, not found (try using -rpath or -rpath-link)
11| ...undefined reference to `QCLucenePhraseQuery::getTerms() const'
12
13Upstream-Status: Inappropriate [configuration]
14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16---
17 src/assistant/help/help.pro | 2 ++
18 1 file changed, 2 insertions(+)
19
20diff --git a/src/assistant/help/help.pro b/src/assistant/help/help.pro
21index ed75c37..a2c55c7 100644
22--- a/src/assistant/help/help.pro
23+++ b/src/assistant/help/help.pro
24@@ -70,3 +70,5 @@ HEADERS += qhelpenginecore.h \
25 # access to clucene
26 HEADERS += qhelpsearchindexwriter_clucene_p.h \
27 qhelpsearchindexreader_clucene_p.h
28+
29+LIBS += -lQt5CLucene
30--
311.8.3.1
32
diff --git a/recipes-qt/qt5/qttools_5.2.0.bb b/recipes-qt/qt5/qttools_5.2.0.bb
new file mode 100644
index 00000000..0effa1bf
--- /dev/null
+++ b/recipes-qt/qt5/qttools_5.2.0.bb
@@ -0,0 +1,5 @@
1require qt5-${PV}.inc
2require ${PN}.inc
3
4SRC_URI[md5sum] = "76a0992967b6d02220ecb69a5ba04ef1"
5SRC_URI[sha256sum] = "ff331510ecb776b3059953e216e9fa7a4c0736eeb148c4cf11acc8150811b7f0"