diff options
-rw-r--r-- | recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch | 33 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 1 |
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch b/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch new file mode 100644 index 00000000..7b681dce --- /dev/null +++ b/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 2e176e3d10535e4fdaa6ecc919538f66f4a2930d Mon Sep 17 00:00:00 2001 | ||
2 | From: Andy Nichols <andy.nichols@qt.io> | ||
3 | Date: Mon, 11 Jul 2016 09:18:33 +0200 | ||
4 | Subject: QWidgetBackingStore: Fix build with QT_NO_OPENGL | ||
5 | |||
6 | A define moved out of the #ifndef QT_NO_OPENGL scope. | ||
7 | |||
8 | Change-Id: I41c943b97f165b5171581e01f3a4b2d3fb25747e | ||
9 | Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io> | ||
10 | |||
11 | Upstream-Status: Backport | ||
12 | Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com> | ||
13 | --- | ||
14 | src/widgets/kernel/qwidgetbackingstore.cpp | 2 ++ | ||
15 | 1 file changed, 2 insertions(+) | ||
16 | |||
17 | diff --git a/src/widgets/kernel/qwidgetbackingstore.cpp b/src/widgets/kernel/qwidgetbackingstore.cpp | ||
18 | index 32aabce..242e625 100644 | ||
19 | --- a/src/widgets/kernel/qwidgetbackingstore.cpp | ||
20 | +++ b/src/widgets/kernel/qwidgetbackingstore.cpp | ||
21 | @@ -67,7 +67,9 @@ QT_BEGIN_NAMESPACE | ||
22 | |||
23 | extern QRegion qt_dirtyRegion(QWidget *); | ||
24 | |||
25 | +#ifndef QT_NO_OPENGL | ||
26 | Q_GLOBAL_STATIC(QPlatformTextureList, qt_dummy_platformTextureList) | ||
27 | +#endif | ||
28 | |||
29 | /** | ||
30 | * Flushes the contents of the \a backingStore into the screen area of \a widget. | ||
31 | -- | ||
32 | cgit v1.0-4-g1e03 | ||
33 | |||
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index f69c33cb..c82195db 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -26,6 +26,7 @@ SRC_URI += "\ | |||
26 | file://0008-configure-paths-for-target-qmake-properly.patch \ | 26 | file://0008-configure-paths-for-target-qmake-properly.patch \ |
27 | file://0009-Reorder-EGL-libraries-from-pkgconfig-and-defaults.patch \ | 27 | file://0009-Reorder-EGL-libraries-from-pkgconfig-and-defaults.patch \ |
28 | file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \ | 28 | file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \ |
29 | file://0013-Fix-build-with-QT_NO_OPENGL.patch \ | ||
29 | " | 30 | " |
30 | 31 | ||
31 | DEPENDS += "qtbase-native" | 32 | DEPENDS += "qtbase-native" |