diff options
author | Simon Aittamaa <simon.aittamaa@gmail.com> | 2016-01-29 09:23:30 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-02-01 16:23:18 +0100 |
commit | d6aeedb7f27b8dd02fa7e6fa193ce9e2e969ecf6 (patch) | |
tree | 7d0a6cadf1ac2a9b946e73f6d3f7bfda3170939f /recipes-qt | |
parent | 4a0acfa4111600b7cb5ae7b16cd6bfa5df2e2123 (diff) | |
download | meta-qt5-d6aeedb7f27b8dd02fa7e6fa193ce9e2e969ecf6.tar.gz |
qtbase: Fix installation of fonts and libraries
This patch fixes three problems
1) Running on a case-sensitive system would result in an error
due to invalid casing of pattern to install.
2) Using install on symlinks would cause multiple copies of the
same file to be installed on the target-system, since install
doesn't preserve symlinks. This wastes a lot of space and it
causes ldconfig to complain about non-symlinked files.
3) Leakage of user-ids, i.e. cp -a would preserve the uid/gid of
whoever built the files, which is usually not what you want.
Signed-off-by: Simon Aittamaa <simon.aittamaa@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index 8b6f509d..1db6b887 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -209,10 +209,10 @@ do_install_append() { | |||
209 | # install fonts manually if they are missing | 209 | # install fonts manually if they are missing |
210 | if [ ! -d ${D}/${OE_QMAKE_PATH_QT_FONTS} ]; then | 210 | if [ ! -d ${D}/${OE_QMAKE_PATH_QT_FONTS} ]; then |
211 | mkdir -p ${D}/${OE_QMAKE_PATH_QT_FONTS} | 211 | mkdir -p ${D}/${OE_QMAKE_PATH_QT_FONTS} |
212 | cp -a ${S}/lib/fonts/* ${D}/${OE_QMAKE_PATH_QT_FONTS} | 212 | cp -d ${S}/lib/fonts/* ${D}/${OE_QMAKE_PATH_QT_FONTS} |
213 | chown -R root:root ${D}/${OE_QMAKE_PATH_QT_FONTS} | 213 | chown -R root:root ${D}/${OE_QMAKE_PATH_QT_FONTS} |
214 | fi | 214 | fi |
215 | install -m 0644 ${B}/lib/libqt* ${D}${libdir} | 215 | cp -d ${B}/lib/libQt* ${D}${libdir} |
216 | # Remove example.pro file as it is useless | 216 | # Remove example.pro file as it is useless |
217 | rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro | 217 | rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro |
218 | 218 | ||