diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-09-25 12:26:22 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2018-09-25 23:34:28 +0000 |
commit | 333437ca8deffa2e2f9d02ae7165c03b4eacdb0d (patch) | |
tree | 999b87b810f83c4c9164fed1a7bf8958ac4fcd88 /recipes-qt | |
parent | 3ad2acb0e7d037de7cf9c137e97398a2eb9c42c5 (diff) | |
download | meta-qt5-333437ca8deffa2e2f9d02ae7165c03b4eacdb0d.tar.gz |
qt5-creator: Fix build due to missing lrelease
Fixes
make[2]:
/mnt/a/yoe/build/tmp/work/i586-yoe-linux-musl/qt5-creator/4.5.1-r0/recipe-sysroot/usr/bin/lrelease:
Command not found
make[2]: *** [Makefile:420: qtcreator_cs.qm] Error 127
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r-- | recipes-qt/qt5/qt5-creator/linguisttool.patch | 23 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-creator_4.5.1.bb | 5 |
2 files changed, 26 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qt5-creator/linguisttool.patch b/recipes-qt/qt5/qt5-creator/linguisttool.patch new file mode 100644 index 00000000..6f92d6ab --- /dev/null +++ b/recipes-qt/qt5/qt5-creator/linguisttool.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | Remove path prefix so it can find these tools from buildhost or native packages | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
5 | Index: qt-creator-opensource-src-4.5.1/share/qtcreator/translations/translations.pro | ||
6 | =================================================================== | ||
7 | --- qt-creator-opensource-src-4.5.1.orig/share/qtcreator/translations/translations.pro | ||
8 | +++ qt-creator-opensource-src-4.5.1/share/qtcreator/translations/translations.pro | ||
9 | @@ -12,10 +12,10 @@ defineReplace(prependAll) { | ||
10 | return($$result) | ||
11 | } | ||
12 | |||
13 | -XMLPATTERNS = $$shell_path($$[QT_INSTALL_BINS]/xmlpatterns) | ||
14 | -LUPDATE = $$shell_path($$[QT_INSTALL_BINS]/lupdate) -locations relative -no-ui-lines -no-sort | ||
15 | -LRELEASE = $$shell_path($$[QT_INSTALL_BINS]/lrelease) | ||
16 | -LCONVERT = $$shell_path($$[QT_INSTALL_BINS]/lconvert) | ||
17 | +XMLPATTERNS = $$OE_QMAKE_PATH_EXTERNAL_HOST_BINS/xmlpatterns | ||
18 | +LUPDATE = $$OE_QMAKE_PATH_EXTERNAL_HOST_BINS/lupdate -locations relative -no-ui-lines -no-sort | ||
19 | +LRELEASE = $$OE_QMAKE_PATH_EXTERNAL_HOST_BINS/lrelease | ||
20 | +LCONVERT = $$OE_QMAKE_PATH_EXTERNAL_HOST_BINS/lconvert | ||
21 | |||
22 | wd = $$replace(IDE_SOURCE_TREE, /, $$QMAKE_DIR_SEP) | ||
23 | |||
diff --git a/recipes-qt/qt5/qt5-creator_4.5.1.bb b/recipes-qt/qt5/qt5-creator_4.5.1.bb index 19980285..91db48cb 100644 --- a/recipes-qt/qt5/qt5-creator_4.5.1.bb +++ b/recipes-qt/qt5/qt5-creator_4.5.1.bb | |||
@@ -23,6 +23,7 @@ SRC_URI = " \ | |||
23 | http://download.qt.io/official_releases/qtcreator/4.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \ | 23 | http://download.qt.io/official_releases/qtcreator/4.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \ |
24 | file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \ | 24 | file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \ |
25 | file://botan-non-x86.patch \ | 25 | file://botan-non-x86.patch \ |
26 | file://linguisttool.patch \ | ||
26 | file://qtcreator.desktop.in \ | 27 | file://qtcreator.desktop.in \ |
27 | " | 28 | " |
28 | SRC_URI_append_libc-musl = " file://0002-Link-with-libexecinfo-on-musl.patch" | 29 | SRC_URI_append_libc-musl = " file://0002-Link-with-libexecinfo-on-musl.patch" |
@@ -51,8 +52,8 @@ do_install() { | |||
51 | chrpath --delete ${D}${libexecdir}/qtcreator/qtcreator_process_stub | 52 | chrpath --delete ${D}${libexecdir}/qtcreator/qtcreator_process_stub |
52 | chrpath --delete ${D}${libexecdir}/qtcreator/qbs_processlauncher | 53 | chrpath --delete ${D}${libexecdir}/qtcreator/qbs_processlauncher |
53 | chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/libqbscore.so.* | 54 | chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/libqbscore.so.* |
54 | chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libcomponentsplugin.so | 55 | test -e ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libcomponentsplugin.so && chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libcomponentsplugin.so |
55 | chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libqtquickplugin.so | 56 | test -e ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libqtquickplugin.so && chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libqtquickplugin.so |
56 | } | 57 | } |
57 | 58 | ||
58 | FILES_${PN} += " \ | 59 | FILES_${PN} += " \ |