diff options
author | Huang Qiyu <huangqy.fnst@cn.fujitsu.com> | 2017-07-25 09:30:23 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-08 20:44:12 +0200 |
commit | 6e9892aa3c675c74e32f3039ab5d210634ab878d (patch) | |
tree | c69bbf55902a0c48c7da2d4f8f9399a9814ad675 /recipes-qt | |
parent | 8960831c154848e42bc433871a7424d7d39ddbdc (diff) | |
download | meta-qt5-6e9892aa3c675c74e32f3039ab5d210634ab878d.tar.gz |
qtbase: add ptest
Add ptest for qtbase by using provided testsuite.
Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r-- | recipes-qt/qt5/qtbase/0001-Delete-qlonglong-and-qulonglong.patch | 28 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase/run-ptest | 6 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 17 |
3 files changed, 50 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase/0001-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0001-Delete-qlonglong-and-qulonglong.patch new file mode 100644 index 00000000..975cd28d --- /dev/null +++ b/recipes-qt/qt5/qtbase/0001-Delete-qlonglong-and-qulonglong.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From c67a4af2e5db4c1e2213961e6392b59affd1959f Mon Sep 17 00:00:00 2001 | ||
2 | From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> | ||
3 | Date: Wed, 7 Jun 2017 21:00:49 +0900 | ||
4 | Subject: [PATCH] Delete qlonglong and qulonglong | ||
5 | |||
6 | Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> | ||
7 | --- | ||
8 | tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro | 2 -- | ||
9 | 1 file changed, 2 deletions(-) | ||
10 | |||
11 | diff --git a/tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro b/tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro | ||
12 | index 09458bd..59a120e 100644 | ||
13 | --- a/tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro | ||
14 | +++ b/tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro | ||
15 | @@ -5,10 +5,8 @@ SUBDIRS=\ | ||
16 | char32_t \ | ||
17 | int \ | ||
18 | long \ | ||
19 | - qlonglong \ | ||
20 | qptrdiff \ | ||
21 | quintptr \ | ||
22 | - qulonglong \ | ||
23 | schar \ | ||
24 | short \ | ||
25 | uchar \ | ||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/recipes-qt/qt5/qtbase/run-ptest b/recipes-qt/qt5/qtbase/run-ptest new file mode 100644 index 00000000..044f834d --- /dev/null +++ b/recipes-qt/qt5/qtbase/run-ptest | |||
@@ -0,0 +1,6 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | for x in ` awk '{print $1}' tst_list `;do | ||
4 | ./${x}; | ||
5 | done | ||
6 | |||
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index 5cfbcfa9..8464873b 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -23,8 +23,12 @@ SRC_URI += "\ | |||
23 | file://0005-configure-bump-path-length-from-256-to-512-character.patch \ | 23 | file://0005-configure-bump-path-length-from-256-to-512-character.patch \ |
24 | file://0009-Disable-all-unknown-features-instead-of-erroring-out.patch \ | 24 | file://0009-Disable-all-unknown-features-instead-of-erroring-out.patch \ |
25 | file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \ | 25 | file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \ |
26 | file://0001-Delete-qlonglong-and-qulonglong.patch \ | ||
27 | file://run-ptest \ | ||
26 | " | 28 | " |
27 | 29 | ||
30 | inherit ptest | ||
31 | |||
28 | # only for target qtbase | 32 | # only for target qtbase |
29 | SRC_URI += "\ | 33 | SRC_URI += "\ |
30 | file://0008-configure-paths-for-target-qmake-properly.patch \ | 34 | file://0008-configure-paths-for-target-qmake-properly.patch \ |
@@ -48,7 +52,7 @@ PACKAGECONFIG_DISTRO ?= "" | |||
48 | PACKAGECONFIG_RELEASE ?= "release" | 52 | PACKAGECONFIG_RELEASE ?= "release" |
49 | # This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency | 53 | # This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency |
50 | # PACKAGECONFIG_OPENSSL ?= "openssl" | 54 | # PACKAGECONFIG_OPENSSL ?= "openssl" |
51 | PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype" | 55 | PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests" |
52 | 56 | ||
53 | PACKAGECONFIG ?= " \ | 57 | PACKAGECONFIG ?= " \ |
54 | ${PACKAGECONFIG_RELEASE} \ | 58 | ${PACKAGECONFIG_RELEASE} \ |
@@ -171,6 +175,17 @@ do_configure() { | |||
171 | ${QT_CONFIG_FLAGS} | 175 | ${QT_CONFIG_FLAGS} |
172 | } | 176 | } |
173 | 177 | ||
178 | fakeroot do_install_ptest() { | ||
179 | mkdir -p ${D}${PTEST_PATH} | ||
180 | t=${D}${PTEST_PATH} | ||
181 | for var in ` find ${B}/tests/auto/ -name tst_*`; do | ||
182 | if [ not ` echo ${var##*/} | grep '\.'` ]; then | ||
183 | echo ${var##*/} >> ${t}/tst_list | ||
184 | install -m 0644 ${var} ${t} | ||
185 | fi | ||
186 | done | ||
187 | } | ||
188 | |||
174 | do_install_append() { | 189 | do_install_append() { |
175 | # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory" | 190 | # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory" |
176 | touch ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/oe-device-extra.pri | 191 | touch ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/oe-device-extra.pri |