summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorGordan Markuš <gordan.markus@pelagicore.com>2017-04-11 16:04:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-12 16:05:25 +0200
commite03d290bc00105908280820d866e074440ab6f00 (patch)
tree94e72c914f7be1335ef015570d26ad909fedada8 /recipes-qt/qt5
parent5b0bb2babfa3b7116465d340cd1da2e9f9bedb78 (diff)
downloadmeta-qt5-e03d290bc00105908280820d866e074440ab6f00.tar.gz
qtwayland: fix initial window property values
This fixes a bug where there is nothing rendered on the QtWayland surface due to missing window properties. Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtwayland/0002-Fix-initial-window-property-values-being-propagated.patch35
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb5
2 files changed, 39 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwayland/0002-Fix-initial-window-property-values-being-propagated.patch b/recipes-qt/qt5/qtwayland/0002-Fix-initial-window-property-values-being-propagated.patch
new file mode 100644
index 00000000..29c9180c
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0002-Fix-initial-window-property-values-being-propagated.patch
@@ -0,0 +1,35 @@
1From 3d30fd8df9b55449844207295ad3d51cc8bb44b1 Mon Sep 17 00:00:00 2001
2From: Robert Griebl <robert.griebl@pelagicore.com>
3Date: Thu, 15 Dec 2016 17:43:00 +0100
4Subject: [PATCH 2/2] Fix initial window property values being propagated
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9This was broken since the the shell-surface refactoring.
10
11Change-Id: I130b7396e85c570a9d11d609af6b3016e3f706f0
12Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
13Reviewed-by: Paul Olav Tvete <paul.tvete@qt.io>
14Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com>
15---
16 src/client/qwaylandwindow.cpp | 3 +++
17 1 file changed, 3 insertions(+)
18
19diff --git a/src/client/qwaylandwindow.cpp b/src/client/qwaylandwindow.cpp
20index c8be9c1..b6f16f0 100644
21--- a/src/client/qwaylandwindow.cpp
22+++ b/src/client/qwaylandwindow.cpp
23@@ -176,6 +176,9 @@ void QWaylandWindow::initWindow()
24 mShellSurface->setAppId(appId);
25 }
26 }
27+ // the user may have already set some window properties, so make sure to send them out
28+ for (auto it = m_properties.cbegin(); it != m_properties.cend(); ++it)
29+ mShellSurface->sendProperty(it.key(), it.value());
30 }
31
32 // Enable high-dpi rendering. Scale() returns the screen scale factor and will
33--
342.9.3
35
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index d42d80a0..bcddb32c 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -44,6 +44,9 @@ EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
44SRCREV = "0e2a950895805457a45abe860bc91a7cc4ba405e" 44SRCREV = "0e2a950895805457a45abe860bc91a7cc4ba405e"
45 45
46# From https://bugreports.qt.io/browse/QTBUG-57767 46# From https://bugreports.qt.io/browse/QTBUG-57767
47SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch" 47SRC_URI += " \
48 file://0001-fix-build-without-xkbcommon-evdev.patch \
49 file://0002-Fix-initial-window-property-values-being-propagated.patch \
50"
48 51
49BBCLASSEXTEND =+ "native nativesdk" 52BBCLASSEXTEND =+ "native nativesdk"