summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-12 18:04:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-14 18:54:55 +0100
commit7ac1481d0a5b702af5ebedd1ac035bd5b67d666f (patch)
treea4a9eb093efe70b4e0dfeccaf58c98878026ce0a /recipes-qt/qt5
parentfd8fc6ffdb2e34b2921f06644264c405eee94f5d (diff)
downloadmeta-qt5-7ac1481d0a5b702af5ebedd1ac035bd5b67d666f.tar.gz
qt5: add Qml support to lupdate
Add dependency to qtdeclarative to qttools' native and nativesdk builds. This gives us lupdate with a support for Qml files. The nativesdk builds of qtdeclarative depend on more modules (Xml, Sql) from nativesdk-qtbase, so preserve all libs that are already built. This brings few extra libs to the package that might not be needed, but keeps the recipe simpler. Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb19
-rw-r--r--recipes-qt/qt5/qttools_git.bb3
2 files changed, 3 insertions, 19 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 3d4900eb..4ac80be4 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -49,6 +49,7 @@ PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
49FILES_${PN}-tools-dev = " \ 49FILES_${PN}-tools-dev = " \
50 ${includedir} \ 50 ${includedir} \
51 ${FILES_SOLIBSDEV} ${libdir}/*.la \ 51 ${FILES_SOLIBSDEV} ${libdir}/*.la \
52 ${libdir}/*.prl \
52 ${OE_QMAKE_PATH_ARCHDATA}/mkspecs \ 53 ${OE_QMAKE_PATH_ARCHDATA}/mkspecs \
53" 54"
54 55
@@ -201,16 +202,6 @@ do_configure() {
201 bin/qmake ${OE_QMAKE_DEBUG_OUTPUT} ${S} -o Makefile || die "Configuring qt with qmake failed. EXTRA_OECONF was ${EXTRA_OECONF}" 202 bin/qmake ${OE_QMAKE_DEBUG_OUTPUT} ${S} -o Makefile || die "Configuring qt with qmake failed. EXTRA_OECONF was ${EXTRA_OECONF}"
202} 203}
203 204
204# Set the EXTRA_QTLIB variable to e.g. Xml, in order to not remove libQt5Xml.so.*
205EXTRA_QTLIB ?= ""
206
207python __anonymous () {
208 templibs = ""
209 for e in d.getVar("EXTRA_QTLIB", True).split():
210 templibs = "%s -not -name 'libQt5%s.so*' -and" % (templibs, e)
211 d.setVar("QTLIBSPRESERVE", templibs)
212}
213
214do_install() { 205do_install() {
215 # Fix install paths for all 206 # Fix install paths for all
216 find -name "Makefile*" | xargs sed -i "s,(INSTALL_ROOT)${STAGING_DIR_NATIVE}${STAGING_DIR_NATIVE},(INSTALL_ROOT)${STAGING_DIR_NATIVE},g" 207 find -name "Makefile*" | xargs sed -i "s,(INSTALL_ROOT)${STAGING_DIR_NATIVE}${STAGING_DIR_NATIVE},(INSTALL_ROOT)${STAGING_DIR_NATIVE},g"
@@ -223,17 +214,11 @@ do_install() {
223 # e.g. qt3d, qtwayland 214 # e.g. qt3d, qtwayland
224 ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt 215 ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
225 216
226 # remove things unused in nativesdk, we need the headers, Qt5Core 217 # remove things unused in nativesdk, we need the headers and libs
227 # and Qt5Bootstrap.
228 rm -rf ${D}${datadir} \ 218 rm -rf ${D}${datadir} \
229 ${D}/${OE_QMAKE_PATH_PLUGINS} \ 219 ${D}/${OE_QMAKE_PATH_PLUGINS} \
230 ${D}${libdir}/cmake \ 220 ${D}${libdir}/cmake \
231 ${D}${libdir}/pkgconfig 221 ${D}${libdir}/pkgconfig
232 find ${D}${libdir} -maxdepth 1 -name 'lib*' -and -not -type d -and \
233 -not -name 'libQt5Core.so*' -and \
234 ${QTLIBSPRESERVE} \
235 -not -name 'libQt5Bootstrap.a' \
236 -exec rm '{}' ';'
237 222
238 # Install CMake's toolchain configuration 223 # Install CMake's toolchain configuration
239 mkdir -p ${D}${datadir}/cmake/OEToolchainConfig.cmake.d/ 224 mkdir -p ${D}${datadir}/cmake/OEToolchainConfig.cmake.d/
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 5ee1e865..8c22e757 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -10,8 +10,7 @@ LIC_FILES_CHKSUM = " \
10 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ 10 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
11" 11"
12 12
13DEPENDS += "qtbase" 13DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
14DEPENDS_class-target = "qtdeclarative qtxmlpatterns"
15 14
16SRC_URI += " \ 15SRC_URI += " \
17 file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch \ 16 file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch \