diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-01 17:36:38 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-06 19:45:45 +0200 |
commit | 26b7fee65a3c23a9c2447d549668f373bfa76bae (patch) | |
tree | fca7565930f8d7705cb5d96c5bc5ce6d7e561a0c /recipes-qt/qt5 | |
parent | 0663bcdddf0311329e607416cd51ce55b9557240 (diff) | |
download | meta-qt5-26b7fee65a3c23a9c2447d549668f373bfa76bae.tar.gz |
qtwebengine: Add 2 more patches to fix do_configure and fix QA warning
* otherwise moc generated files have the same basename and do_configure fails with:
core_generated.gyp:QtWebEngineCore#target has several files with the same basename:
| javascript_dialog_controller: javascript_dialog_controller.cpp
| /OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/qtwebengine/0.9.99+gitAUTOINC+21f6ce84ec-r0/git/src/core/.moc/moc_/OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/qtwebengine/0.9.99+gitAUTOI.moc+21f6ce84ec-r0/git/src/core/javascript_dialog_controller.cpp
...
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r-- | recipes-qt/qt5/qtwebengine.inc | 3 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine/0001-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch (renamed from recipes-qt/qt5/qtwebengine/0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch) | 6 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine/0001-chromium-Drop-build-time-only-dependency-on-x11-libr.patch (renamed from recipes-qt/qt5/qtwebengine/0001-Drop-build-time-only-dependency-on-x11-libraries.patch) | 10 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine/0002-chromium-Strip-unwanted-echo-compiling-prefix-from-C.patch (renamed from recipes-qt/qt5/qtwebengine/0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch) | 8 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine/0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch | 29 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine/0003-functions.prf-Try-to-add-_moc-suffix.patch | 34 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 8 |
7 files changed, 85 insertions, 13 deletions
diff --git a/recipes-qt/qt5/qtwebengine.inc b/recipes-qt/qt5/qtwebengine.inc index b6f56ae2..060faa7b 100644 --- a/recipes-qt/qt5/qtwebengine.inc +++ b/recipes-qt/qt5/qtwebengine.inc | |||
@@ -41,4 +41,7 @@ do_configure() { | |||
41 | QMAKE_AR="${OE_QMAKE_AR}" | 41 | QMAKE_AR="${OE_QMAKE_AR}" |
42 | } | 42 | } |
43 | 43 | ||
44 | do_install_append() { | ||
45 | rmdir ${D}${OE_QMAKE_PATH_PLUGINS}/${BPN} ${D}${OE_QMAKE_PATH_PLUGINS} || true | ||
46 | } | ||
44 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" | 47 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" |
diff --git a/recipes-qt/qt5/qtwebengine/0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch b/recipes-qt/qt5/qtwebengine/0001-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch index c64b32a4..397929f4 100644 --- a/recipes-qt/qt5/qtwebengine/0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch +++ b/recipes-qt/qt5/qtwebengine/0001-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 2fe53c4c28f91941ee3b446e88f519feb2edc457 Mon Sep 17 00:00:00 2001 | 1 | From daf8cd1ccd533d5546ff3a11d19710e0f155cc68 Mon Sep 17 00:00:00 2001 |
2 | From: Simon Busch <morphis@gravedo.de> | 2 | From: Simon Busch <morphis@gravedo.de> |
3 | Date: Fri, 20 Jun 2014 09:09:12 +0200 | 3 | Date: Fri, 20 Jun 2014 09:09:12 +0200 |
4 | Subject: [PATCH 2/2] Use ninja supplied by environment variable NINJA_PATH | 4 | Subject: [PATCH 1/3] Use ninja supplied by environment variable NINJA_PATH |
5 | 5 | ||
6 | Signed-off-by: Simon Busch <morphis@gravedo.de> | 6 | Signed-off-by: Simon Busch <morphis@gravedo.de> |
7 | --- | 7 | --- |
@@ -32,5 +32,5 @@ index 4dcd8ed..8725fd2 100644 | |||
32 | + return($$NINJA_PATH) | 32 | + return($$NINJA_PATH) |
33 | } | 33 | } |
34 | -- | 34 | -- |
35 | 1.9.1 | 35 | 2.0.0 |
36 | 36 | ||
diff --git a/recipes-qt/qt5/qtwebengine/0001-Drop-build-time-only-dependency-on-x11-libraries.patch b/recipes-qt/qt5/qtwebengine/0001-chromium-Drop-build-time-only-dependency-on-x11-libr.patch index 7ee38d0c..abd351a6 100644 --- a/recipes-qt/qt5/qtwebengine/0001-Drop-build-time-only-dependency-on-x11-libraries.patch +++ b/recipes-qt/qt5/qtwebengine/0001-chromium-Drop-build-time-only-dependency-on-x11-libr.patch | |||
@@ -1,11 +1,13 @@ | |||
1 | From f5c8e973f0a246691b71c256361bfa82619ee2ef Mon Sep 17 00:00:00 2001 | 1 | From 0c59430e6b919d4ffec80bfa6b50b9ce9953ac21 Mon Sep 17 00:00:00 2001 |
2 | From: Simon Busch <morphis@gravedo.de> | 2 | From: Simon Busch <morphis@gravedo.de> |
3 | Date: Fri, 20 Jun 2014 09:05:12 +0200 | 3 | Date: Fri, 20 Jun 2014 09:05:12 +0200 |
4 | Subject: [PATCH 1/2] Drop build time only dependency on x11 libraries | 4 | Subject: [PATCH 1/2] <chromium> Drop build time only dependency on x11 |
5 | libraries | ||
5 | 6 | ||
6 | Signed-off-by: Simon Busch <morphis@gravedo.de> | 7 | Signed-off-by: Simon Busch <morphis@gravedo.de> |
8 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
7 | --- | 9 | --- |
8 | src/3rdparty/chromium/build/linux/system.gyp | 114 --------------------------- | 10 | chromium/build/linux/system.gyp | 114 ---------------------------------------- |
9 | 1 file changed, 114 deletions(-) | 11 | 1 file changed, 114 deletions(-) |
10 | 12 | ||
11 | diff --git a/src/3rdparty/chromium/build/linux/system.gyp b/src/3rdparty/chromium/build/linux/system.gyp | 13 | diff --git a/src/3rdparty/chromium/build/linux/system.gyp b/src/3rdparty/chromium/build/linux/system.gyp |
@@ -133,5 +135,5 @@ index 9911317..85016b8 100644 | |||
133 | ], | 135 | ], |
134 | } | 136 | } |
135 | -- | 137 | -- |
136 | 1.9.1 | 138 | 2.0.0 |
137 | 139 | ||
diff --git a/recipes-qt/qt5/qtwebengine/0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch b/recipes-qt/qt5/qtwebengine/0002-chromium-Strip-unwanted-echo-compiling-prefix-from-C.patch index 6b315985..0cbe7aa4 100644 --- a/recipes-qt/qt5/qtwebengine/0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch +++ b/recipes-qt/qt5/qtwebengine/0002-chromium-Strip-unwanted-echo-compiling-prefix-from-C.patch | |||
@@ -1,7 +1,8 @@ | |||
1 | From 7a3179fee9c88ce3dd018b2f159e1b5df74fc7cc Mon Sep 17 00:00:00 2001 | 1 | From faaba972642f1966b4e38394b022d79de114c71e Mon Sep 17 00:00:00 2001 |
2 | From: Simon Busch <morphis@gravedo.de> | 2 | From: Simon Busch <morphis@gravedo.de> |
3 | Date: Fri, 20 Jun 2014 19:04:14 +0200 | 3 | Date: Fri, 20 Jun 2014 19:04:14 +0200 |
4 | Subject: [PATCH] Strip unwanted "@echo compiling &&" prefix from ${CC} | 4 | Subject: [PATCH 2/2] <chromium> Strip unwanted "@echo compiling &&" prefix |
5 | from ${CC} | ||
5 | 6 | ||
6 | Causes problems when called from a perl script: | 7 | Causes problems when called from a perl script: |
7 | 8 | ||
@@ -15,6 +16,7 @@ Traceback (most recent call last): | |||
15 | AssertionError | 16 | AssertionError |
16 | 17 | ||
17 | Signed-off-by: Simon Busch <morphis@gravedo.de> | 18 | Signed-off-by: Simon Busch <morphis@gravedo.de> |
19 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
18 | --- | 20 | --- |
19 | .../WebKit/Source/build/scripts/action_useragentstylesheets.py | 3 +++ | 21 | .../WebKit/Source/build/scripts/action_useragentstylesheets.py | 3 +++ |
20 | 1 file changed, 3 insertions(+) | 22 | 1 file changed, 3 insertions(+) |
@@ -34,5 +36,5 @@ index c0712b3..8460637 100644 | |||
34 | # assert. | 36 | # assert. |
35 | returnCode = subprocess.call(command) | 37 | returnCode = subprocess.call(command) |
36 | -- | 38 | -- |
37 | 1.9.1 | 39 | 2.0.0 |
38 | 40 | ||
diff --git a/recipes-qt/qt5/qtwebengine/0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch b/recipes-qt/qt5/qtwebengine/0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch new file mode 100644 index 00000000..d9b75eb0 --- /dev/null +++ b/recipes-qt/qt5/qtwebengine/0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From fd954d63f62c551c5aeaab662b7ab42a3f2ab527 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Mon, 30 Jun 2014 20:08:17 +0200 | ||
4 | Subject: [PATCH 2/3] functions.prf: Don't match QMAKE_EXT_CPP or QMAKE_EXT_H | ||
5 | anywhere in patch, but at the end | ||
6 | |||
7 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
8 | --- | ||
9 | tools/qmake/mkspecs/features/functions.prf | 4 ++-- | ||
10 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
11 | |||
12 | diff --git a/tools/qmake/mkspecs/features/functions.prf b/tools/qmake/mkspecs/features/functions.prf | ||
13 | index 8725fd2..15c2941 100644 | ||
14 | --- a/tools/qmake/mkspecs/features/functions.prf | ||
15 | +++ b/tools/qmake/mkspecs/features/functions.prf | ||
16 | @@ -40,8 +40,8 @@ defineReplace(findIncludedMocFiles) { | ||
17 | defineReplace(mocOutput) { | ||
18 | out = $$1 | ||
19 | # The order is important, since the output of the second replace would end up accidentaly transformed by the first one | ||
20 | - out = $$replace(out, ^(.*)($$join(QMAKE_EXT_CPP,|)), $${QMAKE_CPP_MOD_MOC}\\1$${QMAKE_EXT_CPP_MOC}) | ||
21 | - out = $$replace(out, ^(.*)($$join(QMAKE_EXT_H,|)), $${QMAKE_H_MOD_MOC}\\1$${first(QMAKE_EXT_CPP)}) | ||
22 | + out = $$replace(out, ^(.*)($$join(QMAKE_EXT_CPP,|))$, $${QMAKE_CPP_MOD_MOC}\\1$${QMAKE_EXT_CPP_MOC}) | ||
23 | + out = $$replace(out, ^(.*)($$join(QMAKE_EXT_H,|))$, $${QMAKE_H_MOD_MOC}\\1$${first(QMAKE_EXT_CPP)}) | ||
24 | return($$out) | ||
25 | } | ||
26 | |||
27 | -- | ||
28 | 2.0.0 | ||
29 | |||
diff --git a/recipes-qt/qt5/qtwebengine/0003-functions.prf-Try-to-add-_moc-suffix.patch b/recipes-qt/qt5/qtwebengine/0003-functions.prf-Try-to-add-_moc-suffix.patch new file mode 100644 index 00000000..bc5a75cc --- /dev/null +++ b/recipes-qt/qt5/qtwebengine/0003-functions.prf-Try-to-add-_moc-suffix.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 5089c3d10f13874e503f5548f40341d8f59e229f Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Tue, 1 Jul 2014 15:58:16 +0200 | ||
4 | Subject: [PATCH 3/3] functions.prf: Try to add _moc suffix | ||
5 | |||
6 | * otherwise moc generated files have the same basename and do_configure fails with: | ||
7 | core_generated.gyp:QtWebEngineCore#target has several files with the same basename: | ||
8 | | javascript_dialog_controller: javascript_dialog_controller.cpp | ||
9 | | /OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/qtwebengine/0.9.99+gitAUTOINC+21f6ce84ec-r0/git/src/core/.moc/moc_/OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/qtwebengine/0.9.99+gitAUTOI.moc+21f6ce84ec-r0/git/src/core/javascript_dialog_controller.cpp | ||
10 | ... | ||
11 | |||
12 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
13 | --- | ||
14 | tools/qmake/mkspecs/features/functions.prf | 4 ++-- | ||
15 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/tools/qmake/mkspecs/features/functions.prf b/tools/qmake/mkspecs/features/functions.prf | ||
18 | index 15c2941..78b1190 100644 | ||
19 | --- a/tools/qmake/mkspecs/features/functions.prf | ||
20 | +++ b/tools/qmake/mkspecs/features/functions.prf | ||
21 | @@ -40,8 +40,8 @@ defineReplace(findIncludedMocFiles) { | ||
22 | defineReplace(mocOutput) { | ||
23 | out = $$1 | ||
24 | # The order is important, since the output of the second replace would end up accidentaly transformed by the first one | ||
25 | - out = $$replace(out, ^(.*)($$join(QMAKE_EXT_CPP,|))$, $${QMAKE_CPP_MOD_MOC}\\1$${QMAKE_EXT_CPP_MOC}) | ||
26 | - out = $$replace(out, ^(.*)($$join(QMAKE_EXT_H,|))$, $${QMAKE_H_MOD_MOC}\\1$${first(QMAKE_EXT_CPP)}) | ||
27 | + out = $$replace(out, ^(.*)($$join(QMAKE_EXT_CPP,|))$, $${QMAKE_CPP_MOD_MOC}\\1_moc$${QMAKE_EXT_CPP_MOC}) | ||
28 | + out = $$replace(out, ^(.*)($$join(QMAKE_EXT_H,|))$, $${QMAKE_H_MOD_MOC}\\1_moc$${first(QMAKE_EXT_CPP)}) | ||
29 | return($$out) | ||
30 | } | ||
31 | |||
32 | -- | ||
33 | 2.0.0 | ||
34 | |||
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index f4964bf7..d06c5214 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -14,9 +14,11 @@ QT_MODULE_BRANCH = "master" | |||
14 | SRC_URI = " \ | 14 | SRC_URI = " \ |
15 | git://gitorious.org/qt-labs/qtwebengine.git;name=qtwebengine;protocol=git;branch=${QT_MODULE_BRANCH} \ | 15 | git://gitorious.org/qt-labs/qtwebengine.git;name=qtwebengine;protocol=git;branch=${QT_MODULE_BRANCH} \ |
16 | git://gitorious.org/qt-labs/chromium.git;name=chromium;protocol=git;branch=${QT_MODULE_BRANCH};destsuffix=git/src/3rdparty \ | 16 | git://gitorious.org/qt-labs/chromium.git;name=chromium;protocol=git;branch=${QT_MODULE_BRANCH};destsuffix=git/src/3rdparty \ |
17 | file://0001-Drop-build-time-only-dependency-on-x11-libraries.patch \ | 17 | file://0001-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch \ |
18 | file://0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch \ | 18 | file://0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ |
19 | file://0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch \ | 19 | file://0003-functions.prf-Try-to-add-_moc-suffix.patch \ |
20 | file://0001-chromium-Drop-build-time-only-dependency-on-x11-libr.patch \ | ||
21 | file://0002-chromium-Strip-unwanted-echo-compiling-prefix-from-C.patch \ | ||
20 | " | 22 | " |
21 | SRCREV_qtwebengine = "21f6ce84ecca9a4ff2aa980b21d2e5174c78d14b" | 23 | SRCREV_qtwebengine = "21f6ce84ecca9a4ff2aa980b21d2e5174c78d14b" |
22 | SRCREV_chromium = "1f3cc8c2618979b557d60ef1ad984a49dca83bff" | 24 | SRCREV_chromium = "1f3cc8c2618979b557d60ef1ad984a49dca83bff" |