summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-09-25 23:31:07 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-26 20:56:01 +0000
commit0cf5966d395f8d0a58dafd5153e5fb8047e4bce0 (patch)
tree1394785a4bd234477b8c983586e5d9e5f0d6203c /recipes-qt/qt5
parent4fb1e6084c7fec8e5e5667bca6e4a4ddfd8b500e (diff)
downloadmeta-qt5-0cf5966d395f8d0a58dafd5153e5fb8047e4bce0.tar.gz
qt5-creator: upgrade to 4.7.1+
botan was replaced with botan2 in: http://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?h=4.7&id=a44fe2e4f03fc18ce9c3d050f71fe369916259b8 lets see if we still need those fixes for botan Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch91
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Use-correct-path-prefix.patch (renamed from recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch)4
-rw-r--r--recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch (renamed from recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch)2
-rw-r--r--recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch28
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb (renamed from recipes-qt/qt5/qt5-creator_4.5.1.bb)20
5 files changed, 12 insertions, 133 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch b/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
deleted file mode 100644
index ea336360..00000000
--- a/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
+++ /dev/null
@@ -1,91 +0,0 @@
1From 231e0cf0c764d3b63cd5ec788ac0ee901b47fc8e Mon Sep 17 00:00:00 2001
2From: Greg Nietsky <gregory@distrotech.co.za>
3Date: Tue, 4 Mar 2014 11:33:40 +0200
4Subject: [PATCH] Fix: Allow qt-creator to build on arm aarch32 and aarch64
5
6Botan is imported hardwired for x86 this small patch allows it
7too operate on arm other platforms could be added.
8
9Task-number: QTCREATORBUG-8107
10Change-Id: Iddea28f21c9fa1afd2fdd5d16a44e6c96a516a7a
11---
12 src/libs/3rdparty/botan/botan.cpp | 16 +++++++++++++++-
13 src/libs/3rdparty/botan/botan.h | 2 ++
14 2 files changed, 17 insertions(+), 1 deletion(-)
15
16diff --git a/src/libs/3rdparty/botan/botan.cpp b/src/libs/3rdparty/botan/botan.cpp
17index 87736d5fe3..2e950d88bf 100644
18--- a/src/libs/3rdparty/botan/botan.cpp
19+++ b/src/libs/3rdparty/botan/botan.cpp
20@@ -1101,6 +1101,8 @@ class Montgomery_Exponentiator : public Modular_Exponentiator
21
22 #if (BOTAN_MP_WORD_BITS != 32)
23 #error The mp_x86_32 module requires that BOTAN_MP_WORD_BITS == 32
24+#elif !defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
25+typedef Botan::u64bit dword;
26 #endif
27
28 #ifdef Q_OS_UNIX
29@@ -1118,6 +1120,7 @@ extern "C" {
30 */
31 inline word word_madd2(word a, word b, word* c)
32 {
33+#if defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
34 asm(
35 ASM("mull %[b]")
36 ASM("addl %[c],%[a]")
37@@ -1127,6 +1130,11 @@ inline word word_madd2(word a, word b, word* c)
38 : "0"(a), "1"(b), [c]"g"(*c) : "cc");
39
40 return a;
41+#else
42+ dword z = (dword)a * b + *c;
43+ *c = (word)(z >> BOTAN_MP_WORD_BITS);
44+ return (word)z;
45+#endif
46 }
47
48 /*
49@@ -1134,6 +1142,7 @@ inline word word_madd2(word a, word b, word* c)
50 */
51 inline word word_madd3(word a, word b, word c, word* d)
52 {
53+#if defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
54 asm(
55 ASM("mull %[b]")
56
57@@ -1147,6 +1156,11 @@ inline word word_madd3(word a, word b, word c, word* d)
58 : "0"(a), "1"(b), [c]"g"(c), [d]"g"(*d) : "cc");
59
60 return a;
61+#else
62+ dword z = (dword)a * b + c + *d;
63+ *d = (word)(z >> BOTAN_MP_WORD_BITS);
64+ return (word)z;
65+#endif
66 }
67
68 }
69@@ -2315,7 +2329,7 @@ namespace Botan {
70
71 extern "C" {
72
73-#ifdef Q_OS_UNIX
74+#if defined(Q_OS_UNIX) && defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
75 /*
76 * Helper Macros for x86 Assembly
77 */
78diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h
79index d7b90cc92f..26ca8aca37 100644
80--- a/src/libs/3rdparty/botan/botan.h
81+++ b/src/libs/3rdparty/botan/botan.h
82@@ -85,7 +85,9 @@
83 #endif
84
85 #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
86+#if !defined(__arm__) && !defined(__aarch64__)
87 #define BOTAN_TARGET_CPU_IS_X86_FAMILY
88+#endif
89 #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
90
91 #if defined(BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN) || \
diff --git a/recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch b/recipes-qt/qt5/qt5-creator/0001-Use-correct-path-prefix.patch
index 1c589cad..c064a9a9 100644
--- a/recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch
+++ b/recipes-qt/qt5/qt5-creator/0001-Use-correct-path-prefix.patch
@@ -1,4 +1,4 @@
1From 22ff2f705ee47d41c41a0a39bbda454ce54f9819 Mon Sep 17 00:00:00 2001 1From 50443809cc261a3f466cdebd3fa2dd4dda6e6a28 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 25 Sep 2018 23:15:08 +0000 3Date: Tue, 25 Sep 2018 23:15:08 +0000
4Subject: [PATCH] Use correct path prefix 4Subject: [PATCH] Use correct path prefix
@@ -12,7 +12,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12 1 file changed, 4 insertions(+), 4 deletions(-) 12 1 file changed, 4 insertions(+), 4 deletions(-)
13 13
14diff --git a/share/qtcreator/translations/translations.pro b/share/qtcreator/translations/translations.pro 14diff --git a/share/qtcreator/translations/translations.pro b/share/qtcreator/translations/translations.pro
15index 5f752f2855..87bc3d9cab 100644 15index 0df9762fcc..de09bc47ed 100644
16--- a/share/qtcreator/translations/translations.pro 16--- a/share/qtcreator/translations/translations.pro
17+++ b/share/qtcreator/translations/translations.pro 17+++ b/share/qtcreator/translations/translations.pro
18@@ -12,10 +12,10 @@ defineReplace(prependAll) { 18@@ -12,10 +12,10 @@ defineReplace(prependAll) {
diff --git a/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch b/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch
index 93938428..9b225a57 100644
--- a/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch
+++ b/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch
@@ -1,4 +1,4 @@
1From 9841dfba76dba7812405418049f259802cd06163 Mon Sep 17 00:00:00 2001 1From 88afa7173c7d0c97e15d9ee9c58e8c0364799bb7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 16 Jan 2018 13:26:57 +0000 3Date: Tue, 16 Jan 2018 13:26:57 +0000
4Subject: [PATCH] Link with libexecinfo on musl 4Subject: [PATCH] Link with libexecinfo on musl
diff --git a/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch b/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch
deleted file mode 100644
index 32671815..00000000
--- a/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 925868614c475d9e90bff8d9a33525f5d65d907c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 25 Sep 2018 23:17:42 +0000
4Subject: [PATCH] botan: check for i386 || x86_64
5
6Just check for x86 or x86_64 to define X86 based support
7This makes sure it compiles for non-x86 platforms
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12---
13 src/libs/3rdparty/botan/botan.h | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h
17index 26ca8aca37..969405c56e 100644
18--- a/src/libs/3rdparty/botan/botan.h
19+++ b/src/libs/3rdparty/botan/botan.h
20@@ -85,7 +85,7 @@
21 #endif
22
23 #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
24-#if !defined(__arm__) && !defined(__aarch64__)
25+#if defined(__i386__) || defined(__x86_64__)
26 #define BOTAN_TARGET_CPU_IS_X86_FAMILY
27 #endif
28 #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
diff --git a/recipes-qt/qt5/qt5-creator_4.5.1.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 6451b334..482b10d0 100644
--- a/recipes-qt/qt5/qt5-creator_4.5.1.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -17,21 +17,19 @@ inherit qmake5
17DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native" 17DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native"
18DEPENDS_append_libc-musl = " libexecinfo" 18DEPENDS_append_libc-musl = " libexecinfo"
19 19
20# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.5.1 20SRCREV = "8768e39d3c8e74e583eca3897cc6de53a99c3dde"
21# 4.5.1.meta-qt5.2 21PV = "4.7.1+git${SRCPV}"
22
23# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.7.1
24# 4.7.1.meta-qt5.1
22SRC_URI = " \ 25SRC_URI = " \
23 http://download.qt.io/official_releases/qtcreator/4.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \ 26 git://code.qt.io/qt-creator/qt-creator.git;branch=4.7 \
24 file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \ 27 file://0001-Use-correct-path-prefix.patch \
25 file://0002-Use-correct-path-prefix.patch \
26 file://0003-botan-check-for-i386-x86_64.patch \
27 file://qtcreator.desktop.in \ 28 file://qtcreator.desktop.in \
28" 29"
29SRC_URI_append_libc-musl = " file://0004-Link-with-libexecinfo-on-musl.patch" 30SRC_URI_append_libc-musl = " file://0002-Link-with-libexecinfo-on-musl.patch"
30
31SRC_URI[md5sum] = "bd7fdbcdfa84df1171fb28174353e57f"
32SRC_URI[sha256sum] = "5fdfc8f05694e37162f208616627262c9971749d6958d8881d62933b3b53e909"
33 31
34S = "${WORKDIR}/qt-creator-opensource-src-${PV}" 32S = "${WORKDIR}/git"
35 33
36EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}${QT_DIR_NAME}" 34EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}${QT_DIR_NAME}"
37 35