diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-07-08 13:56:10 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-07-22 16:25:56 -0300 |
commit | ecf7db0bd5012162d5fff5cb25f9a07a1a6e084a (patch) | |
tree | 1223586feba860cd855e84aecc3db9ca57b58586 /recipes-qt/qt5 | |
parent | 15a4f86005e4435b9e0a2f1e7d0477e327fcbe83 (diff) | |
download | meta-qt5-ecf7db0bd5012162d5fff5cb25f9a07a1a6e084a.tar.gz |
qtwayland: Rework recipe to allow PACKAGECONFIG use
The Qt Wayland uses some modules which can be enabled/disabled
depending on users needs, however this must be deterministic. So we
now use PACKAGECONFIG to enable/disable those features. Following
options are available:
- brcm-egl
- compositor-api
- drm-egl
- glx
- libhybris-egl
- wayland-egl
- xcompositor
- xkb
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Acked-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r-- | recipes-qt/qt5/qtwayland_git.bb | 29 |
1 files changed, 19 insertions, 10 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb index e36d2c0a..df42f309 100644 --- a/recipes-qt/qt5/qtwayland_git.bb +++ b/recipes-qt/qt5/qtwayland_git.bb | |||
@@ -1,6 +1,8 @@ | |||
1 | require qt5.inc | 1 | require qt5.inc |
2 | require qt5-git.inc | 2 | require qt5-git.inc |
3 | 3 | ||
4 | DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native" | ||
5 | |||
4 | # There are no LGPLv3-only licensed files in this component. | 6 | # There are no LGPLv3-only licensed files in this component. |
5 | LICENSE = "BSD & (LGPL-2.1 & The-Qt-Company-Qt-LGPL-Exception-1.1 | LGPL-3.0)" | 7 | LICENSE = "BSD & (LGPL-2.1 & The-Qt-Company-Qt-LGPL-Exception-1.1 | LGPL-3.0)" |
6 | LIC_FILES_CHKSUM = " \ | 8 | LIC_FILES_CHKSUM = " \ |
@@ -11,18 +13,25 @@ LIC_FILES_CHKSUM = " \ | |||
11 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | 13 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ |
12 | " | 14 | " |
13 | 15 | ||
14 | # wayland-native is already in wayland DEPENDS, but add it here | 16 | #FIXME: xkb should be optional; we add it here to fix the build error without it |
15 | # explicitly, because it's native wayland-scanner we're looking for | 17 | # (https://bugreports.qt.io/browse/QTBUG-54851) |
16 | # libxkbcommon isn't mandatory make it easier to remove by .bbappend | 18 | PACKAGECONFIG ?= " \ |
17 | # (e.g. for building qtwayland with danny which doesn't have libxkbcommon in oe-core). | 19 | compositor-api \ |
18 | XKB_DEPENDS = "libxkbcommon xproto" | 20 | wayland-egl \ |
19 | DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native ${XKB_DEPENDS} ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite', '', d)}" | 21 | xkb \ |
22 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcompositor xkb glx', '', d)} \ | ||
23 | " | ||
20 | 24 | ||
21 | QT_WAYLAND_CONFIG ?= "wayland-compositor" | 25 | PACKAGECONFIG[compositor-api] = "CONFIG+=wayland-compositor" |
22 | QT_WAYLAND_DEFINES ?= "" | 26 | PACKAGECONFIG[xcompositor] = "CONFIG+=config_xcomposite CONFIG+=done_config_xcomposite,CONFIG+=done_config_xcomposite,libxcomposite" |
27 | PACKAGECONFIG[glx] = "CONFIG+=config_glx CONFIG+=done_config_glx,CONFIG+=done_config_glx,virtual/mesa" | ||
28 | PACKAGECONFIG[xkb] = "CONFIG+=config_xkbcommon CONFIG+=done_config_xkbcommon,CONFIG+=done_config_xkbcommon,libxkbcommon xproto" | ||
29 | PACKAGECONFIG[wayland-egl] = "CONFIG+=config_wayland_egl CONFIG+=done_config_wayland_egl,CONFIG+=done_config_wayland_egl,virtual/egl" | ||
30 | PACKAGECONFIG[brcm-egl] = "CONFIG+=config_brcm_egl CONFIG+=done_config_brcm_egl,CONFIG+=done_config_brcm_egl,virtual/egl" | ||
31 | PACKAGECONFIG[drm-egl] = "CONFIG+=config_drm_egl_server CONFIG+=done_config_drm_egl_server,CONFIG+=done_config_drm_egl_server,libdrm virtual/egl" | ||
32 | PACKAGECONFIG[libhybris-egl] = "CONFIG+=config_libhybris_egl_server CONFIG+=done_config_libhybris_egl_server,CONFIG+=done_config_libhybris_egl_server,libhybris" | ||
23 | 33 | ||
24 | EXTRA_QMAKEVARS_PRE += "CONFIG+=${QT_WAYLAND_CONFIG}" | 34 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" |
25 | EXTRA_QMAKEVARS_PRE += "DEFINES+=${QT_WAYLAND_DEFINES}" | ||
26 | 35 | ||
27 | FILES_${PN}-plugins += " \ | 36 | FILES_${PN}-plugins += " \ |
28 | ${OE_QMAKE_PATH_PLUGINS}/*/*/*${SOLIBSDEV} \ | 37 | ${OE_QMAKE_PATH_PLUGINS}/*/*/*${SOLIBSDEV} \ |