diff options
author | Huang Qiyu <huangqy.fnst@cn.fujitsu.com> | 2017-07-12 12:58:39 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-12 10:24:57 +0200 |
commit | ec8c62e06c9b07323f2a3379bd0e405f06956ced (patch) | |
tree | e1af5eb0ad763cb0513def6a8fdd6242d3eed987 /recipes-qt/qt5 | |
parent | 05455e605ba75ad12fc6a29630e53ccfa74609e4 (diff) | |
download | meta-qt5-ec8c62e06c9b07323f2a3379bd0e405f06956ced.tar.gz |
qtxmlpatterns: add ptest
Add ptest for qttools by using provided testsuite in qtxmlpatterns.
Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r-- | recipes-qt/qt5/qtxmlpatterns/run-ptest | 6 | ||||
-rw-r--r-- | recipes-qt/qt5/qtxmlpatterns_git.bb | 2 |
2 files changed, 8 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtxmlpatterns/run-ptest b/recipes-qt/qt5/qtxmlpatterns/run-ptest new file mode 100644 index 00000000..044f834d --- /dev/null +++ b/recipes-qt/qt5/qtxmlpatterns/run-ptest | |||
@@ -0,0 +1,6 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | for x in ` awk '{print $1}' tst_list `;do | ||
4 | ./${x}; | ||
5 | done | ||
6 | |||
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb index c7efaf3f..9333be0b 100644 --- a/recipes-qt/qt5/qtxmlpatterns_git.bb +++ b/recipes-qt/qt5/qtxmlpatterns_git.bb | |||
@@ -1,5 +1,6 @@ | |||
1 | require qt5.inc | 1 | require qt5.inc |
2 | require qt5-git.inc | 2 | require qt5-git.inc |
3 | require qt5-ptest.inc | ||
3 | 4 | ||
4 | LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )" | 5 | LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )" |
5 | LIC_FILES_CHKSUM = " \ | 6 | LIC_FILES_CHKSUM = " \ |
@@ -19,3 +20,4 @@ DEPENDS += "qtbase" | |||
19 | SRCREV = "9f7e01b582b1bd83cc6b8a854c510871335e2e74" | 20 | SRCREV = "9f7e01b582b1bd83cc6b8a854c510871335e2e74" |
20 | 21 | ||
21 | BBCLASSEXTEND =+ "native nativesdk" | 22 | BBCLASSEXTEND =+ "native nativesdk" |
23 | |||