summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorJohannes Pointner <johannes.pointner@br-automation.com>2016-08-10 16:50:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-31 19:11:59 +0200
commitc2ddf663e22937cb64a7fb343892806d473b978f (patch)
tree4f45cae6cd6308fe05c52b09084fc044e172aeaa /recipes-qt/qt5
parentd9cd5ede502ddf04767d5531340b12050ee7f899 (diff)
downloadmeta-qt5-c2ddf663e22937cb64a7fb343892806d473b978f.tar.gz
qtbase: Fix build with QT_NO_OPENGL
This fixes the build of qtbase without opengl support Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch33
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch b/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch
new file mode 100644
index 00000000..7b681dce
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch
@@ -0,0 +1,33 @@
1From 2e176e3d10535e4fdaa6ecc919538f66f4a2930d Mon Sep 17 00:00:00 2001
2From: Andy Nichols <andy.nichols@qt.io>
3Date: Mon, 11 Jul 2016 09:18:33 +0200
4Subject: QWidgetBackingStore: Fix build with QT_NO_OPENGL
5
6A define moved out of the #ifndef QT_NO_OPENGL scope.
7
8Change-Id: I41c943b97f165b5171581e01f3a4b2d3fb25747e
9Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
10
11Upstream-Status: Backport
12Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com>
13---
14 src/widgets/kernel/qwidgetbackingstore.cpp | 2 ++
15 1 file changed, 2 insertions(+)
16
17diff --git a/src/widgets/kernel/qwidgetbackingstore.cpp b/src/widgets/kernel/qwidgetbackingstore.cpp
18index 32aabce..242e625 100644
19--- a/src/widgets/kernel/qwidgetbackingstore.cpp
20+++ b/src/widgets/kernel/qwidgetbackingstore.cpp
21@@ -67,7 +67,9 @@ QT_BEGIN_NAMESPACE
22
23 extern QRegion qt_dirtyRegion(QWidget *);
24
25+#ifndef QT_NO_OPENGL
26 Q_GLOBAL_STATIC(QPlatformTextureList, qt_dummy_platformTextureList)
27+#endif
28
29 /**
30 * Flushes the contents of the \a backingStore into the screen area of \a widget.
31--
32cgit v1.0-4-g1e03
33
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index f69c33cb..c82195db 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -26,6 +26,7 @@ SRC_URI += "\
26 file://0008-configure-paths-for-target-qmake-properly.patch \ 26 file://0008-configure-paths-for-target-qmake-properly.patch \
27 file://0009-Reorder-EGL-libraries-from-pkgconfig-and-defaults.patch \ 27 file://0009-Reorder-EGL-libraries-from-pkgconfig-and-defaults.patch \
28 file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \ 28 file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
29 file://0013-Fix-build-with-QT_NO_OPENGL.patch \
29" 30"
30 31
31DEPENDS += "qtbase-native" 32DEPENDS += "qtbase-native"