diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2016-02-19 11:08:27 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-02 15:16:52 +0200 |
commit | 9758a7aff69fde12b7b2cf82f1934edd6abc9e77 (patch) | |
tree | 0128a731a8867c1be6fa48311591921660a15df1 /recipes-qt/qt5 | |
parent | bf2cafa909a27250f853a823e9d7101307337e7a (diff) | |
download | meta-qt5-9758a7aff69fde12b7b2cf82f1934edd6abc9e77.tar.gz |
qtbase: Remove unsupported options xvideo, xinerama, xinput, gtkstyle
* xvideo and xinerama were removed in:
commit e824abd987d77efaa085fe1f9fb514d270798d55
Author: Alexander Volkov <a.volkov@rusbitech.ru>
Date: Tue Oct 13 18:43:25 2015 +0300
configure: Remove unused options -xvideo and -xinerama
-xvideo was not used even by Qt 4 for a long time.
-xinerama was used by the xlib plugin which was dropped
by e6a7a6a381c0b61a93a642b425ecbcd714fd1c29.
* xinput was removed in:
commit fa8dbbff8895e7e1fdf1e6b0a9f3d821cd2caf2f
Author: Alexander Volkov <a.volkov@rusbitech.ru>
Date: Thu Oct 8 18:19:39 2015 +0300
configure: Remove -xinput option
It's obsolete since e6a7a6a381c0b61a93a642b425ecbcd714fd1c29
(Remove xlib plugin) and a2337f79ffd229aa1e91f6bfec6294570eb3fe44
(Remove Windows and X11 from src/widgets/platforms).
The actual option is -xinput2.
* gtkstyle was removed (partially replaced with gtk) in:
commit 899a815414e95da8d9429a4a4f4d7094e49cfc55
Author: Dmitry Shachnev <mitya57@gmail.com>
Date: Thu Jul 30 21:32:43 2015 +0300
Remove gtk2 style from qtbase, it will be moved to qtstyleplugins
This will allow us to drop gtk2 support from qtbase in future,
while still providing the gtk2 style for those who want to use it.
Also with moving to qtstyleplugins, the code can be simplified
because we can directly link to libraries we need, instead of using
QLibrary.
[ChangeLog][QtWidgets] Remove QGtkStyle, it is now provided in
qtstyleplugins repository.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 7 |
1 files changed, 2 insertions, 5 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index 051ec89d..42a57e84 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -36,7 +36,7 @@ RDEPENDS_${PN}-tools += "perl" | |||
36 | 36 | ||
37 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}" | 37 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}" |
38 | PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}" | 38 | PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}" |
39 | PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xvideo xsync xshape xrender xrandr xfixes xinput2 xinput xinerama xcursor glib gtkstyle xkb', '', d)}" | 39 | PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xsync xshape xrender xrandr xfixes xinput2 xcursor glib xkb', '', d)}" |
40 | PACKAGECONFIG_FONTS ?= "" | 40 | PACKAGECONFIG_FONTS ?= "" |
41 | PACKAGECONFIG_SYSTEM ?= "jpeg libpng zlib" | 41 | PACKAGECONFIG_SYSTEM ?= "jpeg libpng zlib" |
42 | PACKAGECONFIG_MULTIMEDIA ?= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}" | 42 | PACKAGECONFIG_MULTIMEDIA ?= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}" |
@@ -96,15 +96,12 @@ PACKAGECONFIG[sql-db2] = "-sql-db2,-no-sql-db2" | |||
96 | PACKAGECONFIG[sql-sqlite2] = "-sql-sqlite2,-no-sql-sqlite2,sqlite" | 96 | PACKAGECONFIG[sql-sqlite2] = "-sql-sqlite2,-no-sql-sqlite2,sqlite" |
97 | PACKAGECONFIG[sql-sqlite] = "-sql-sqlite -system-sqlite,-no-sql-sqlite,sqlite3" | 97 | PACKAGECONFIG[sql-sqlite] = "-sql-sqlite -system-sqlite,-no-sql-sqlite,sqlite3" |
98 | PACKAGECONFIG[xcursor] = "-xcursor,-no-xcursor,libxcursor" | 98 | PACKAGECONFIG[xcursor] = "-xcursor,-no-xcursor,libxcursor" |
99 | PACKAGECONFIG[xinerama] = "-xinerama,-no-xinerama,libxinerama" | ||
100 | PACKAGECONFIG[xinput] = "-xinput,-no-xinput" | ||
101 | PACKAGECONFIG[xinput2] = "-xinput2,-no-xinput2,libxi" | 99 | PACKAGECONFIG[xinput2] = "-xinput2,-no-xinput2,libxi" |
102 | PACKAGECONFIG[xfixes] = "-xfixes,-no-xfixes,libxfixes" | 100 | PACKAGECONFIG[xfixes] = "-xfixes,-no-xfixes,libxfixes" |
103 | PACKAGECONFIG[xrandr] = "-xrandr,-no-xrandr,libxrandr" | 101 | PACKAGECONFIG[xrandr] = "-xrandr,-no-xrandr,libxrandr" |
104 | PACKAGECONFIG[xrender] = "-xrender,-no-xrender,libxrender" | 102 | PACKAGECONFIG[xrender] = "-xrender,-no-xrender,libxrender" |
105 | PACKAGECONFIG[xshape] = "-xshape,-no-xshape" | 103 | PACKAGECONFIG[xshape] = "-xshape,-no-xshape" |
106 | PACKAGECONFIG[xsync] = "-xsync,-no-xsync" | 104 | PACKAGECONFIG[xsync] = "-xsync,-no-xsync" |
107 | PACKAGECONFIG[xvideo] = "-xvideo,-no-xvideo" | ||
108 | PACKAGECONFIG[openvg] = "-openvg,-no-openvg" | 105 | PACKAGECONFIG[openvg] = "-openvg,-no-openvg" |
109 | PACKAGECONFIG[iconv] = "-iconv,-no-iconv,virtual/libiconv" | 106 | PACKAGECONFIG[iconv] = "-iconv,-no-iconv,virtual/libiconv" |
110 | PACKAGECONFIG[xkb] = "-xkb,-no-xkb -no-xkbcommon,libxkbcommon" | 107 | PACKAGECONFIG[xkb] = "-xkb,-no-xkb -no-xkbcommon,libxkbcommon" |
@@ -113,7 +110,7 @@ PACKAGECONFIG[evdev] = "-evdev,-no-evdev" | |||
113 | PACKAGECONFIG[mtdev] = "-mtdev,-no-mtdev,mtdev" | 110 | PACKAGECONFIG[mtdev] = "-mtdev,-no-mtdev,mtdev" |
114 | # depends on glib | 111 | # depends on glib |
115 | PACKAGECONFIG[fontconfig] = "-fontconfig,-no-fontconfig,fontconfig" | 112 | PACKAGECONFIG[fontconfig] = "-fontconfig,-no-fontconfig,fontconfig" |
116 | PACKAGECONFIG[gtkstyle] = "-gtkstyle,-no-gtkstyle,gtk+" | 113 | PACKAGECONFIG[gtk] = "-gtk,-no-gtk,gtk+" |
117 | PACKAGECONFIG[directfb] = "-directfb,-no-directfb,directfb" | 114 | PACKAGECONFIG[directfb] = "-directfb,-no-directfb,directfb" |
118 | PACKAGECONFIG[linuxfb] = "-linuxfb,-no-linuxfb" | 115 | PACKAGECONFIG[linuxfb] = "-linuxfb,-no-linuxfb" |
119 | PACKAGECONFIG[mitshm] = "-mitshm,-no-mitshm,mitshm" | 116 | PACKAGECONFIG[mitshm] = "-mitshm,-no-mitshm,mitshm" |