diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2015-05-28 14:58:06 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-05-28 21:16:50 +0200 |
commit | 48ee17af942ac9860e834c8dec049370e7802a56 (patch) | |
tree | 004e47c94682eaa418c9e718c3264ca121732102 /recipes-qt/qt5/qtwebengine_git.bb | |
parent | 3208763b8b3f65b17825ded4b2c9b9166d78f2b2 (diff) | |
download | meta-qt5-48ee17af942ac9860e834c8dec049370e7802a56.tar.gz |
qt5: merge .inc and _git.bb files
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 72 |
1 files changed, 71 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index 81c53335..c14a556c 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -1,5 +1,75 @@ | |||
1 | SUMMARY = "QtWebEngine combines the power of Chromium and Qt" | ||
2 | |||
3 | LICENSE = "LGPL-3.0 & BSD" | ||
4 | LIC_FILES_CHKSUM = " \ | ||
5 | file://src/core/browser_context_qt.cpp;md5=91895ac1852e1b07202d9716194e8dd8;beginline=1;endline=35 \ | ||
6 | file://src/3rdparty/chromium/LICENSE;md5=537e0b52077bf0a616d0a0c8a79bc9d5 \ | ||
7 | file://LICENSE.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | ||
8 | " | ||
9 | |||
10 | DEPENDS += " \ | ||
11 | ninja-native \ | ||
12 | qtbase qtdeclarative qtxmlpatterns qtquickcontrols \ | ||
13 | libdrm fontconfig pixman openssl pango cairo icu pciutils \ | ||
14 | libcap \ | ||
15 | " | ||
16 | |||
17 | COMPATIBLE_MACHINE = "(-)" | ||
18 | COMPATIBLE_MACHINE_i586 = "(.*)" | ||
19 | COMPATIBLE_MACHINE_x86-64 = "(.*)" | ||
20 | COMPATIBLE_MACHINE_armv6 = "(.*)" | ||
21 | COMPATIBLE_MACHINE_armv7a = "(.*)" | ||
22 | |||
23 | inherit qmake5 | ||
24 | inherit gettext | ||
25 | inherit pythonnative | ||
26 | inherit perlnative | ||
27 | |||
28 | require qt5.inc | ||
1 | require qt5-git.inc | 29 | require qt5-git.inc |
2 | require ${PN}.inc | 30 | |
31 | # To avoid trouble start with not separated build directory | ||
32 | SEPB = "${S}" | ||
33 | B = "${SEPB}" | ||
34 | |||
35 | # Project ERROR: Missing CMake tests. Either create tests in tests/auto/cmake, or disable cmake config file creation with CONFIG-=create_cmake. | ||
36 | EXTRA_QMAKEVARS_POST += "CONFIG-=create_cmake" | ||
37 | |||
38 | export NINJA_PATH="${STAGING_BINDIR_NATIVE}/ninja" | ||
39 | |||
40 | do_configure() { | ||
41 | # replace LD with CXX, to workaround a possible gyp inheritssue? | ||
42 | export LD="${CXX}" | ||
43 | export CC="${CC}" | ||
44 | export CXX="${CXX}" | ||
45 | export CC_host="gcc" | ||
46 | export CXX_host="g++" | ||
47 | export QMAKE_MAKE_ARGS="${EXTRA_OEMAKE}" | ||
48 | |||
49 | # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as | ||
50 | # arguments here | ||
51 | ${OE_QMAKE_QMAKE} -r ${EXTRA_QMAKEVARS_PRE} QTWEBENGINE_ROOT="${S}" \ | ||
52 | QMAKE_CXX="${OE_QMAKE_CXX}" QMAKE_CC="${OE_QMAKE_CC}" \ | ||
53 | QMAKE_LINK="${OE_QMAKE_LINK}" \ | ||
54 | QMAKE_CFLAGS="${OE_QMAKE_CFLAGS}" \ | ||
55 | QMAKE_CXXFLAGS="${OE_QMAKE_CXXFLAGS}" \ | ||
56 | QMAKE_AR="${OE_QMAKE_AR}" \ | ||
57 | -after ${EXTRA_QMAKEVARS_POST} | ||
58 | } | ||
59 | |||
60 | do_install_append() { | ||
61 | rmdir ${D}${OE_QMAKE_PATH_PLUGINS}/${BPN} ${D}${OE_QMAKE_PATH_PLUGINS} || true | ||
62 | } | ||
63 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" | ||
64 | |||
65 | # for /usr/share/qt5/qtwebengine_resources.pak | ||
66 | FILES_${PN} += "${OE_QMAKE_PATH_QT_TRANSLATIONS} ${OE_QMAKE_PATH_QT_DATA}" | ||
67 | |||
68 | RDEPENDS_${PN}-examples += " \ | ||
69 | ${PN}-qmlplugins \ | ||
70 | qtquickcontrols-qmlplugins \ | ||
71 | qtdeclarative-qmlplugins \ | ||
72 | " | ||
3 | 73 | ||
4 | QT_MODULE_BRANCH = "5.4" | 74 | QT_MODULE_BRANCH = "5.4" |
5 | QT_MODULE_BRANCH_CHROMIUM = "37.0.2062-based" | 75 | QT_MODULE_BRANCH_CHROMIUM = "37.0.2062-based" |