summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qttools_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-08-25 14:43:49 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 20:49:29 +0200
commita6df86ea4becebb434b13e6fe1c62760494d81d5 (patch)
tree27f4858f301bbc67c52fb63eeaef84c305d5fc8a /recipes-qt/qt5/qttools_git.bb
parent22c28fee3cbd394ae1b261854637696b1f5deeb5 (diff)
downloadmeta-qt5-a6df86ea4becebb434b13e6fe1c62760494d81d5.tar.gz
qttools: use one recipe for all compilations
Instead of separate recipes for target, native and nativesdk, use one recipe with BBCLASSEXTEND in place. Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qttools_git.bb')
-rw-r--r--recipes-qt/qt5/qttools_git.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index afc89849..a13fb747 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -9,9 +9,11 @@ LIC_FILES_CHKSUM = " \
9 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ 9 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
10" 10"
11 11
12DEPENDS += "qtbase qtdeclarative qtxmlpatterns" 12DEPENDS += "qtbase"
13DEPENDS_class-target = "qtdeclarative qtxmlpatterns"
13 14
14SRC_URI += " \ 15SRC_URI += " \
16 file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch \
15 file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \ 17 file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \
16 file://0003-add-noqtwebkit-configuration.patch \ 18 file://0003-add-noqtwebkit-configuration.patch \
17" 19"
@@ -20,8 +22,14 @@ FILES_${PN}-tools += "${datadir}/${QT_DIR_NAME}/phrasebooks"
20FILES_${PN}-examples = "${datadir}/${QT_DIR_NAME}/examples" 22FILES_${PN}-examples = "${datadir}/${QT_DIR_NAME}/examples"
21 23
22PACKAGECONFIG ??= "" 24PACKAGECONFIG ??= ""
25PACKAGECONFIG_class-native ??= "linguistonly"
26PACKAGECONFIG_class-nativesdk ??= "linguistonly"
27PACKAGECONFIG[linguistonly] = ""
23PACKAGECONFIG[qtwebkit] = ",,qtwebkit" 28PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
24 29
25EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}" 30EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
31EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'linguistonly', 'CONFIG+=linguistonly', '', d)}"
26 32
27SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c" 33SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c"
34
35BBCLASSEXTEND = "native nativesdk"