summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qttools_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-02-01 08:39:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2018-02-22 13:56:45 +0000
commit5250890a9f7b42a77711dfe9a3adcf86b576c2a8 (patch)
tree2f75c5d9d0a852eafe9d3b980825c41b8155e504 /recipes-qt/qt5/qttools_git.bb
parent3f2f3a014e19ba6c23bca85b8fd1a46a85294c58 (diff)
downloadmeta-qt5-5250890a9f7b42a77711dfe9a3adcf86b576c2a8.tar.gz
qt5: refactor ptest
Current implementation was causing build issues as it cluttered source directories and modified recipe sysroot content. Tests are now build in the separate build directory ${B} where we don't need to worry about moving files to the recipe sysroot, and if tests are enabled in PACKAGECONFIG, they have been already built during do_compile task. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qttools_git.bb')
-rw-r--r--recipes-qt/qt5/qttools_git.bb15
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 2187f9c3..dad5ba81 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -1,5 +1,6 @@
1require qt5.inc 1require qt5.inc
2require qt5-git.inc 2require qt5-git.inc
3require qt5-ptest.inc
3 4
4HOMEPAGE = "http://www.qt.io" 5HOMEPAGE = "http://www.qt.io"
5LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )" 6LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
@@ -11,14 +12,11 @@ LIC_FILES_CHKSUM = " \
11 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ 12 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
12" 13"
13 14
14inherit ptest
15
16DEPENDS += "qtbase qtdeclarative qtxmlpatterns" 15DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
17 16
18# Patches from https://github.com/meta-qt5/qttools/commits/b5.10 17# Patches from https://github.com/meta-qt5/qttools/commits/b5.10
19# 5.10.meta-qt5.1 18# 5.10.meta-qt5.1
20SRC_URI += " \ 19SRC_URI += " \
21 file://run-ptest \
22 file://0001-add-noqtwebkit-configuration.patch \ 20 file://0001-add-noqtwebkit-configuration.patch \
23 file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \ 21 file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \
24" 22"
@@ -35,16 +33,9 @@ SRCREV = "3ce89dc37d3c73033c18dcec9e4710afd747ce01"
35 33
36BBCLASSEXTEND = "native nativesdk" 34BBCLASSEXTEND = "native nativesdk"
37 35
38do_compile_ptest() {
39 export PATH=${STAGING_DIR_NATIVE}/usr/include/qt5:$PATH
40 cd ${S}/tests
41 qmake -o Makefile tests.pro
42 oe_runmake
43}
44
45do_install_ptest() { 36do_install_ptest() {
46 mkdir -p ${D}${PTEST_PATH} 37 mkdir -p ${D}${PTEST_PATH}
47 t=${D}${PTEST_PATH} 38 t=${D}${PTEST_PATH}
48 cp ${S}/tests/auto/qtdiag/tst_tdiag $t 39 cp ${B}/tests/auto/qtdiag/tst_tdiag $t
49 cp ${S}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t 40 cp ${B}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t
50} 41}