summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase-native_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-01-26 16:54:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-26 16:18:39 +0100
commit333949a8239dfa7788b35f1059614733e11a6a25 (patch)
tree420843abad8bfc939484fa34bd6f7da9d432db8d /recipes-qt/qt5/qtbase-native_git.bb
parentc0ba8ab590ba4e17a2a04925cf48915233d4f493 (diff)
downloadmeta-qt5-333949a8239dfa7788b35f1059614733e11a6a25.tar.gz
Upgrade to Qt 5.8
The linux-oe-g++ mkspec is changed to use $$(...) operator to obtain the contents of an environment value when qmake is run instead of when Makefile is processed. All OE_QMAKE_xxx variables need to be exported for qmake to find them. configure's setBootstrapVariable function needs to change $$(..) to normal $(...) operator to work with qmake's Makefile. qt.conf generation for qtbase recipes is not needed, as configure will generate its own version based on configure arguments. Skip running qmake, since configure is now automatically invoked when it's run in qtbase's root folder. Update PACKAGECONFIGs for qtbase to match current configure options. The new Qt configuration system [1] can be used with a new variable EXTRA_QMAKEVARS_CONFIGURE, which takes both command line and feature arguments. Merge the two qtwayland recipes to one that supports all three targets (target, native, nativesdk) without need for additional patch. Recipes for new Qt modules: QtSCXML, QtNetworkAuth, QtGamepad. Removes qtdeclarative-render2d [1] https://www.mail-archive.com/development@qt-project.org/msg25257.html Change-Id: Ib37c4d7323e8b45aa2b171e8427b6ec15aaee213 Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase-native_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb31
1 files changed, 6 insertions, 25 deletions
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 4da56405..ba1be2c1 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -22,33 +22,22 @@ require qt5-git.inc
22# common for qtbase-native, qtbase-nativesdk and qtbase 22# common for qtbase-native, qtbase-nativesdk and qtbase
23SRC_URI += "\ 23SRC_URI += "\
24 file://0001-Add-linux-oe-g-platform.patch \ 24 file://0001-Add-linux-oe-g-platform.patch \
25 file://0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
26 file://0003-Add-external-hostbindir-option.patch \ 25 file://0003-Add-external-hostbindir-option.patch \
27 file://0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch \ 26 file://0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch \
28 file://0005-configure-bump-path-length-from-256-to-512-character.patch \ 27 file://0005-configure-bump-path-length-from-256-to-512-character.patch \
29 file://0006-QOpenGLPaintDevice-sub-area-support.patch \
30 file://0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
31 file://0008-configure-paths-for-target-qmake-properly.patch \ 28 file://0008-configure-paths-for-target-qmake-properly.patch \
32 file://0009-Reorder-EGL-libraries-from-pkgconfig-and-defaults.patch \ 29 file://0009-Disable-all-unknown-features-instead-of-erroring-out.patch \
33 file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \ 30 file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
34" 31"
35 32
36# common for qtbase-native and nativesdk-qtbase 33# common for qtbase-native and nativesdk-qtbase
37SRC_URI += " \ 34SRC_URI += " \
38 file://0011-Always-build-uic.patch \ 35 file://0011-Always-build-uic.patch \
39 file://0012-Add-external-hostbindir-option-for-native-sdk.patch \
40" 36"
41 37
42CLEANBROKEN = "1" 38CLEANBROKEN = "1"
43 39
44QT_CONF_PATH = "${B}/qt.conf"
45
46do_generate_qt_config_file() {
47 :
48}
49
50PACKAGECONFIG_CONFARGS = " \ 40PACKAGECONFIG_CONFARGS = " \
51 -prefix ${prefix} \
52 -sysroot ${STAGING_DIR_NATIVE} \ 41 -sysroot ${STAGING_DIR_NATIVE} \
53 -no-gcc-sysroot \ 42 -no-gcc-sysroot \
54 -system-zlib \ 43 -system-zlib \
@@ -68,11 +57,15 @@ PACKAGECONFIG_CONFARGS = " \
68 -verbose \ 57 -verbose \
69 -release \ 58 -release \
70 -prefix ${OE_QMAKE_PATH_PREFIX} \ 59 -prefix ${OE_QMAKE_PATH_PREFIX} \
60 -hostprefix ${OE_QMAKE_PATH_PREFIX} \
71 -bindir ${OE_QMAKE_PATH_BINS} \ 61 -bindir ${OE_QMAKE_PATH_BINS} \
62 -hostbindir ${OE_QMAKE_PATH_BINS} \
72 -libdir ${OE_QMAKE_PATH_LIBS} \ 63 -libdir ${OE_QMAKE_PATH_LIBS} \
64 -hostlibdir ${OE_QMAKE_PATH_LIBS} \
73 -headerdir ${OE_QMAKE_PATH_HEADERS} \ 65 -headerdir ${OE_QMAKE_PATH_HEADERS} \
74 -archdatadir ${OE_QMAKE_PATH_ARCHDATA} \ 66 -archdatadir ${OE_QMAKE_PATH_ARCHDATA} \
75 -datadir ${OE_QMAKE_PATH_DATA} \ 67 -datadir ${OE_QMAKE_PATH_DATA} \
68 -hostdatadir ${QMAKE_MKSPEC_PATH_NATIVE} \
76 -docdir ${OE_QMAKE_PATH_DOCS} \ 69 -docdir ${OE_QMAKE_PATH_DOCS} \
77 -sysconfdir ${OE_QMAKE_PATH_SETTINGS} \ 70 -sysconfdir ${OE_QMAKE_PATH_SETTINGS} \
78 -no-glib \ 71 -no-glib \
@@ -84,20 +77,8 @@ PACKAGECONFIG_CONFARGS = " \
84 -platform linux-oe-g++ \ 77 -platform linux-oe-g++ \
85" 78"
86 79
87# qtbase is exception, configure script is using our get(X)QEvalMakeConf and setBootstrapEvalVariable functions to read it from shell
88export OE_QMAKE_COMPILER
89export OE_QMAKE_CC
90export OE_QMAKE_CFLAGS
91export OE_QMAKE_CXX
92export OE_QMAKE_CXXFLAGS
93export OE_QMAKE_LINK
94export OE_QMAKE_LDFLAGS
95export OE_QMAKE_AR
96export OE_QMAKE_STRIP
97
98do_configure_prepend() { 80do_configure_prepend() {
99 MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -opensource -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}" 81 MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -opensource -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
100 bin/qmake ${OE_QMAKE_DEBUG_OUTPUT} ${S} -o Makefile || die "Configuring qt with qmake failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
101} 82}
102 83
103do_install() { 84do_install() {
@@ -123,4 +104,4 @@ do_install() {
123 ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt 104 ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
124} 105}
125 106
126SRCREV = "69b43e74d78e050cf5e40197acafa4bc9f90c0bd" 107SRCREV = "49dc9aa409d727824f26b246054a22b5a7dd5980"