diff options
author | Stefan Schmidt <stefan@datenfreihafen.org> | 2013-09-28 22:25:14 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-10-05 14:42:08 +0200 |
commit | d691c447784646688b3b0445d63359a7d9292926 (patch) | |
tree | 1af4ae2c2cdd56821e8c93823fed9c3db8e6e4e6 /recipes-qt/maliit/maliit-framework-qt5_git.bb | |
parent | f4188229f100349f4c88340b62a37d3ebfe51cc5 (diff) | |
download | meta-qt5-d691c447784646688b3b0445d63359a7d9292926.tar.gz |
maliit: Import maliit recipes from meta-oe
* Imported from rev 13ae5105ee30410136beeae66ec41ee4a8a2e2b0
This is the first step to move these recipes over to qt5.
* maliit-framework-qt5: Build with qt5
Switch to new github repo
Update SRCREV and remove patches which now longer apply
Disable doc generation and xcb
Fix packaging
* maliit-plugins-qt5: Build with qt5.
Switch to new github repo
Update SRCREV and PV
Fix packaging
* maliit-*-qt5: Adjust MKSPEC path
* meta-framework-qt5: Cleanup packaging and enable dbus activation.
Move pkgconfig files, headers and spec files into dev.
Cleanup packaging rules
Enable dbus activation to start maliit server on demand
* maliit-plugins-qt5: Set MALIIT_PLUGINS_DATA_DIR to avoid path leakage from host
If not overriden here MALIIT_PLUGINS_DATA_DIR would point to some host
paths resulting in e.g. qml files not being found.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Stefan Schmidt <stefan@datenfreihafen.org>
Diffstat (limited to 'recipes-qt/maliit/maliit-framework-qt5_git.bb')
-rw-r--r-- | recipes-qt/maliit/maliit-framework-qt5_git.bb | 98 |
1 files changed, 98 insertions, 0 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb new file mode 100644 index 00000000..ccd0c4cb --- /dev/null +++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb | |||
@@ -0,0 +1,98 @@ | |||
1 | DESCRIPTION = "A virtual keyboard for touch-screen based user interfaces" | ||
2 | HOMEPAGE = "https://wiki.maliit.org/Main_Page" | ||
3 | |||
4 | LICENSE = "LGPLv2.1" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad" | ||
6 | |||
7 | inherit qmake5 | ||
8 | |||
9 | # Set path of qt5 headers as qmake5_base.bbclass sets this to just ${includedir} | ||
10 | # but | ||
11 | # actually it is ${includedir}/qt5 | ||
12 | OE_QMAKE_PATH_HEADERS = "${OE_QMAKE_PATH_QT_HEADERS}" | ||
13 | |||
14 | |||
15 | SRC_URI = "git://github.com/maliit/framework.git;branch=master \ | ||
16 | file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ | ||
17 | file://maliit-server.desktop \ | ||
18 | " | ||
19 | |||
20 | SRCREV = "dbc0403f329d7f6ce2f5a09e6ff5adbd2548a8c9" | ||
21 | PV = "0.99.0+git${SRCPV}" | ||
22 | |||
23 | |||
24 | PACKAGES =+ "${PN}-gtk" | ||
25 | GTKIMMODULES_PACKAGES = "${PN}-gtk" | ||
26 | |||
27 | # FIXME: Do we need something like this with qt5? | ||
28 | #RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4" | ||
29 | |||
30 | RRECOMMENDS_${PN} = "maliit-plugins-qt5" | ||
31 | |||
32 | FILES_${PN} += "\ | ||
33 | ${libdir}/*.so* \ | ||
34 | ${bindir} \ | ||
35 | ${datadir}/applications/maliit-server.desktop \ | ||
36 | ${datadir}/dbus-1 \ | ||
37 | " | ||
38 | |||
39 | FILES_${PN}-dbg += "\ | ||
40 | ${libdir}/maliit-framework-tests \ | ||
41 | " | ||
42 | |||
43 | FILES_${PN}-dev += "\ | ||
44 | ${includedir}/maliit \ | ||
45 | ${libdir}/pkgconfig \ | ||
46 | ${libdir}/qt5 \ | ||
47 | " | ||
48 | |||
49 | EXTRA_QMAKEVARS_PRE = "\ | ||
50 | PREFIX=${prefix} \ | ||
51 | LIBDIR=${libdir} \ | ||
52 | QT_IM_PLUGIN_PATH=${libdir}/qt4/plugins/inputmethods \ | ||
53 | MALIIT_INSTALL_PRF=${QMAKE_MKSPEC_PATH}/mkspecs/features \ | ||
54 | SCHEMADIR=${sysconfdir}/gconf/schemas \ | ||
55 | CONFIG+=disable-gconf \ | ||
56 | CONFIG+=disable-gtk-cache-update \ | ||
57 | CONFIG+=local-install \ | ||
58 | CONFIG+=nosdk \ | ||
59 | CONFIG+=nodoc \ | ||
60 | CONFIG+=noxcb \ | ||
61 | CONFIG+=enable-dbus-activation \ | ||
62 | " | ||
63 | |||
64 | EXTRA_OEMAKE += "INSTALL_ROOT=${D}" | ||
65 | |||
66 | do_install_append() { | ||
67 | #Fix absolute paths | ||
68 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${libdir}/${QT_DIR_NAME}/mkspecs/features/maliit-framework.prf | ||
69 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${libdir}/${QT_DIR_NAME}/mkspecs/features/maliit-plugins.prf | ||
70 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${libdir}/${QT_DIR_NAME}/mkspecs/features/maliit-defines.prf | ||
71 | |||
72 | install -d ${D}${datadir}/applications | ||
73 | install -m 644 ${WORKDIR}/maliit-server.desktop ${D}${datadir}/applications | ||
74 | } | ||
75 | |||
76 | pkg_postinst_${PN} () { | ||
77 | #!/bin/sh | ||
78 | # should run online | ||
79 | if [ "x$D" != "x" ]; then | ||
80 | exit 1 | ||
81 | fi | ||
82 | echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile | ||
83 | ln -s /usr/share/applications/maliit-server.desktop /etc/xdg/autostart/maliit-server.desktop | ||
84 | } | ||
85 | |||
86 | pkg_postrm_${PN} () { | ||
87 | #!/bin/sh | ||
88 | # should run online | ||
89 | if [ "x$D" = "x" ]; then | ||
90 | exit 1 | ||
91 | fi | ||
92 | if [ -e "/etc/xprofile" ]; then | ||
93 | sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile | ||
94 | fi | ||
95 | rm -f /etc/xdg/autostart/maliit-server.desktop | ||
96 | } | ||
97 | |||
98 | S = "${WORKDIR}/git" | ||