diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-10-29 12:16:06 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-11-03 22:39:09 +0100 |
commit | faa07fc3a61f16a5de5b548f74c155a81dd86190 (patch) | |
tree | c36de8675bc1b0affdc42c42797a501d7cadbd51 /recipes-devtools | |
parent | f11778340c574de8cf46b9980a4f8c5b1fa50410 (diff) | |
download | meta-qt5-faa07fc3a61f16a5de5b548f74c155a81dd86190.tar.gz |
cmake: Rename and update .bbappend to match new version from oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/cmake/cmake_2.8.11.2.bbappend | 7 | ||||
-rw-r--r-- | recipes-devtools/cmake/cmake_2.8.12.bbappend | 20 |
2 files changed, 20 insertions, 7 deletions
diff --git a/recipes-devtools/cmake/cmake_2.8.11.2.bbappend b/recipes-devtools/cmake/cmake_2.8.11.2.bbappend deleted file mode 100644 index 0ad2d2fb..00000000 --- a/recipes-devtools/cmake/cmake_2.8.11.2.bbappend +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | # Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable | ||
2 | # and possibly missing qmake binary (qtbase-native can be removed from sysroot | ||
3 | # e.g. in order to upgrade it, even when there is target qtbase) | ||
4 | |||
5 | do_configure_prepend() { | ||
6 | sed -i 's/^find_package(Qt5Core QUIET)$/#find_package(Qt5Core QUIET)/g' ${S}/Tests/RunCMake/CMakeLists.txt | ||
7 | } | ||
diff --git a/recipes-devtools/cmake/cmake_2.8.12.bbappend b/recipes-devtools/cmake/cmake_2.8.12.bbappend new file mode 100644 index 00000000..ebacf720 --- /dev/null +++ b/recipes-devtools/cmake/cmake_2.8.12.bbappend | |||
@@ -0,0 +1,20 @@ | |||
1 | # Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable | ||
2 | # and possibly missing qmake binary (qtbase-native can be removed from sysroot | ||
3 | # e.g. in order to upgrade it, even when there is target qtbase) | ||
4 | |||
5 | #| -- Performing Test run_pic_test - Success | ||
6 | #| CMake Error at tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:27 (message): | ||
7 | #| The imported target "Qt5::Core" references the file | ||
8 | #| | ||
9 | #| "/qmake" | ||
10 | #| | ||
11 | #| but this file does not exist. Possible reasons include: | ||
12 | |||
13 | do_configure_prepend() { | ||
14 | sed -i 's/^find_package(Qt5Core QUIET)$/#find_package(Qt5Core QUIET)/g' ${S}/Tests/RunCMake/CMakeLists.txt | ||
15 | sed -i 's/^find_package(Qt5Core REQUIRED)/#find_package(Qt5Core REQUIRED)/g' ${S}/Tests/RunCMake/IncompatibleQt/IncompatibleQt.cmake | ||
16 | sed -i 's/^ find_package(Qt5Widgets REQUIRED)/# find_package(Qt5Widgets REQUIRED)/g' ${S}/Tests/QtAutomoc/CMakeLists.txt | ||
17 | sed -i 's/^find_package(Qt5Core REQUIRED)/#find_package(Qt5Core REQUIRED)/g' ${S}/Tests/Qt4And5Automoc/CMakeLists.txt | ||
18 | sed -i 's/^ find_package(Qt5Widgets QUIET NO_MODULE)/# find_package(Qt5Widgets QUIET NO_MODULE)/g' ${S}/Tests/CMakeLists.txt | ||
19 | sed -i 's/^find_package(Qt5Widgets QUIET)/#find_package(Qt5Widgets QUIET)/g' ${S}/Source/QtDialog/CMakeLists.txt | ||
20 | } | ||