summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2014-06-25 09:55:16 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-06 19:45:44 +0200
commita608ef4d63ddc58528eb7defa6a7f89c71ea7033 (patch)
tree84499351a0d5dd52c0dba9092c8080372d2afddc /recipes-devtools
parent59099420054095e2e68d2c562036b60982167ece (diff)
downloadmeta-qt5-a608ef4d63ddc58528eb7defa6a7f89c71ea7033.tar.gz
ninja-native: add recipe
Needed to build qtwebengine. Taken from meta-browser. Signed-off-by: Simon Busch <morphis@gravedo.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/ninja/ninja-native_1.4.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/ninja/ninja-native_1.4.0.bb b/recipes-devtools/ninja/ninja-native_1.4.0.bb
new file mode 100644
index 00000000..a115c2e3
--- /dev/null
+++ b/recipes-devtools/ninja/ninja-native_1.4.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Ninja is a small build system with a focus on speed."
2LICENSE = "Apache-2"
3
4inherit native
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
7
8SRCREV="63d5b1013cafb2db95687cf446eb5bb68cf6a27a"
9SRCBRANCH="release"
10
11SRC_URI = "git://github.com/martine/ninja.git;branch=${SRCBRANCH}"
12
13S="${WORKDIR}/git"
14
15do_compile() {
16 python ${S}/bootstrap.py
17}
18
19do_install() {
20 install -d ${D}${bindir}
21 install -m 0755 ${S}/ninja ${D}${bindir}/ninja
22}