summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-05-02 00:44:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-05-02 00:44:13 +0200
commit6310c5c17380ad5e3bdaf1938e025d713066e7ee (patch)
treea823ea744e8c148d8bc4682b44c34f757885a2ba
parentdcf2ece48ea45336f44e01fd3f93e0efa0a163b6 (diff)
downloadmeta-qt5-upstream/warrior-next.tar.gz
qtdeclarative: fix build with gcc-11upstream/warrior-nextupstream/warrior
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch69
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
2 files changed, 71 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch b/recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch
new file mode 100644
index 00000000..0eb78467
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch
@@ -0,0 +1,69 @@
1From aca2df64cd0cb6c4a8c03dc564c59f2a805dda7c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 4 Mar 2021 14:37:06 -0800
4Subject: [PATCH] Fix build with gcc-11
5
6* squash 2 patches from meta-qt5/master:
7qmldebug: Include limits header
8
9this is needed to solve
10qmldebug/qqmlprofilerevent_p.h:314:65: error: 'numeric_limits' is not a member of 'std'
11
12Its exposed bu gcc11
13
14yarr: Include <limits> for numeric_limits
15
16Fixes
17src/3rdparty/masm/yarr/Yarr.h:46:44: error: 'numeric_limits' is not a member of 'std'
18 46 | static const unsigned offsetNoMatch = std::numeric_limits<unsigned>::max();
19 | ^~~~~~~~~~~~~~
20
21Upstream-Status: Pending
22
23And add <limits> also to src/qml/jsruntime/qv4propertykey_p.h.
24
25Signed-off-by: Khem Raj <raj.khem@gmail.com>
26Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
27---
28 src/3rdparty/masm/yarr/Yarr.h | 2 +-
29 src/qml/jsruntime/qv4propertykey_p.h | 1 +
30 src/qmldebug/qqmlprofilerevent_p.h | 1 +
31 3 files changed, 3 insertions(+), 1 deletion(-)
32
33diff --git a/src/3rdparty/masm/yarr/Yarr.h b/src/3rdparty/masm/yarr/Yarr.h
34index ccf78f9880..cbb42c60d8 100644
35--- a/src/3rdparty/masm/yarr/Yarr.h
36+++ b/src/3rdparty/masm/yarr/Yarr.h
37@@ -27,7 +27,7 @@
38
39 #pragma once
40
41-#include <limits.h>
42+#include <limits>
43 #include "YarrErrorCode.h"
44
45 namespace JSC { namespace Yarr {
46diff --git a/src/qml/jsruntime/qv4propertykey_p.h b/src/qml/jsruntime/qv4propertykey_p.h
47index 47867765db..c945b27498 100644
48--- a/src/qml/jsruntime/qv4propertykey_p.h
49+++ b/src/qml/jsruntime/qv4propertykey_p.h
50@@ -50,6 +50,7 @@
51 // We mean it.
52 //
53
54+#include <limits>
55 #include <private/qv4global_p.h>
56
57 QT_BEGIN_NAMESPACE
58diff --git a/src/qmldebug/qqmlprofilerevent_p.h b/src/qmldebug/qqmlprofilerevent_p.h
59index 1e205d8dbb..f2467bb032 100644
60--- a/src/qmldebug/qqmlprofilerevent_p.h
61+++ b/src/qmldebug/qqmlprofilerevent_p.h
62@@ -47,6 +47,7 @@
63 #include <QtCore/qvarlengtharray.h>
64 #include <QtCore/qmetatype.h>
65
66+#include <limits>
67 #include <initializer_list>
68 #include <type_traits>
69
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index d27450b8..43c1063c 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -27,3 +27,5 @@ do_install_append_class-nativesdk() {
27SRCREV = "36e4e9bbd402cefab9d7b68635a94a02e0b41187" 27SRCREV = "36e4e9bbd402cefab9d7b68635a94a02e0b41187"
28 28
29BBCLASSEXTEND =+ "native nativesdk" 29BBCLASSEXTEND =+ "native nativesdk"
30
31SRC_URI += "file://0001-Fix-build-with-gcc-11.patch"