summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Aittamaa <simon.aittamaa@gmail.com>2016-01-29 09:23:30 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-25 16:19:27 -0300
commitea37a0bc987aa9484937ad68f762b4657c198617 (patch)
tree8ac8f342b45e9cc7143a35e9efc009ec5b90b658
parent9bfcf79fcd824efb9f2a9bd72ecbedfee1315c96 (diff)
downloadmeta-qt5-upstream/jethro.tar.gz
qtbase: Fix installation of fonts and librariesupstream/jethrojethro
This patch fixes three problems 1) Running on a case-sensitive system would result in an error due to invalid casing of pattern to install. 2) Using install on symlinks would cause multiple copies of the same file to be installed on the target-system, since install doesn't preserve symlinks. This wastes a lot of space and it causes ldconfig to complain about non-symlinked files. 3) Leakage of user-ids, i.e. cp -a would preserve the uid/gid of whoever built the files, which is usually not what you want. Signed-off-by: Simon Aittamaa <simon.aittamaa@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 3ef59231..62c0ab59 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -229,10 +229,10 @@ do_install_append() {
229 # install fonts manually if they are missing 229 # install fonts manually if they are missing
230 if [ ! -d ${D}/${OE_QMAKE_PATH_QT_FONTS} ]; then 230 if [ ! -d ${D}/${OE_QMAKE_PATH_QT_FONTS} ]; then
231 mkdir -p ${D}/${OE_QMAKE_PATH_QT_FONTS} 231 mkdir -p ${D}/${OE_QMAKE_PATH_QT_FONTS}
232 cp -a ${S}/lib/fonts/* ${D}/${OE_QMAKE_PATH_QT_FONTS} 232 cp -d ${S}/lib/fonts/* ${D}/${OE_QMAKE_PATH_QT_FONTS}
233 chown -R root:root ${D}/${OE_QMAKE_PATH_QT_FONTS} 233 chown -R root:root ${D}/${OE_QMAKE_PATH_QT_FONTS}
234 fi 234 fi
235 install -m 0644 ${B}/lib/libqt* ${D}${libdir} 235 cp -d ${B}/lib/libQt* ${D}${libdir}
236 # Remove example.pro file as it is useless 236 # Remove example.pro file as it is useless
237 rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro 237 rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro
238 238