summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-07-27 13:04:33 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2020-04-13 13:43:27 +0200
commit180edd66444db330301f22266cac7d588fd48c6a (patch)
tree8bb804a2fe01bf92d13e00e4a3cd0698add6fd88
parent4e46626fced762e2f96b97a2569124597efe11ff (diff)
downloadmeta-qt5-upstream/jansa/rocko.tar.gz
qtchooser: drop useless patch, set PVupstream/rocko-nextupstream/rockoupstream/jansa/rocko
* set PV to something better than just 'git' * drop 0001-Makefile-install-the-man-dir.patch, the change was already applied long before the currently used SRCREV, do_patch WARNING: was correctly complaining: WARNING: qtchooser-git-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch 0001-Makefile-install-the-man-dir.patch patching file Makefile Hunk #1 succeeded at 2 with fuzz 1 (offset 1 line). Hunk #2 succeeded at 79 with fuzz 2 (offset 22 lines). Now at patch 0001-Makefile-install-the-man-dir.patch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qtchooser/qtchooser/0001-Makefile-install-the-man-dir.patch35
-rw-r--r--recipes-qt/qtchooser/qtchooser_git.bb5
2 files changed, 2 insertions, 38 deletions
diff --git a/recipes-qt/qtchooser/qtchooser/0001-Makefile-install-the-man-dir.patch b/recipes-qt/qtchooser/qtchooser/0001-Makefile-install-the-man-dir.patch
deleted file mode 100644
index 8e8e1c69..00000000
--- a/recipes-qt/qtchooser/qtchooser/0001-Makefile-install-the-man-dir.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 3f142e100cc3dd69b816ce79152760c823cb86e9 Mon Sep 17 00:00:00 2001
2From: Li Xin <lixin.fnst@cn.fujitsu.com>
3Date: Fri, 29 Apr 2016 12:41:34 +0900
4Subject: [PATCH] Makefile: install the man dir
5
6upstream-status: backported
7
8Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
9---
10 Makefile | 3 +++
11 1 file changed, 3 insertions(+)
12
13diff --git a/Makefile b/Makefile
14index 20b9100..1fd8cd3 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -1,5 +1,6 @@
18 prefix = /usr
19 bindir = $(prefix)/bin
20+MKDIR = mkdir -p
21 TOOLS = assistant \
22 designer \
23 lconvert \
24@@ -56,6 +57,8 @@ install:
25 case `uname -s` in Darwin) \
26 for tool in $(MACTOOLS); do ln -sf qtchooser "$(INSTALL_ROOT)$(bindir)/$$tool"; done \
27 ;; esac
28+ $(MKDIR) $(INSTALL_ROOT)$(prefix)/share/man/man1
29+ install -m 644 -p doc/qtchooser.1 $(INSTALL_ROOT)$(prefix)/share/man/man1
30
31 uninstall:
32 cd src/qtchooser && $(MAKE) uninstall
33--
341.8.4.2
35
diff --git a/recipes-qt/qtchooser/qtchooser_git.bb b/recipes-qt/qtchooser/qtchooser_git.bb
index e745e8ad..06b1ae91 100644
--- a/recipes-qt/qtchooser/qtchooser_git.bb
+++ b/recipes-qt/qtchooser/qtchooser_git.bb
@@ -1,8 +1,7 @@
1DESCRIPTION = "Wrapper to select between Qt development binary versions" 1DESCRIPTION = "Wrapper to select between Qt development binary versions"
2HOMEPAGE = "http://macieira.org/qtchooser" 2HOMEPAGE = "http://macieira.org/qtchooser"
3LICENSE = "LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | GPL-3.0" 3LICENSE = "LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | GPL-3.0"
4SRC_URI = "git://code.qt.io/cgit/qtsdk/qtchooser.git;branch=master \ 4SRC_URI = "git://code.qt.io/cgit/qtsdk/qtchooser.git"
5 file://0001-Makefile-install-the-man-dir.patch"
6 5
7LIC_FILES_CHKSUM = " \ 6LIC_FILES_CHKSUM = " \
8 file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \ 7 file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
@@ -11,7 +10,7 @@ LIC_FILES_CHKSUM = " \
11" 10"
12S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
13SRCREV = "a1b6736e4f2daf86cd1626004d40ef57db85fbb5" 12SRCREV = "a1b6736e4f2daf86cd1626004d40ef57db85fbb5"
14#PV = "39+git${SRCREV}" 13PV = "39+git${SRCPV}"
15 14
16inherit pkgconfig 15inherit pkgconfig
17 16