diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-02-28 20:56:51 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-17 16:08:56 +0200 |
commit | 5d5ba83cc6eadbff6d60d5ae4947bc9b48d846f4 (patch) | |
tree | 6cbef8286c4d167c13bbdcabbf862b0945a71e17 | |
parent | a376cc61ed00eccd0892936d101a1ecece0e6f3c (diff) | |
download | meta-qt5-5d5ba83cc6eadbff6d60d5ae4947bc9b48d846f4.tar.gz |
qt5-native: rename to qtbase-native to avoid confusion
* we also had PROVIDES for qt5-tools-native, this makes it a bit easier to see what is what
* drop FILESEXTRAPATHS, not needed after renaming to match BPN with qtbase patches
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | classes/qmake5.bbclass | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5.inc | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native.inc (renamed from recipes-qt/qt5/qt5-native.inc) | 3 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch (renamed from recipes-qt/qt5/qt5-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch) | 0 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native_5.0.0+git.bb (renamed from recipes-qt/qt5/qt5-native_5.0.0+git.bb) | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native_5.0.1.bb (renamed from recipes-qt/qt5/qt5-native_5.0.1.bb) | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase.inc | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase/0001-Always-build-uic.patch (renamed from recipes-qt/qt5/qt5-native/0001-Always-build-uic.patch) | 0 | ||||
-rw-r--r-- | recipes-qt/qt5/qtjsbackend-native.inc | 2 |
9 files changed, 7 insertions, 8 deletions
diff --git a/classes/qmake5.bbclass b/classes/qmake5.bbclass index 180cedcf..00d6c0ea 100644 --- a/classes/qmake5.bbclass +++ b/classes/qmake5.bbclass | |||
@@ -3,7 +3,7 @@ | |||
3 | # | 3 | # |
4 | inherit qmake5_base | 4 | inherit qmake5_base |
5 | 5 | ||
6 | QT5TOOLSDEPENDS ?= "qt5-native " | 6 | QT5TOOLSDEPENDS ?= "qtbase-native " |
7 | DEPENDS_prepend = "${QT5TOOLSDEPENDS}" | 7 | DEPENDS_prepend = "${QT5TOOLSDEPENDS}" |
8 | 8 | ||
9 | export QMAKESPEC = "${STAGING_DATADIR}/qt5/mkspecs/${TARGET_OS}-oe-g++" | 9 | export QMAKESPEC = "${STAGING_DATADIR}/qt5/mkspecs/${TARGET_OS}-oe-g++" |
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc index e9b87a0b..97f3ee17 100644 --- a/recipes-qt/qt5/qt5.inc +++ b/recipes-qt/qt5/qt5.inc | |||
@@ -6,7 +6,7 @@ inherit qmake5_base | |||
6 | ICU = "icu " | 6 | ICU = "icu " |
7 | ICU_powerpc = "pango" | 7 | ICU_powerpc = "pango" |
8 | 8 | ||
9 | DEPENDS += "qt5-tools-native virtual/libgl freetype jpeg libpng zlib openssl glib-2.0 ${ICU}" | 9 | DEPENDS += "virtual/libgl freetype jpeg libpng zlib openssl glib-2.0 ${ICU}" |
10 | 10 | ||
11 | require qt5_arch.inc | 11 | require qt5_arch.inc |
12 | 12 | ||
diff --git a/recipes-qt/qt5/qt5-native.inc b/recipes-qt/qt5/qtbase-native.inc index 1aa5c0ce..db1292cd 100644 --- a/recipes-qt/qt5/qt5-native.inc +++ b/recipes-qt/qt5/qtbase-native.inc | |||
@@ -2,7 +2,6 @@ DESCRIPTION = "Native version of Qt/[X11|Mac|Embedded]" | |||
2 | DEPENDS = "zlib-native dbus-native" | 2 | DEPENDS = "zlib-native dbus-native" |
3 | SECTION = "libs" | 3 | SECTION = "libs" |
4 | HOMEPAGE = "http://qt-project.org" | 4 | HOMEPAGE = "http://qt-project.org" |
5 | PROVIDES = "qt5-tools-native" | ||
6 | 5 | ||
7 | INC_PR = "r0" | 6 | INC_PR = "r0" |
8 | 7 | ||
@@ -10,8 +9,6 @@ inherit native | |||
10 | 9 | ||
11 | QT_MODULE = "qtbase" | 10 | QT_MODULE = "qtbase" |
12 | 11 | ||
13 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/qtbase:" | ||
14 | |||
15 | SRC_URI += " \ | 12 | SRC_URI += " \ |
16 | file://0001-qlibraryinfo-Allow-the-specification-of-where-to-loa.patch \ | 13 | file://0001-qlibraryinfo-Allow-the-specification-of-where-to-loa.patch \ |
17 | file://0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch \ | 14 | file://0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch \ |
diff --git a/recipes-qt/qt5/qt5-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch b/recipes-qt/qt5/qtbase-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch index 1b294fd2..1b294fd2 100644 --- a/recipes-qt/qt5/qt5-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch +++ b/recipes-qt/qt5/qtbase-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch | |||
diff --git a/recipes-qt/qt5/qt5-native_5.0.0+git.bb b/recipes-qt/qt5/qtbase-native_5.0.0+git.bb index e99971fb..80d80565 100644 --- a/recipes-qt/qt5/qt5-native_5.0.0+git.bb +++ b/recipes-qt/qt5/qtbase-native_5.0.0+git.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | require qt5-native.inc | 1 | require ${PN}.inc |
2 | require qt5-5.0.0+git.inc | 2 | require qt5-5.0.0+git.inc |
3 | 3 | ||
4 | PR = "${INC_PR}.0" | 4 | PR = "${INC_PR}.0" |
diff --git a/recipes-qt/qt5/qt5-native_5.0.1.bb b/recipes-qt/qt5/qtbase-native_5.0.1.bb index f822a3e3..f5d96130 100644 --- a/recipes-qt/qt5/qt5-native_5.0.1.bb +++ b/recipes-qt/qt5/qtbase-native_5.0.1.bb | |||
@@ -3,5 +3,7 @@ require qt5-${PV}.inc | |||
3 | 3 | ||
4 | PR = "${INC_PR}.0" | 4 | PR = "${INC_PR}.0" |
5 | 5 | ||
6 | SRC_URI += "file://0001-Always-build-uic.patch" | ||
7 | |||
6 | SRC_URI[md5sum] = "720e5061d75913dfa97bf8bef4a443df" | 8 | SRC_URI[md5sum] = "720e5061d75913dfa97bf8bef4a443df" |
7 | SRC_URI[sha256sum] = "6f8a0489eb057f6cba5e77cabaec13dcd010da562b3b88f91fe960022d7c37c8" | 9 | SRC_URI[sha256sum] = "6f8a0489eb057f6cba5e77cabaec13dcd010da562b3b88f91fe960022d7c37c8" |
diff --git a/recipes-qt/qt5/qtbase.inc b/recipes-qt/qt5/qtbase.inc index 2b14de1e..f420d37a 100644 --- a/recipes-qt/qt5/qtbase.inc +++ b/recipes-qt/qt5/qtbase.inc | |||
@@ -8,7 +8,7 @@ SRC_URI += " \ | |||
8 | file://qplatformdefs.h \ | 8 | file://qplatformdefs.h \ |
9 | " | 9 | " |
10 | 10 | ||
11 | DEPENDS += "qt5-tools-native virtual/libgl freetype jpeg libpng zlib openssl glib-2.0 ${ICU}" | 11 | DEPENDS += "qtbase-native virtual/libgl freetype jpeg libpng zlib openssl glib-2.0 ${ICU}" |
12 | 12 | ||
13 | # to provide xcb/xcb_icccm.h, xcb/xcb_image.h, xcb/xcb_keysyms.h and dbus/dbus.h | 13 | # to provide xcb/xcb_icccm.h, xcb/xcb_image.h, xcb/xcb_keysyms.h and dbus/dbus.h |
14 | # DEPENDS += "xcb-util-wm xcb-util-image xcb-util-keysyms dbus" | 14 | # DEPENDS += "xcb-util-wm xcb-util-image xcb-util-keysyms dbus" |
diff --git a/recipes-qt/qt5/qt5-native/0001-Always-build-uic.patch b/recipes-qt/qt5/qtbase/0001-Always-build-uic.patch index 3f2e3fd9..3f2e3fd9 100644 --- a/recipes-qt/qt5/qt5-native/0001-Always-build-uic.patch +++ b/recipes-qt/qt5/qtbase/0001-Always-build-uic.patch | |||
diff --git a/recipes-qt/qt5/qtjsbackend-native.inc b/recipes-qt/qt5/qtjsbackend-native.inc index 8a66229a..37e2b80d 100644 --- a/recipes-qt/qt5/qtjsbackend-native.inc +++ b/recipes-qt/qt5/qtjsbackend-native.inc | |||
@@ -1,7 +1,7 @@ | |||
1 | LICENSE = "LGPLv2.1" | 1 | LICENSE = "LGPLv2.1" |
2 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780" | 2 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780" |
3 | 3 | ||
4 | DEPENDS = "qt5-native" | 4 | DEPENDS = "qtbase-native" |
5 | 5 | ||
6 | QT_MODULE = "qtjsbackend" | 6 | QT_MODULE = "qtjsbackend" |
7 | 7 | ||