summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-15 16:58:45 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-17 00:20:58 +0100
commitfd376e159de6ebcf659a2e083635ca1f244fab30 (patch)
tree2819ad1169e8c4417fdd21add4f4843f1ab837e7
parent7f324f11bbbfe326cbb90edc8efbbe3f4fcc0874 (diff)
downloadmeta-qt5-fd376e159de6ebcf659a2e083635ca1f244fab30.tar.gz
qtwebengine: Fix missing headers found in build with clang
Fixes chromium/third_party/perfetto/include/perfetto/base/task_runner.h:48:55: error: unknown type name 'uint32_t' | virtual void PostDelayedTask(std::function<void()>, uint32_t delay_ms) = 0; Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0011-chromium-Include-cstddef-and-cstdint.patch50
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-Include-cstddef-and-cstdint.patch b/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-Include-cstddef-and-cstdint.patch
new file mode 100644
index 00000000..32dde335
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-Include-cstddef-and-cstdint.patch
@@ -0,0 +1,50 @@
1From c2ca4923d5e534789b205968eb01779a90ec1299 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 15 Jan 2020 16:53:46 -0800
4Subject: [PATCH] chromium: Include <cstddef> and <cstdint>
5
6These headers are needed for uintXX_t and size_t definitions
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 chromium/media/cdm/supported_cdm_versions.h | 1 +
11 .../third_party/perfetto/include/perfetto/base/task_runner.h | 1 +
12 chromium/third_party/webrtc/call/rtx_receive_stream.h | 1 +
13 3 files changed, 3 insertions(+)
14
15diff --git a/chromium/media/cdm/supported_cdm_versions.h b/chromium/media/cdm/supported_cdm_versions.h
16index 3f220da8c71..c54e3bb7d30 100644
17--- a/chromium/media/cdm/supported_cdm_versions.h
18+++ b/chromium/media/cdm/supported_cdm_versions.h
19@@ -6,6 +6,7 @@
20 #define MEDIA_CDM_SUPPORTED_CDM_VERSIONS_H_
21
22 #include <array>
23+#include <cstddef>
24
25 #include "media/base/media_export.h"
26 #include "media/cdm/api/content_decryption_module.h"
27diff --git a/chromium/third_party/perfetto/include/perfetto/base/task_runner.h b/chromium/third_party/perfetto/include/perfetto/base/task_runner.h
28index cf60401238f..02658e7139b 100644
29--- a/chromium/third_party/perfetto/include/perfetto/base/task_runner.h
30+++ b/chromium/third_party/perfetto/include/perfetto/base/task_runner.h
31@@ -18,6 +18,7 @@
32 #define INCLUDE_PERFETTO_BASE_TASK_RUNNER_H_
33
34 #include <functional>
35+#include <cstdint>
36
37 #include "perfetto/base/export.h"
38
39diff --git a/chromium/third_party/webrtc/call/rtx_receive_stream.h b/chromium/third_party/webrtc/call/rtx_receive_stream.h
40index 8ffa4400a9c..a389fc2a574 100644
41--- a/chromium/third_party/webrtc/call/rtx_receive_stream.h
42+++ b/chromium/third_party/webrtc/call/rtx_receive_stream.h
43@@ -11,6 +11,7 @@
44 #ifndef CALL_RTX_RECEIVE_STREAM_H_
45 #define CALL_RTX_RECEIVE_STREAM_H_
46
47+#include <cstdint>
48 #include <map>
49
50 #include "call/rtp_packet_sink_interface.h"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 1a241547..e42cf491 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -162,6 +162,7 @@ SRC_URI += " \
162 file://chromium/0008-chromium-Fix-build-on-32bit-arches-with-64bit-time_t.patch;patchdir=src/3rdparty \ 162 file://chromium/0008-chromium-Fix-build-on-32bit-arches-with-64bit-time_t.patch;patchdir=src/3rdparty \
163 file://chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch;patchdir=src/3rdparty \ 163 file://chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch;patchdir=src/3rdparty \
164 file://chromium/0010-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \ 164 file://chromium/0010-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \
165 file://chromium/0011-chromium-Include-cstddef-and-cstdint.patch;patchdir=src/3rdparty \
165" 166"
166 167
167SRC_URI_append_libc-musl = "\ 168SRC_URI_append_libc-musl = "\