summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-08-15 11:18:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2020-11-03 17:01:34 +0100
commitb39d7973dd8566bd9a6670f29b3a483f182d3395 (patch)
treecfdf9e67363156671f3b4168774dd169cd453f24
parentbca5326e4561960c09a238d01e33ce4794b01d2b (diff)
downloadmeta-qt5-b39d7973dd8566bd9a6670f29b3a483f182d3395.tar.gz
qttools: Force build of native help-tools when clang is set in PACKAGECONFIG
Am working on recipes for kdevelop and musescore. These require native help tools - at least because cmake configs reference them. * Have tried other - patch-less - ways to achieve this without success * Tested multiple combinations with and without clang in PACKAGECONFIG * gcc/clang toolchain with expected result: For clang set, native tools are build for clang misssing tools are not build. * Target build remained unchanged because it was buildung help tools with clang in PACKAGECONFIG * Tried also to add the patch to nativesdk but help tools were not build. Stopped further investigation - that is not a use case for me - sorry Note for clang-toolchain users (confused me a bit - now it's obvious): For qttools-native clang has to be set explicitly in PACKAGECONFIG, otherwise native help tools are not build (same as behaviour as before). Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> (cherry picked from commit f30c4ba364030ad1c92d24c6f5ee3bc7e479dc65)
-rw-r--r--recipes-qt/qt5/qttools/0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch32
-rw-r--r--recipes-qt/qt5/qttools_git.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qttools/0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch b/recipes-qt/qt5/qttools/0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch
new file mode 100644
index 00000000..4bc53c79
--- /dev/null
+++ b/recipes-qt/qt5/qttools/0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch
@@ -0,0 +1,32 @@
1From 88c20560720693b6b30d48af748ab232238f9ac8 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Fri, 14 Aug 2020 21:25:27 +0200
4Subject: [PATCH] Force native build of qt-help tools as qhelpgenerato
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstrem-Statu: Inappropriate [embedded specific]
10
11Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
12---
13 src/assistant/assistant.pro | 6 ------
14 1 file changed, 6 deletions(-)
15
16diff --git a/src/assistant/assistant.pro b/src/assistant/assistant.pro
17index d34b5590..7d87ac48 100644
18--- a/src/assistant/assistant.pro
19+++ b/src/assistant/assistant.pro
20@@ -14,9 +14,3 @@ SUBDIRS += \
21
22 assistant.depends = help
23 qhelpgenerator.depends = help
24-
25-qtNomakeTools( \
26- assistant \
27- qhelpgenerator \
28- qcollectiongenerator \
29-)
30--
312.26.2
32
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 52e2f3c0..ab40a28c 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -19,6 +19,7 @@ SRC_URI += " \
19 file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \ 19 file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \
20 file://0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch \ 20 file://0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch \
21" 21"
22SRC_URI_append_class-native = " ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'file://0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch', '', d)}"
22 23
23FILES_${PN}-tools += "${datadir}${QT_DIR_NAME}/phrasebooks" 24FILES_${PN}-tools += "${datadir}${QT_DIR_NAME}/phrasebooks"
24FILES_${PN}-examples = "${datadir}${QT_DIR_NAME}/examples" 25FILES_${PN}-examples = "${datadir}${QT_DIR_NAME}/examples"
@@ -36,7 +37,7 @@ export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_BINDIR}/llvm-config"
36 37
37EXTRA_QMAKEVARS_PRE += " \ 38EXTRA_QMAKEVARS_PRE += " \
38 ${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \ 39 ${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
39 ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=disable_external_rpath', 'CONFIG+=noqdoc', d)} \ 40 ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=disable_external_rpath CONFIG+=assistant', 'CONFIG+=noqdoc', d)} \
40" 41"
41 42
42SRCREV = "9d5d92a49256af65a85fa69b58e6744c2722321b" 43SRCREV = "9d5d92a49256af65a85fa69b58e6744c2722321b"