summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-03-08 12:33:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-03-13 12:07:25 +0100
commit3e759d827722de6fddc9449f1149137021f4e25e (patch)
tree4b8d5d0c1d70208a9d7df05c6091c6833c56c016
parentf712bf9f8817700d1d6fc663291368df07dacdf1 (diff)
downloadmeta-qt5-3e759d827722de6fddc9449f1149137021f4e25e.tar.gz
qtwebengine: Fix build with ninja >= 1.10.0
* For now just skip version check. Looked into: ninja came from meta-oe to oe-core with: commit fc3aef67a95a90e9a485c6b0e93db8cdeab5d3ab Author: Khem Raj <raj.khem@gmail.com> Date: Thu Jul 27 21:52:12 2017 -0700 ninja: Add recipe llvm is using it, therefore move it from meta-oe Signed-off-by: Khem Raj <raj.khem@gmail.com> That was in rocko release cycle. So the assumption we have a ninja decent enough should be acceptable. * and since the upgrade to ninja-1.10.0 in: commit d1cd957cea29f3ab111ae752bc9ad75a1324c255 Author: Upgrade Helper <auh@auh.yoctoproject.org> Date: Fri Feb 21 14:45:35 2020 -0800 ninja: upgrade 1.9.0 -> 1.10.0 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> the do_configure task fails with: | ERROR: Feature 'webengine-system-ninja' was enabled, but the pre-condition 'tests.webengine-ninja' failed. * Looked into qtwebengine current dev branch: There is no solution yet. So as soon as upstream offers a better solution most likely this patch will not apply any more and has to be removed then. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch39
-rw-r--r--recipes-qt/qt5/qtwebengine/0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch (renamed from recipes-qt/qt5/qtwebengine/0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-musl-link-against-libexecinfo.patch (renamed from recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0005-mkspecs-Allow-builds-with-libc-glibc.patch (renamed from recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb9
5 files changed, 47 insertions, 7 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch b/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch
new file mode 100644
index 00000000..89014da3
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch
@@ -0,0 +1,39 @@
1From 5f5afe275757efe77ff48debb040e08001ea5907 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Sun, 8 Mar 2020 10:51:48 +0100
4Subject: [PATCH] Remove ninja version test for now - it fails for ninja >=
5 1.10.x
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10As long as upstream has no better solution, assume we have a ninja version
11recent enough
12
13Fixes:
14| Found ninja from path: /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/qtwebengine/5.14.1+gitAUTOINC+73d457481c_a9a20127e8-r0/recipe-sysroot-native/usr/bin/ninja
15| + /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/qtwebengine/5.14.1+gitAUTOINC+73d457481c_a9a20127e8-r0/recipe-sysroot-native/usr/bin/ninja --version
16| > 1.10.0
17| Ninja version too old
18
19Upstream-Status: Inappropriate [temporary-hack]
20
21Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
22---
23 configure.pri | 3 +--
24 1 file changed, 1 insertion(+), 2 deletions(-)
25
26diff --git a/configure.pri b/configure.pri
27index 3a144e3f..6c3f29fd 100644
28--- a/configure.pri
29+++ b/configure.pri
30@@ -163,8 +163,7 @@ defineTest(qtConfTest_detectNinja) {
31 !isEmpty(ninja) {
32 qtLog("Found ninja from path: $$ninja")
33 qtRunLoggedCommand("$$ninja --version", version)|return(false)
34- contains(version, "1.[7-9].*"): return(true)
35- qtLog("Ninja version too old")
36+ return(true)
37 }
38 qtLog("Building own ninja")
39 return(false)
diff --git a/recipes-qt/qt5/qtwebengine/0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch b/recipes-qt/qt5/qtwebengine/0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch
index ea536aff..df52bdc8 100644
--- a/recipes-qt/qt5/qtwebengine/0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch
+++ b/recipes-qt/qt5/qtwebengine/0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch
@@ -1,4 +1,4 @@
1From 9f996977ebbb894aa321240cb5590bdae27f14a5 Mon Sep 17 00:00:00 2001 1From 455479c661d2ed39882842a623b0aec29bd3c3d9 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io> 2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Tue, 12 Dec 2017 16:06:14 +0200 3Date: Tue, 12 Dec 2017 16:06:14 +0200
4Subject: [PATCH] musl: don't use pvalloc as it's not available on musl 4Subject: [PATCH] musl: don't use pvalloc as it's not available on musl
diff --git a/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch b/recipes-qt/qt5/qtwebengine/0004-musl-link-against-libexecinfo.patch
index a2dce542..337c14ac 100644
--- a/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
+++ b/recipes-qt/qt5/qtwebengine/0004-musl-link-against-libexecinfo.patch
@@ -1,4 +1,4 @@
1From 7ed387e99975dc25ced3496c7dd98411f11d28e2 Mon Sep 17 00:00:00 2001 1From 507d6323fe871cee981155675cb5ef7cbd253db1 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io> 2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Thu, 14 Dec 2017 11:28:10 +0200 3Date: Thu, 14 Dec 2017 11:28:10 +0200
4Subject: [PATCH] musl: link against libexecinfo 4Subject: [PATCH] musl: link against libexecinfo
diff --git a/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch b/recipes-qt/qt5/qtwebengine/0005-mkspecs-Allow-builds-with-libc-glibc.patch
index 8f25c687..06c659c9 100644
--- a/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch
+++ b/recipes-qt/qt5/qtwebengine/0005-mkspecs-Allow-builds-with-libc-glibc.patch
@@ -1,4 +1,4 @@
1From cde19c7f959ff4ea0d2aa202b9c7a048d3c7200e Mon Sep 17 00:00:00 2001 1From 6d2e83489770c2eae6d15d06ca9c04667140bb84 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 12 Nov 2019 19:53:59 -0800 3Date: Tue, 12 Nov 2019 19:53:59 -0800
4Subject: [PATCH] mkspecs: Allow builds with libc != glibc 4Subject: [PATCH] mkspecs: Allow builds with libc != glibc
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index ea6d0935..6b54efc6 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -145,15 +145,16 @@ RDEPENDS_${PN}-examples += " \
145QT_MODULE_BRANCH_CHROMIUM = "77-based" 145QT_MODULE_BRANCH_CHROMIUM = "77-based"
146 146
147# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.14 147# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.14
148# 5.14.meta-qt5.2 148# 5.14.meta-qt5.3
149SRC_URI += " \ 149SRC_URI += " \
150 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 150 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
151 file://0001-Force-host-toolchain-configuration.patch \ 151 file://0001-Force-host-toolchain-configuration.patch \
152 file://0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch \
152" 153"
153SRC_URI_append_libc-musl = "\ 154SRC_URI_append_libc-musl = "\
154 file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \ 155 file://0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
155 file://0003-musl-link-against-libexecinfo.patch \ 156 file://0004-musl-link-against-libexecinfo.patch \
156 file://0004-mkspecs-Allow-builds-with-libc-glibc.patch \ 157 file://0005-mkspecs-Allow-builds-with-libc-glibc.patch \
157" 158"
158 159
159# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/77-based 160# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/77-based