summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2019-12-30 11:44:21 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-13 23:27:14 +0100
commit254576f9b4b2a6271b4ed25df335c625bd6ef885 (patch)
tree907fb356de0e4fd0832cea161d501095a374c5dc
parent47399df989db21bbc628db6c23c82290d4d82fa5 (diff)
downloadmeta-qt5-254576f9b4b2a6271b4ed25df335c625bd6ef885.tar.gz
qt-kiosk-browser: Add recipe
The Qt Kiosk Browser provides a simple browser which offers a nice set of features for use on a Kiosk device. It supports: - Out of box screen saver - Virtual Keyboard - Highly configurable Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt-kiosk-browser/qt-kiosk-browser/qt-kiosk-browser.conf5
-rw-r--r--recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb32
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser/qt-kiosk-browser.conf b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser/qt-kiosk-browser.conf
new file mode 100644
index 00000000..4f4849b5
--- /dev/null
+++ b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser/qt-kiosk-browser.conf
@@ -0,0 +1,5 @@
1{
2 "URL": "http://github.com/OSSystems/qt-kiosk-browser",
3 "RestartTimeout": 0,
4 "ScreenSaverTimeout": 0
5}
diff --git a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
new file mode 100644
index 00000000..f196ae03
--- /dev/null
+++ b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Qt Kiosk Browser"
2DESCRIPTION = "Provides a simple but highly configurable browser for use on Kiosk devices"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
4LICENSE = "GPLv3"
5
6DEPENDS = "qtwebengine"
7
8SRC_URI = " \
9 git://github.com/OSSystems/qt-kiosk-browser;protocol=https \
10 file://${BPN}.conf \
11"
12
13PV = "0.0+git${SRCPV}"
14SRCREV = "d42b7d9050b5445e2b9430022a46d5d583581631"
15
16S = "${WORKDIR}/git"
17
18inherit qmake5
19
20EXTRA_QMAKEVARS_PRE += "PREFIX=${prefix}"
21
22do_install_append() {
23 install -Dm 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
24}
25
26RDEPENDS_${PN} += " \
27 liberation-fonts \
28 qtdeclarative-qmlplugins \
29 qtquickcontrols-qmlplugins \
30 qtvirtualkeyboard \
31 qtwebengine-qmlplugins \
32"