summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-01 12:21:51 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2020-02-03 13:40:15 +0100
commit0bbd0ebe270388f26fa36b766328221e252a3863 (patch)
tree0a9bc53a4f773a1b450d87b8b87f31f2cbccf7ef
parent239147405e04945e086ce972ff50375bc8259071 (diff)
downloadmeta-qt5-0bbd0ebe270388f26fa36b766328221e252a3863.tar.gz
qtwebengine: Link libatomic on x86/32bit
Fixes CAS link errors Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch32
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch
new file mode 100644
index 00000000..3bf0c5eb
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch
@@ -0,0 +1,32 @@
1From 5b4b896c1c6c79cc7c870a398acf1baf4b6bec7b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 1 Feb 2020 12:17:23 -0800
4Subject: [PATCH] chromium: Link v8 with libatomic on x86
5
6Fixes
7| v8_base_without_compiler_jumbo_47.cc:(.text._ZN2v88internal4wasm12_GLOBAL__N_123ExecuteCompilationUnitsERKSt10shared_ptrINS2_22BackgroundCompileTokenEEPNS0_8CountersEiNS2_19CompileBaselineOnlyE+0x29a): undefined reference to `__atomic_l
8oad'
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 chromium/v8/BUILD.gn | 3 ++-
14 1 file changed, 2 insertions(+), 1 deletion(-)
15
16diff --git a/chromium/v8/BUILD.gn b/chromium/v8/BUILD.gn
17index e21400265dd..7e56609b9da 100644
18--- a/chromium/v8/BUILD.gn
19+++ b/chromium/v8/BUILD.gn
20@@ -3310,7 +3310,8 @@ v8_source_set("v8_base_without_compiler") {
21 if (v8_current_cpu == "mips" || v8_current_cpu == "mipsel" ||
22 v8_current_cpu == "mips64" || v8_current_cpu == "mips64el" ||
23 v8_current_cpu == "ppc" || v8_current_cpu == "ppc64" ||
24- v8_current_cpu == "s390" || v8_current_cpu == "s390x") {
25+ v8_current_cpu == "s390" || v8_current_cpu == "s390x" ||
26+ v8_current_cpu == "x86") {
27 libs = [ "atomic" ]
28 }
29
30--
312.25.0
32
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index ddd5b9f8..ea6d0935 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -170,6 +170,7 @@ SRC_URI += " \
170 file://chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch;patchdir=src/3rdparty \ 170 file://chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch;patchdir=src/3rdparty \
171 file://chromium/0010-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \ 171 file://chromium/0010-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \
172 file://chromium/0011-chromium-Include-cstddef-and-cstdint.patch;patchdir=src/3rdparty \ 172 file://chromium/0011-chromium-Include-cstddef-and-cstdint.patch;patchdir=src/3rdparty \
173 file://chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch;patchdir=src/3rdparty \
173" 174"
174 175
175SRC_URI_append_libc-musl = "\ 176SRC_URI_append_libc-musl = "\